Asrock X370 Taichi + Ryzen 2600 won't POST

Sorry to be a bother, and I have also asked on reddit, so I’m pretty much just copying my post from there in the hopes that some genius on here might be able to help!

PCPartPicker Part List

I’m having some trouble with the above configuration.

Whenever I power the PC on, the result seems to kinda vary. Sometimes it’ll just stick on debug code 13, sometimes 01, sometimes 1F, sometimes 2D, sometimes it’ll look like it’s actually progressing, then give 2 and 4 beeps.
At no point is there any output from the GPU, though sometimes, when it manages to do the beeps, the monitor will get woken up almost immediately before the motherboard reboots itself.
If I have no GPU plugged in, then if it gets to the beeping stage, it will this time beep for 2, 4, then 5.

The debug codes it tends to stop at all relate to memory, as far as the manual says. Though the manual really isn’t descriptive at all - I’m not sure they they couldn’t just ask engineering for what all the 256 different codes actually mean.

I got the motherboard and CPU used, but I have tried with two brand new sticks of RAM - the one listed above, and a 16GB Samsung ECC UDIMM (M391A2K43BB1-CTD), both with the same result.

I’m hoping the issue is just due to a potentially too old BIOS version, but I have no way to tell what the current version is, short of reading directly from the BIOS chip, which I don’t really have the tools to do.

Tried with a single RAM stick. Tried every slot.

Reseated CPU.

Tried two different brand new RAM sticks.

Cleared CMOS more times than I can recall.

Tried with and without GPU.

I recorded 4.5 minutes of attempting to POST

Sorry it’s vertical - I didn’t have a better way to mount my phone.

The CPU did come with some bent pins with some dried paste when I got it, but I straightened and cleaned them up before seating.

Thank you for reading :slight_smile:

My first guess is the bios version as you have pointed out. I did however have an issue with my brother’s build. The ssd was installed above the graphics card. (m.2). It wouldn’t display an image. I troubleshot the ram and remounted the cpu before swapping the m.2 to a different m.2 slot. That took care of my brother’s build issue.

I seriously think it is the bios though. Your taking a year older motherboard with a year newer cpu. The bios needs to be updated to use newer cpus.

1 Like

I really hope it’s the BIOS version. Though I perhaps somewhat naiively assumed that a refurbed motherboard from eBay would already have the latest BIOS installed.

I have the same board and I had the same issue a while ago when I upgraded my BIOS and switched to new RAM sticks. Here are two things to consider:

  1. Are the RAM sticks really in the slot? Are you sure? It does take a considerable amount of pressure on my board to get them in.

  2. Are your RAM sticks on the board’s (or AMD’s) QVL? My old sticks were not and did work for quite a time but after a while my board had the same boot issues.

So, I fixed this issue by correctly mouting QVL RAM sticks

The stick clicks in on both ends, so I don’t think I can get them in any tighter without snapping something.

Neither sticks are on the QVL. The Crucial RAM is only a couple of letters off, and the Crucial site itself says the RAM is 100% guaranteed to work. And I mean, it’s a single stick of 4GB 2400MHz - it’s pretty basic as far as DDR4 goes.

Try reading the manual and figuring out the post codes.

I would take canned air and hit the cpu socket and ram slots with bursts. One little metallic flake is all it takes. I would also make sure the socket and the cpu pins are clean.

90 percent alcohol wipe and tedious pin cleaning.

Ditto on checking the pins. i figured out the problem with my x370 taichi was actually just one amazingly bent pin so that was folded over itself so looking at it from the top showed nothing wrong.

If you bough the cpu recent enough I’d see if you can return it and also just get a 3000 series chip.

Had a B450 board with a bios update for the 3000 series that just wouldn’t seem to post with older chips… although that might have just been my busted as 1700x.

The manual is pretty useless in this case unfortunately. There’s a huge range of numbers that all seem to map to memory issues, and at least one that seems incorrect altogether: the manual says that 55 is shown when no memory is detected, yet I get 4d when there are no DIMMs present.

Yeah, I gave the socket a good blast, and cleaned the pins quite thoroughly with a soft brush.

The pins are all definitely straight - I looked over them slowly from the side with one eye closed :slight_smile:

I would do this, but I got the chip on eBay, and being the moron that I am, I never took photos of the condition the CPU was in when I got it :/, so I can’t really return it.

They are a couple letters off on Crucial’s list? Than this might be the culprit. Honestly, try QVL RAM

Edit: Also, try contacting your seller and ask which BIOS version is/was installed or when the board was purchased.

This is the exact RAM I’m using

I got it from Amazon though, so I’ll try returning it and testing with some QVL RAM.

I did. Unfortunately, they don’t know what the version was :confused:

Interesting, these are the stick I had which aren’t able to boot. When I purchased them, they were not on any QVL, but now they are on Crucial’s. These sticks worked for about a year and after a BIOS upgrade issues started to occur. I’m now using these sticks without any issues.

I’ll switch the stick out for this one.

I’m yet to be let down by Corsair sticks, and this one is 100% on the QVL.

If you’re wondering why I’m going for such low capacity, it’s bacause I want to verify that everything else actually works. The end goal is a FreeNAS machine with ECC. I read somewhere that people had luck with Samsung B-Die, hence why that was the first one I tried.

It’s worth to give it a try. In any case, the red ones I’ve purchased after the Crucial sticks apparently have been removed from Corsair’s QVL, even though I double checked before buying. The reason for this is I purchased different sticks that did not work properly (failed Memtest at anything above 2400MHz). These sticks were LPX 3200 but the appear now on Corsair’s QVL…

And actually, if I manage to confirm that the motherboard does in fact work, I might end up selling it anyway, to switch it for the X470D4U - it seems quite ideal for my purposes. 2x10GbE + 1xIPMI!

So ram causes a lot of extra effort.

Well, I don’t know yet. Replacement RAM will arrive tomorrow!

Almost got that one but couldn’t justify the expense since the cost of a good fibre card and needed cables and such was going to cost as much and I already had a board.

Why would you need a fibre card? Unless you need more than 20GbE, in which case the X470D4U board wouldn’t be the best option anyway.

Well since you are using an Ryzen 2000 series cpu on a X370 board.
Its very likely that you are going to need to update the bios,
before that combo will work.

So that is the first thing i would suggest to do.

X370 and B350 are first gen Ryzen boards.
They will need a bios update to support the Ryzen 2000 series cpu´s.


Welp, QVL RAM produced the same result. Though it happened to stop at code 94 once this time, which hasn’t happened before. Of course that code isn’t documented either though.

Guess it’s time to drop £50 on a 1200 then :expressionless: