Return to Level1Techs.com

ASRock X370 TaiChi Motherboard Review- Ryzen | Level One Techs


#161

I would just unstall the Asrock package drivers for sound and run off what ever stock windows drivers for now or uninstall reinstall until it works correctly :) Normal realtek :(


#162

To be honest - uninstall/reinstall was something I had to do with my Xonar's drivers too :-D I figured that's just the way sound works on a PC...


#163

Once windows stopped uninstalling it , I found it more solid than that. lol I literally prefer the DSP and options.


#164

[Beta] ASRock A-Tuning utility ver:3.0.134

http://www.asrock.com/mb/AMD/X370%20Taichi/index.us.asp#osW1064

Picked this up last night.


#165

As it turns out the Gaming K4 BIOS/UEFI is almost exactly the same as the Taichi with all the same options. I'm just posting this here since I was looking for info about the P-states. Which are totally available on the Gaming K4 btw, I just can't figure out which one is the idle P-state.


#166

Hey Wendell,
I was wondering if you could link the other G Skill RAM you tested. In AMD RYZEN: PART 1 THE CHIP, THE MYTH, THE LEGEND you mentioned that there were two G Skill RAMs you tested and the faster of the two had 16-16-16-36 timings. I did a look through G Skills website and wanted to confirm that F4-3200C16D was indeed the faster one.


#167

New bios :)

http://www.asrock.com/mb/AMD/X370%20Taichi/index.us.asp#BIOS

ASRock A-Tuning Taichi utility ver:3.0.135

http://www.asrock.com/mb/AMD/X370%20Taichi/index.us.asp#osW1064

I do know how i got to the new bios :) but the link works and i flashed it already.


#168

kit/part # listed in validation


#169

I'm using two of these and they seem to work as well:


#170

For anyone looking to get this board, I have one and have gotten to 3000mhz on the RAM using this kit.
http://www.microcenter.com/product/458668/Vengeance_Series_16GB_2_x_8GB_DDR4-3000_PC4-24000_Desktop_Memory_Kit
You need the 1.60 bios to do so. No extra voltage needed for me.


#171

I have the new BIOS 2.0 and cannot get my RAM G.Skill F4-3200C16-8GTZKW to go above 2400mhz with any voltage or settings. Also the XMP does not work... Any ideas?


#172

Step 1. (Because ASRock Boards do weird stuff after BIOS update)
Load Defaults, restart and Clear CMOS.

Step 2. Retry RAM overclock as before

If Step 2 fails goto
Step 3.
Try manually setting the DRAM Voltage to 1.35V that the XMP profile needs. I have seen a similar problem on my X370 Gaming K4.

Step 4.
See about manually setting the CAS latencies a bit looser than the XMP spec (like 20-20-20-40), disable AM4 Advanced boot training and see if it will post. Then reduce the case latencies from there.

If you get a 4F (no post) do a CLR CMOS or if you get a 3f/something code and powercycling there's a XMP issue. You can let it power cycle 4 times and it will get back to the BIOS again. Do a load defaults then and try again. (I recommend disconnecting HDD's to avoid unnecessary spin/stop cycles on them.)

Likely the MAX you should easily be able to get is 2933MHz.


#173

Hi I tried all of these things and same problem. I cleared BIOS to defaults . restart and clear CMOS using the button on the back plate.

XMP does not work even with 1.36V

2666Mhz does not work even after boot with 2400 first and loose timings. Board beeps 3 time, turns off and repeats 4 times then boots with mem 2133... CPU is at 3.9Ghz at all time no issues.


#174

This is with 2 SIngle Rank DIMMS in Slots A2 and B2 correct?


#175

Yes. I am thinking its the memory...


#176

Looks like someone on Reddit had the same issue with your RAM on an older BIOS.

The List:

For A list of community tested Ryzen Memory:

http://rymem.vraith.com/basic/view_by_mobo


#177

Updated Post.

But yes, likely your memory currently just isn't well supported.


#178

The question now is do I attempt to return it or sell it and try another one or wait more... very sad.


#179

With timings of 16-18-18, you do not have Samsung b-die memory which is the variety that has has all the love in bios development to date. If you do return and swap it out. Look for ideally the C14 14-14-14-34 timed memory sku or the 16-16-16 memory which also has had sucess i believe.

In the mean time, Have you tried booting with a single stick of ram and getting that to 3200mhz?

have you tried increasing SOC voltage to 1.2v? If that doesn't help increase to 1.25v and retry. In extreme OC guides that say 1.35 is the absolute max but I would try to stay below 1.3 as extra voltage will also increase temps.

If nothing else it will allow you, by a process of elimination, to determine if one of the sticks is faulty or if it is motherboard settings giving you a challenge.


ASRock x370 taichi & ram
#180

Today I lowered only the timings:

No luck above 2400Mhz though...