Return to Level1Techs.com

ASRock X370 TaiChi Motherboard Review- Ryzen | Level One Techs


#341

Thats a wise decission.
Basically its allways smart to wait wenn a new bios popup,
and see if users are reporting any issues with it.
Next to that if you dont have any issues with the current bios version.
Then probablly its kinda better to stay on it for a little while longer.


#342

Exactly! Waiting to install BIOSes doesn’t hurt in general. That being said, on AM4 I still want new ones because of new AGESA updates and the related improvements :slight_smile:


#343

I tried the 4.80 bios last week, bad things happened…

For some reason it would not allow me to boot from the NVMe in the M2_2 slot.

I tried several things without luck- switched to M2_1, moved stick to an add-in card.
I even booted to a sata drive, formatted the stick and re-installed the OS (ubu mate) but no luck.

I had gone from 3.20 to 3.30 to 4.80.

I also changed a couple of other things at the time, including a new power supply (thought I had fried something on the main board with the new PSU. Was not fun)

It could be because I jumped a couple of bios versions, but rolling back to like 4.64(or whatever intermediate version there was) before throwing in the towel and going back to 3.30.

Would love to hear from others who could update who were booting from NVMe and had no issue?

Like I said, I changed a few things at the same time, so probably did something wrong… But 3.3 works :man_shrugging:


#344

I just watched Buildzoid’s PCB review and towards the end he states that basically everything except Level5 LLC isn’t really useable. Now, this vid is over a year old and I was wonderimg whether this is still the case? Has ASRock been able to alleviate this issue with a BIOS update?


#345

In case ppl are still interested, there is a new BIOS for this board available:

As usually, I’ll wait a while before giving this one a try :wink:


#346

Yeah i tried 5.10 and it seems it started initializing the second slot PCIe GPU at boot.
Now i can’t use my second slot Vega64 for PCIe passthrough. Does anyone know how to disable this?

The new bios is better in almost all other ways.
Memory training bugs have disappeared, memory bandwidth bug is gone.
The only strange thing except for gpu initialization i have found is that it sets vcore to -0.10v by default witch which most often makes systems unstable. Easy to fix if you are aware of it.


#347

Is it only me or is the CSM option gone from 5.10?


#348

Thanks! I’ll still wait for a while though…

Interesting…


#349

So have anyone successfully passed through a Vega with BIOS 5.10?


#350

p state oc seems to work now

auto from main page
pstate 0 clock speed
offset voltage from main page

working :ok_hand:t2:
both clock speed and voltage drops as they should, fucking finally

left boost on, i think there was such setting? but since its working, ill let that be


#351

Regarding my post earlier considering the mainboard’s LLC levels I discovered a comment where a user states (and buildzoid recognises) that he made an error when measuring. Hence, the default LLC of 3 should be fine.

However, to you guys think keeping the LLC at 5 (the lowest setting) will increase the longevity/health of the CPU?