Return to Level1Techs.com

ASRock X370 TaiChi Motherboard Review- Ryzen | Level One Techs


#321

Ya I love my board… since I got the GSKIL FLAREX 3200 14 latency ram…I actually haven’t even over clocked the BCLK yet. I run my 1700 at its hot end 55 degrees at 3.9


#322

Those numbers look very good,
not really much reasons to try to push the memory way beyond that tbh.
The Asrock Taichi at its price point is a very decent board.
The issues that Buildzoid is complaining about, could be caused by soo manny different reasons.
Ryzen still needs some time to mature out.


#323

It seems to me that enabling unofficial AMD overclocking mode from Afterburner causes memory instability, super super weird

I can at least confirm that its not subtimings as 3200MHz boots correctly with identical subtimings with 3466MHz, simple way to describe that weirdness:

Only MHz & CAS and tRFC is changing
3466MHz CL16 = works
3466MHz CL16 & Unofficial OC = doesnt work
3200MHz CL14 & Unofficial OC = works

:man_shrugging:


#324

Yeah its probablly a thing with the imc of a said chip aswell.
Wendell also noted something about that weirdness.
But in all fairness 3200mhz CL14 should be more then fine.
You can go crazy on higher clocked memory kits and try to get the tightest timings possible.
However how much of a realworld benefit is that going to give us?
I dont think that its going to make a mindblowing difference if i´m honnest.


#325

It seems there is a new BIOS out there. Anyone tested it yet?


#326

Nope - it says it’s to (and I quote):

Update AGESA for future coming processors.


#327

Well, ASRock has been sloppy when it comes to update notes concerning their BIOSes.


#328

Agreed - some more detail would be welcome!
Perhaps it’s to support the APUs?


#329

Boot, no xmp
Asrock OC
CPU-Z stress test and benchmark did boost only one core to 3.8

Boot, no xmp
Asrock OC "p-state"
CPU-Z stress test and benchmark did boost only one core to 3.8

Boot, no xmp
AMD OC "p-state"
Windows doing nothing sticks all cores to 3.8

Boot, xmp loaded, manual timings
Asrock OC
Windows doing nothing sticks all cores to 3.8

…ok?

What next?
I should test lower voltage

bonus note
Seems that with Asrock OC mode, manual ram timings open up only after selecting XMP profile
AyyMD OC mode only shows hexes from p-states tab

hopes & dreams section
Would be great to have downclocking CPU
3600MHz or possibly 3200MHz CL12 sticks


#330

Typing them numbers to main page Asrock OC mode does this

Which seems to alter p states 0 and 1, locking that hertz & voltage

Then setting that 1 to auto results as

Which is weird result, its now locked to 3200MHz which doesnt belong to 1700, defaults are 3000MHz & 2700MHz

and to make behavior even weirder, it doesnt boost to 3.8GHz when using the CPU, and CPU-Z score is reflecting that

My conclusion:
Overclocking to 3.8GHz automatically scales these pstates, which is cool
But the thing itself has two bugs

  1. P state 1 locks max overclocks and voltages from P state 0
  2. Simply setting P state 1 to auto fixes above, but it refuses to do P state 0

Wonky untested workaround:
Just rise hertz and keep on disabling state 1, till that thing is 3.8GHz

Confusing bonus remarks:
Voltage seems to be 1.4 instead of 1.36 :man_shrugging:t2:

While reading through thoughts:
Did not check at all that boost setting :man_shrugging:t2:


#331

Got it to work!

  1. AsRock OC Mode
    Overclock
    XMP
    and whatever

  2. Switch to AMD CBS OC
    & toggle p state 1 from custom to auto

and it converts everything to that nutty CBS hex mess, and downclock works after changing that p state 1 to auto


#332

There is yet another BIOS. It’s 4.60 and comes with AGESA PinnaclePI-AM4_1.0.0.1a.

I’ll stick to my usual “policiy” though and wait for a month before installing it. If there are braver folks around, let me know how it turned out xD


#333

Since I’m either blind or a hash is indeed missing I’ve taken the liberty of calculating the md5 hashes of the latest BIOS versions:

693f54d3b5f2d9d7d00ce25d77194503 X370TC3.30
582854af9f27b7d9de81576497b9a833 X370 Taichi(3.30)WIN.zip
7823f4abb0ce8aac59530d0bd0e4b3d5 X370TC4.60

Let me know if there is something wrong with those hashes…


#334

Fine but I do not have on of the cpus that goes along with the update.


#335

I’ve tested the 4.60 BIOS and it does seem to be working fine.


#336

Same here - the v4.60 BIOS also updates the CPU microcode to 0x08001136.

This new ucode seems to add the “ibpb” (Indirect Branch Predictor Barrier) CPU feature (which shows up in /proc/cpuinfo) to assist with speculation mitigation.

[email protected]:~# grep . /sys/devices/system/cpu/vulnerabilities/*
/sys/devices/system/cpu/vulnerabilities/meltdown:Not affected
/sys/devices/system/cpu/vulnerabilities/spectre_v1:Mitigation: __user pointer sanitization
/sys/devices/system/cpu/vulnerabilities/spectre_v2:Mitigation: Full AMD retpoline, IBPB

cpuinfo:

[email protected]:~# cat /proc/cpuinfo | head -28
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 23
model           : 1
model name      : AMD Ryzen 7 1800X Eight-Core Processor
stepping        : 1
microcode       : 0x8001136
cpu MHz         : 2736.748
cache size      : 512 KB
physical id     : 0
siblings        : 16
core id         : 0
cpu cores       : 8
apicid          : 0
initial apicid  : 0
fpu             : yes
fpu_exception   : yes
cpuid level     : 13
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm constant_tsc rep_good nopl nonstop_tsc cpuid extd_apicid aperfmperf pni pclmulqdq monitor ssse3 fma cx16 sse4_1 sse4_2 movbe popcnt aes xsave avx f16c rdrand lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw skinit wdt tce topoext perfctr_core perfctr_nb bpext perfctr_llc mwaitx cpb hw_pstate sme vmmcall fsgsbase bmi1 avx2 smep bmi2 rdseed adx smap clflushopt sha_ni xsaveopt xsavec xgetbv1 xsaves clzero irperf xsaveerptr ibpb arat npt lbrv svm_lock nrip_save tsc_scale vmcb_clean flushbyasid decodeassists pausefilter pfthreshold avic v_vmsave_vmload vgif overflow_recov succor smca
bugs            : sysret_ss_attrs null_seg spectre_v1 spectre_v2
bogomips        : 7199.95
TLB size        : 2560 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 43 bits physical, 48 bits virtual
power management: ts ttp tm hwpstate eff_freq_ro [13] [14]

#337

For 4.70 that previous trick doesnt work, but today I bothered to go through settings and it seems that this time the way is to

  1. AsRock OC Mode
    XMP / whatever timings

  2. AMD CBS
    Set hertz to P state 0, dont touch voltage
    &
    P state 1 to auto
    &
    Offset vcore voltage

Its not downclocking as great as before, but its going down to 1,499.9MHz & 1.050-1.144v +offset


#338

ASRock released a new BIOSes. 4.80 and 4.81 (beta), any experiences so for?
(Personally, I always wait a month before installing a new BIOS, but some other people might not be that patient :wink: )


#339

I think 4.80 may be buggy (for Linux) due to this issue:

ASRock BIOS breaks Linux

Haven’t tried either.


#340

I’ve also heard that the new AGESA causes problems in general, with ASUS even skipping this one. Hence, I’ll skip this BIOS too.