Return to Level1Techs.com

ASRock X370 TaiChi Motherboard Review- Ryzen | Level One Techs


#221

Yeah it wasn't up to his usual standard, maybe just frustrations with his experience showing through.

Waiting is a good idea, let the dust settle first :slight_smile:


#222

Well TTL's motherboard reviews never really interested me all that much tbh.
The main reason for that is that he looks like a Msi fan to me.
He rambles allot, but i miss allot of detailed specific information about vrm implementations,
and that kind of specific stuff.
He just reads whats on the box as far as that is concerned.
And that puts me off from some of his reviews a bit.

As far as bios updates are concerned, Ryzen is a new platform.
So bios updates will come out on the spring to improve the platform.
But in a few months, as soon as Ryzen has settled, there will be less bios updates.
Its really not only Asrock, but basiclly any mobo manufacturer deal with this.
Great thing about Asrock, is that they take the reviewers seriouslly and contact them about it.


#223

I work in customer support so I know what you're talking about. But regarding the stuff he said it was somewhat expected :smiley:


#224

BIOS/UEFI fixes are always welcome as that kind of thing usually is a kinda bad experience. I've had several motherboards that just got abandoned by the manufacturer after a couple of years. Plenty of issues not resolved ofc.


#225

FYI: A new UEFI, v3.0, has just been posted.


#226

Well I can tell you that https://www.newegg.com/Product/Product.aspx?Item=N82E16820104704 the 3200 doesn't work :frowning: ... im having problems with it showing as "single channel memory mode" in the UEFI .. shows both sticks ... shows 16 gb ... but ... boot into windows and I only have 8G of ram .... cant do anything to change this .. it just doesn't work it would seem ... have a ticket with ASRock .. we will see if they reply with any information ... but so far I guess I'm liking the processor and other than the fact that the motherboard doesn't work as advertised ... the hyperx was listed on their site as being compatible ... everything else seems pretty good on it. .. oh and this is with the 3.00 uefi update

If anyone has run into this on their Taichi boards and figured out a way around it .. let me know ... I was able it get it to say dual channel memory mode once when I had the ram in A1 and B1 which is not where they tell you to put it and when I booted into windows I had 16G of ram ... but .. it was only there for one boot and then I tried to change the loadline collaboration and it rebooted several times and was back to single channel when it finally booted .. and I was never able to get it back


#227

I can check tomorrow if it's the same kit but I have a hyperX Predator kit that works great at 2933 but not 3200 . Have you tried 2933 and are you on agesa 1006 with the latest uefi?


#228

I cant even get it to work at 2400 :frowning: ... im running the latest 3.00 UEFI and as I say ... in uefi it shows both sticks but shows single channel memory mode ... and it will boot like that .. in 2400 speed .. but that's it ... if I try the two xmp profiles .. it will just reboot over and over .. then finally boot in 2400 and in windows only will have 8g of ram even though the UEFI and even cpu-z shows 2 sticks in A2 and B2

I have just tried the two profiles .. one is 3200 the other is 3000 which is I believe the 2933 you speak of .. but .. as I say .. it worked once when I saw it saying dual channel memory mode ... but .. that happened once and when the ram was in the wrong slots .. A1 and B1 .. but .. it only was able to boot into the 3200 speed once then I tried to OC the processor to 3600 .. and as soon as I changed the load line calibration .. it went back to single channel mode again ... and would not do the memory OC ... and went back to 2400 and back to 8G in windows ... and I haven't been able to get it to see it as dual channel memory since ... and since .. I cant OC the memory the least bit without it bootlooping and then resetting back to default


#229

Manually specify dram voltage 1.37 volts and soc voltage 1.15v and try that? I haven't tested uefi 3.00 yet


#230

ok .. I tired that .. when you say SOC voltage I couldn't find anything but VDDCR_SOC Voltage .. and that was an offset with no value so if that's the one you were talking about .. woudlnt know the value to offset it so it would be 1.15 ... but I tried setting the dram voltage ot 1.37 ,, after rebooting 4-6 times it finally let me back into the uefi and it showed it was at 1.37 but still the same ... still single not dual and still showing only 8 gig usable ram in windows :frowning: ... maybe 3.00 is a bad UEFI ... you say yours is working with a different version .. do you see a problem with downgrading the uefi? ... if I wanted to try 2.40 which is probably what you are on? ... who knows .. I may have a bad MB .. or RAM or Processor .. with these issues ... its hard to tell and I want to be able to return something if its not working properly :smiley:


#231

According to that screenshot Windows can see all 16GB, it just can't use it. Seems more like a Windows issue then a board issue.

Open Startmenu and type msconfig, go into Boot tab, select advanced options. See what Maximum Memory says. If the checkbox is checked, try removing it first then reboot. If that doesn't work you might try entering your own value for testing purposes.


#232

actually came across that on the net already .. tried it ... it wasn't checked ... I checked the box, it set it to the full ram and I rebooted ... went back to msconfig it was still checked but the value was now at 0 .. and the memory in the system was the same ... and like I said ... I did get it to say dual channel ram once and when it did in uefi .. then when I booted into windows I had the 16g usable ... so something "in the uefi" is causing windows to show the way it is .. because I had changed nothing but that one time I got the ram to show up right in the uefi ... was the one time it shows up right in windows ... but thanks for the reply .. it was a good try


#233

Hm, you said after it showed the full 16GB you tried to adjust something in the UEFI, maybe that screwed some other setting too. Also, have you reset to default UEFI settings after the Update? On some boards with some updates there are some leftovers that can be fixed by loading defaults (or optimized defaults).

Also by any chance do you have a Live-Distro lying around that you could boot to see if the same issue appears under Linux?


#234

I do actually have a distro .. and actually booted into it because lol ... while playing with the uefi I did the software download thing .. but .. realized it was downloading to most likely the EFI partition which is you have no access too .. so I booted into Linux .. and actually forgot to look to see if the ram was the same .. lol DOH... as for the uefi ... I actually unplugged it ... and clear cmos ... and ... I also did the load defaults in the uefi ... and ... I downloaded 3.00 from the website and flashed it through the USB instead of downloading it in the uefi like I first did ..thinking maybe something got goofed in the download ...I will boot back to Linux and see what it says and post back


#235

Yeah .. same issue in Linux


#236

Hm ok, so looks like a board issue afterall :confused: But if they are already in A2 and B2 and reset to defaults there's not all that much I can think of. Can't really be defective RAM either because it wouldn't POST and it wouldn't show 16GB total either :confused:


#237

yeah .. I'm hoping the same thing .. I cant see it being any defective part ... I think its just a uefi glitch that needs to be worked out ... maybe when Wendell tries the 3.00 and sees if he has issues with it ... he will confirm a problem .. and reassure me that going back to 2.40 wont cause any issues ... or I guess I can wait until the next update


#238

Try both sticks individually


#239

Both sticks boot fine and work as 8G sticks individually at stock 2400 without trying to hit the 3200 they are rated at ... didn't try OC'ing a single stick


#240

Its not like you have something better to do that solve ram problems so could as well try that 3200MHz with both and repeat process to all slots :smiley: