ASRock Rack has created the first AM4 socket server boards, X470D4U, X470D4U2-2T

I’d be interested to hear how it goes with your build.

I’m still waiting for my board to be delivered. Here in Germany it is 3 - 5 business days delivered (meaning, nobody has it directly in stock).

Mine has been shipped today (literally just received the shipment notice lol)

ASRock Rack states on their website, that the X470D4U2-2T with BIOS 4.10 would run a Ryzen 5 5500 but it is not! I have to update to the latest beta BIOS 4.14 and with that, you can’t disable SMT anymore. Now I am begging for months for a fix but they never have time…

The X470D4U2 is here and is having RHEL 9.1 prepared to take on the ZFS drives / pool from the current server that it is replacing (a Supermicro X10SLH-F with E3-1246 v3).

Things I see:

  • Yeah, like everyone noticed, there is a tid bit less room between AM4 socket and the nearest DIMM slot (A2) than one is used to.
    I was not able to use the nice Noctua NH-L9x65 cooler that I use for server boards that aren’t running in rack cases, because the heat pipes protrude a few millimeters too far into the realm of the DIMM slot.

Solution: I had the AMD Wraith Prism cooler left over from the Ryzen 7 3700X, which I never used (My motto: If it glows, it goes.) The cooling block of the Wraith however fits PRECISELY, leaving exactly enough room to install a normal height DIMM in the A2 slot.

I replaced the transparent glowing LED fan unit of the AMD Wraith cooler with the Noctua NF-A9x14 PWM fan from the NH-L9x65 cooler. Now nothing glows, and all DIMM slots are available.

  • ECC DIMM compatibility:

I just want to give some feedback for the folks that are looking for feedback on working modules. The following works:

# dmidecode 3.3                                             
Getting SMBIOS data from sysfs.                             
SMBIOS 3.3.0 present.                                       
                                                            
Handle 0x0018, DMI type 16, 23 bytes                        
Physical Memory Array                                       
        Location: System Board Or Motherboard               
        Use: System Memory                                  
        Error Correction Type: Multi-bit ECC                
        Maximum Capacity: 128 GB                                                                                        
        Error Information Handle: 0x0017                    
        Number Of Devices: 4                           

Using 2 of these:
        Manufacturer: Micron Technology
        Part Number: 18ASF2G72AZ-2G6D1   
        Rank: 2                                             
        Configured Memory Speed: 2666 MT/s

And 2 of these:
       Part Number: TIMETEC-ED4-2666    
        Rank: 2
        Configured Memory Speed: 2666 MT/s

On Amazon they are listed as:
"Timetec Hynix IC 16GB DDR4 2666MHz PC4-21300 Unbuffered ECC 1.2V CL19 2Rx8 Dual Rank 288 Pin UDIMM Server Memory RAM Module Upgrade (16GB) "
and
“Crucial CT16G4WFD8266 16GB DDR4 2666MHz ECC DIMM Module, CT16G4WFD8266”

  • Finally I wanted to see if the X470 Chipset SATA ports are any good.

I just did a very basic comparison of the same TOSHIBA MG08ACA16TE HDD hooked up to the X470D4U SATA port (one of the native ports, not the external ASM1061 ports) and then also attached the drive to a port on the LSI SAS3008 HBA that is still in the Supermicro server.

X470 Chipset SATA Port:

LSI SAS3008 HBA Port:

Result: nope, X470 SATA Ports are not going to replace your half-modern HBA. There’s I guess no way to save the 14 Watts that the HBA is pulling with on-board SATA. Oh well.

1 Like

Write caching on the HBA?

Would be interested to see the ASM results, can’t understand why there would be such a big difference without caching getting involved somewhere.

Here is the same Toschiba drive attached to one of the ASM SATA ports of the X470D4U:

The is/was empty (unpartitioned) and in fact new in all three tests (done with the “gnome-disks” program).

The LSI 3008 HBA has 7 other disks on it, so, it has some other stuff going, whereas the X470 currently is still waiting to assume duty and has absolutely nothing going on. The LSI HBA is in IT mode has no caching of its own, but I imagin the latency will be influenced by the fact the card is serving several disks in a ZFS pool at the time that one new drive (not part of any pool yet) was tested…

Anyone know why 4.26 is seemingly stuck in beta? Other boards take priority? Are there any issues with 4.26, is it stable enough to flash?

I have:

I just got the board a week ago, and it has not yet assumed home-production duty yet.

In testing, with RHEL 9.1 with an R5 3600 and 3x NVME (one on a riser in PCIe 6) and 3x Toshiba 16TB HDDs (in X470 SATA as well as the ASM SATA and the HBA) plus an LSI SAS2308 (in PCIe 4) and an Intel I225-LM (in PCIe 5) and 4x 2666 16GB ECC UDIMMs, it has so far been very stable.

I also reduced the PPT to 45 Watts, and that seems to be working just fine too.

For the folks who are using this board:

On the newer BIOS I see the following settings:

PCIE6/PCIE4 Link Width

Does the x4x4x4x4 setting mean PCIe6 x4x4 + PCIe4 x4x4, or does it mean PCIe6 x4x4x4x4 (and then PCIe 4 is left empty)?

I lack a PCIe 4x NVME adapter to test this, but I would be interested in one if it works.
Otherwise the the same effect is ofcourse having two PCIe 2x adapters one each in the upper and lower slot… but you need to know which it is before getting two or just the one card.

Thanks to anyone who has knowledge of how to interpret this option.

And since the discussion was of the long standing BETA 4.26 BIOS, this option and its description are very interesting:

Maybe I should just try it… I was kind of chicken, but surely things will just not work instead of exploding. :slight_smile:

Hey there,

after running the X470D4U stable (with some minor issues) for almost two years, yesterday we got random crashes of Debian Linux during boot. After the crash the Mainboard is dead. It doesn’t do anything when pressing the power button. You’ve to replug the power cord to make it work again.

After a lot of debugging it seems to be an issue with the Seasonic Focus Gold 450W. When temporarily switching to a Corsair CV450 we had lying around the issue seems to be fixed.

The error was always reproducible when using the power cycle feature in the BMC. The board turns off, does a click sound, then does another click sound, turns on for 1s and immediately turns off again with a click sound. This does not happen with the Corsair PSU.

Somebody has an idea what’s happening here? Is this just a corrupted PSU after running 2.5 years 24/7 or is this some incompatibility? I don’t if I should buy a new Seasonic PSU as a replacement or choose another manufacturer.

x4x4x4x4

means if you have a quad m.2 adapter… you can see all 4 m.2’s

if you dont use x4x4x4x4… then you’ll only see 1 m.2 drive.

OK, having had my board for a few months now, I noticed an issue: the system inventory isn’t updated. At all. CPU? Can’t see it. RAM? Vanished. PCIe cards? Nope, nothing to see. The only thing it actually reports is the fan speed. I tried resetting the BMC, no dice: still nowt.

BMC Firmware Version 	2.20.00
BIOS Firmware Version 	P3.50
PSP Firmware Version 	0.9.0.77
Microcode Version 	08001138

My CPU is a R7 1700 (non-X) so updating the BIOS is a no-go option as 3.50 is the latest version supporting 1st gen Ryzen. Same goes for the BMC, really.

Any suggestions solving this before contacting Asrock?

TIA!

Yepp, that was what it ended up being. =)

Interestingly, each and every one of the four NVME connections on the four-way bifurcated x16 slot is in a separate IOMMU group! How cool is that?

IOMMU Group 19 27:00.0 Non-Volatile memory controller [0108]: Sandisk Corp WD Black SN750 / PC SN730 NVMe SSD [15b7:5006]
IOMMU Group 20 28:00.0 Non-Volatile memory controller [0108]: Sandisk Corp WD Black SN750 / PC SN730 NVMe SSD [15b7:5006]
IOMMU Group 21 29:00.0 Non-Volatile memory controller [0108]: Samsung Electronics Co Ltd NVMe SSD Controller SM981/PM981/PM983 [144d:a808]

Very handy, as I can add a fourth NVME and assign it to a VM instead of setting up a whole other motherboard to prepare a new RHEL install for another server that needs to keep downtime to a minimum.

The ASrock board is just cool.

1 Like

System inventory doesn’t work with the beta 4.26 BIOS either… maybe it’ll never work?
But, unless you have tons of servers in use, maybe it’s not such a big deal?

@Apple2c Thx for confirming that. I’ll contact Asrock if this is expected behaviour and/or what we as consumers can do to fix it. Except buying another CPU that is :roll_eyes:

[edit: Asrock was contacted successfully, now awaiting response from their engineers]

Just recently got a X470D4U, noticed the VMedia settings don’t persist when the BMC restarts. Somewhat annoying as I think TrueNAS tried to do SMART tests against the virtual devices and caused a crash. Not 100% on that since I don’t know exactly when the crash occurred other than both time it has happened, the SMART test was scheduled to run during that time frame.

What BIOS are you running? I have just built a system with a 5600G and I do not see the x4x4x4x4 option. I only see the x16. x8x8, or x8x4x4. The board I have come with BIOS 4.20.

@Apple2c Well, I got a response from the engineers: update the BMC. So I did, from 2.20.00 to 2.32.00 and I was unable to connect to the BMC again. I then flashed it back to 2.20.00 as the Linux system that’s installed worked just fine and I could SSH into the system to run the socflash tool Asrock has on their download page for the X470 boards. Fortunately I had the foresight of obtaining all BMC updates including the current one (2.20.00) so it was fairly easy if you know your way on the Linux cli. I then tried 3.02.00 just in case, but unfortunately the BMC was no longer available via the network, again :roll_eyes: The engineers told me my CPU (R7 1700) is too old and the system inventory page was a later addition so it won’t work unless I get another CPU.

Of course, there’s the BIOS as well, but that wasn’t gonna change as 3.50 is the latest version for 1st gen Ryzen (1000 series) CPU’s. So, next question: what CPU do you run as you’re on the Beta version 4.26 (note: BMC and BIOS are different beasts!)

@2FA SMART is not intended for virtual devices, only the underlaying bare metal hardware. So disable SMART on said devices to fix that problem.

Yeah, no kidding it’s not intended… TrueNAS has a “all disk” options which I used as I had disabled the vmemdia devices. They came back though when the BMC rebooted which I didn’t expect.

Hey guys I’ve been banging my head over this for the last few days, hope you can help. I am unable to enter the BIOS setup menu of anything except the motherboard UEFI. Let me explain:

  1. Motherboard UEFI (push Del during POSt) - Success
  2. Ctrl+A for my Adaptec RAID card setup ROM - does nothing
  3. Ctrl+S for my Mellanox Fiber card - does nothing
  4. Ctrl+H on my other LSI Megaraid card - does nothing

I can’t get into any setup ROMs outside the UEFI.

Also, I can’t get the built-in AMD RAID option ROM to show up either!!! I’m trying to use the built-in AMD RAID as well but that also does nothing and doesn’t even show up as a prompt.

I tried disabling UEFI everywhere and setting every boot option to Legacy Only but that still doesn’t work.

Any suggestions??