ASRock Rack has created the first AM4 socket server boards, X470D4U, X470D4U2-2T

Yeah, I noticed in the early part of this thread :wink:

Anyway, the 4500 is part of AMDs effort to cash as much silicon as they can while demand is high, the R3 4100 and R5 4500 are essentially 4000 series APUs with their GPU parts disabled. See the Wiki page. I think these are only available as tray-units, so an additional cooler is required anyway. I have the Cooler Master A30 in mind, pretty small and fits within the socket footprint, so sufficient clearance to the RAM slot next to it, I reckon. Given the server resides in an “ancient” Antec 3U server enclosure with several 120mm case fans, airflow (=cooling) will probably suffice, especially as I don’t intend to run the system 24/7 (that’s where the IPMI comes in handy) or for heavy workloads (where the EPYC based 3151 SoC shines).

As for DDR4, that’s going nowhere any time fast. DDR5 is still in the “early adoption” phase, meaning prices are high, availability not the best and current performance levels leave the early adopters with sub-par memory once manufacturers optimize their DDR5 fabrication processes to reach the higher clock speeds specified for DDR5. Also, AMD has yet to release their DDR5 platform, so expect a surge in pricing then. I suspect DDR4 will remain available for current price levels for at least another 12-18 months. In fact, once DDR5 takes off, I expect a price drop for DDR4 as vendors clear out their inventory/stocks. But what do i know, I only bought my first PC over 2 decades ago for my 28th b-day :face_with_open_eyes_and_hand_over_mouth: (yeah, showing my age here :stuck_out_tongue: ) I might be able to stretch my budget this month and get 2x 16GB instead. My desktop is running 2x 8GB ATM, I may swap these out for the 16GB sticks. Again, not really needed for the workload, but still nice to have.

I’m aware of the limitations the NVMe links on the board have, but it leaves SATA ports free for storage disks. I plan on an 1TB NVMe drive, with 128GB for the OS, 786MB for cache (for the RAID6) and the remainder for wear-leveling. I know strictly speaking I won’t need that, but it’ll improve the lifespan of the device I reckon. PSU will be another ancient Antec device, but it should be server grade anyway (it had 5yrs warranty, long expired though). Besides, Antec Europe HQ is in the next city, so getting some isn’t too difficult :wink:

Interesting! I am trying to do about the same but cant use slot #4 and #6 at the same time! As soon as I plug in the second card both stop working. No matter what bifurcated configuration I use! And, believe me I tried all possible configurations!-/


(Supermicro AOC-SLG3-2M2 expansion card plugged in to slot#4 at the moment )
Anything else you do to get this working?

@Dutch_Master my system has been running 24/7 since May 2019, think I’ve restarted it maybe 20 - 30 times and it’s been fine. Soon to get a much needed RAM and CPU upgrade.

I like the board, the only stupid thing is the non standard AMD socket, how they placed it a few millimeters to close to the RAM. First BIOS’s were kinda clunky as well but seem to be good for the most part now, not that I’ve upgraded since P3.50 & 2.20.00 BMC :sweat_smile:.


On another note.

How does one go about getting IOMMU working for Proxmox?

Was following the guide for Pci passthrough but when I get up to verifiying IOMMU is enabled this is what I get:

[email protected]:~# dmesg | grep -e DMAR -e IOMMU
[    0.234733] pci 0000:00:00.2: AMD-Vi: IOMMU performance counters supported
[    0.239535] pci 0000:00:00.2: AMD-Vi: Found IOMMU cap 0x40
[    0.239785] perf/amd_iommu: Detected AMD IOMMU #0 (2 banks, 4 counters/bank).

The Proxmox guide says it should be something like “DMAR: IOMMU enabled”.

For the sake of sanity can someone tell me what BIOS settings should be changed? I think I got them all but I want to be sure. Assume I’m doing this from scratch :+1:.


Edit, You guys also see in the new Level1Techs video that @wendell finally has one of one of these boards :grin:.

2 Likes

I think he’s had one for a bit (pretty sure i heard him talk about it before), just never did a video on it.

1 Like

Does anyone have successfully run an APU with x470d4u? In kernel message i see
[ 18.726370] amdgpu 0000:30:00.0: BAR 6: can’t assign [??? 0x00000000 flags 0x20000000] (bogus alignment)
[ 18.773413] [drm:amdgpu_get_bios [amdgpu]] ERROR Unable to locate a BIOS ROM
[ 18.773415] amdgpu 0000:30:00.0: amdgpu: Fatal error during GPU init
[ 18.773418] amdgpu 0000:30:00.0: amdgpu: amdgpu: finishing device.
[ 18.795632] ------------[ cut here ]------------
[ 18.795637] WARNING: CPU: 10 PID: 1313 at kernel/workqueue.c:3047 __flush_work.isra.0+0x67/0x80
[ 18.795637] Modules linked in: snd_hda_codec_hdmi(E+) snd_hda_intel(E) fjes(E-) snd_intel_dspcfg(E) soundwire_intel(E) soundwire_generic_allocation(E) snd_soc_core(E) amd64_edac_mod(E) snd_compress(E) soundwire_cadence(E) edac_mce_amd(E) amdgpu(E+) snd_hda_codec(E) ast(E) snd_hda_core(E) drm_vram_helper(E) kvm_amd(E) snd_hwdep(E) gpu_sched(E) drm_ttm_helper(E) ttm(E) soundwire_bus(E) cdc_ether(E) snd_pcm(E) kvm(E) drm_kms_helper(E) snd_timer(E) sp5100_tco(E) irqbypass(E) usbnet(E) snd(E) ccp(E) rapl(E) acpi_ipmi(E) pcspkr(E) wmi_bmof(E) efi_pstore(E) k10temp(E) watchdog(E) soundcore(E) rng_core(E) cec(E) mii(E) joydev(E) ipmi_si(E) sg(E) ipmi_devintf(E) ipmi_msghandler(E) evdev(E) button(E) acpi_cpufreq(E) fuse(E) drm(E) configfs(E) sunrpc(E) efivarfs(E) ip_tables(E) x_tables(E) autofs4(E) zfs(POE) zunicode(POE) zzstd(OE) zlua(OE) zavl(POE) icp(POE) zcommon(POE) znvpair(POE) spl(OE) raid10(E) raid456(E) async_raid6_recov(E) async_memcpy(E) async_pq(E) async_xor(E) async_tx(E) xor(E)
[ 18.795665] raid6_pq(E) libcrc32c(E) crc32c_generic(E) raid1(E) raid0(E) multipath(E) linear(E) md_mod(E) sr_mod(E) cdrom(E) sd_mod(E) hid_generic(E) uas(E) usbhid(E) hid(E) usb_storage(E) crc32_pclmul(E) crc32c_intel(E) ahci(E) ghash_clmulni_intel(E) nvme(E) libahci(E) mpt3sas(E) aesni_intel(E) raid_class(E) igb(E) nvme_core(E) xhci_pci(E) libaes(E) libata(E) t10_pi(E) scsi_transport_sas(E) i2c_algo_bit(E) crypto_simd(E) xhci_hcd(E) dca(E) crc_t10dif(E) cryptd(E) ptp(E) crct10dif_generic(E) usbcore(E) crct10dif_pclmul(E) glue_helper(E) i2c_piix4(E) gpio_amdpt(E) crct10dif_common(E) pps_core(E) usb_common(E) scsi_mod(E) be2net(E) wmi(E) video(E) gpio_generic(E)
[ 18.795684] CPU: 10 PID: 1313 Comm: systemd-udevd Tainted: P OE 5.10.109+truenas #1
[ 18.795685] Hardware name: To Be Filled By O.E.M. To Be Filled By O.E.M./X470D4U, BIOS P4.20 04/14/2021
[ 18.795686] RIP: 0010:__flush_work.isra.0+0x67/0x80
[ 18.795687] Code: 50 65 48 2b 14 25 28 00 00 00 75 24 48 83 c4 58 c3 48 8d 7c 24 28 88 44 24 07 e8 74 f2 81 00 0f b6 44 24 07 eb d6 0f 0b eb d2 <0f> 0b 31 c0 eb cc e8 fe 4e 81 00 66 66 2e 0f 1f 84 00 00 00 00 00
[ 18.795688] RSP: 0018:ffffb87c41047b18 EFLAGS: 00010246
[ 18.795689] RAX: 0000000000000001 RBX: 0000000000000000 RCX: ffff91d78fbfe3f8
[ 18.795689] RDX: 0000000000000001 RSI: 0000000000000001 RDI: ffff91d786a45698
[ 18.795689] RBP: 0000000000000001 R08: 0000000000000000 R09: ffff91de9ecb0710
[ 18.795690] R10: ffffb87c41047908 R11: ffff91de9f2b9fe8 R12: ffff91d786a45698
[ 18.795690] R13: ffff91d78fadc740 R14: ffff91d786a40000 R15: 0000000000000000
[ 18.795691] FS: 00007f5b7ff518c0(0000) GS:ffff91de9ec80000(0000) knlGS:0000000000000000
[ 18.795692] CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[ 18.795692] CR2: 00007fe0ddc14024 CR3: 0000000108388000 CR4: 0000000000350ee0
[ 18.795693] Call Trace:
[ 18.795698] ? try_to_grab_pending+0xd5/0x180
[ 19.083376] __cancel_work_timer+0x102/0x190
[ 19.083378] ? __flush_work.isra.0+0x35/0x80
[ 19.083380] ? del_timer_sync+0x67/0xb0
[ 19.083384] ttm_bo_lock_delayed_workqueue+0x11/0x20 [ttm]
[ 19.083460] amdgpu_device_fini+0x35/0x4a6 [amdgpu]
[ 19.083527] amdgpu_driver_load_kms.cold+0x35/0x57 [amdgpu]
[ 19.115837] amdgpu_pci_probe+0x114/0x1a0 [amdgpu]
[ 19.115841] local_pci_probe+0x42/0x80
[ 19.125965] ? _cond_resched+0x16/0x40
[ 19.125969] pci_device_probe+0xfd/0x1b0
[ 19.125971] really_probe+0x222/0x480
[ 19.125973] driver_probe_device+0xe1/0x150
[ 19.125973] device_driver_attach+0xa1/0xb0
[ 19.125974] __driver_attach+0x8a/0x150
[ 19.125975] ? device_driver_attach+0xb0/0xb0
[ 19.125975] ? device_driver_attach+0xb0/0xb0
[ 19.125976] bus_for_each_dev+0x78/0xc0
[ 19.125977] bus_add_driver+0x12b/0x1e0
[ 19.125978] driver_register+0x8b/0xe0
[ 19.125979] ? 0xffffffffc1205000
[ 19.125981] do_one_initcall+0x44/0x1d0
[ 19.125983] ? do_init_module+0x23/0x240
[ 19.125984] ? kmem_cache_alloc_trace+0xf5/0x200
[ 19.125985] do_init_module+0x4c/0x240
[ 19.125987] __do_sys_finit_module+0xb1/0x110
[ 19.125989] do_syscall_64+0x33/0x80
[ 19.125990] entry_SYSCALL_64_after_hwframe+0x44/0xa9
[ 19.125992] RIP: 0033:0x7f5b8040a9b9
[ 19.216650] Code: 00 c3 66 2e 0f 1f 84 00 00 00 00 00 0f 1f 44 00 00 48 89 f8 48 89 f7 48 89 d6 48 89 ca 4d 89 c2 4d 89 c8 4c 8b 4c 24 08 0f 05 <48> 3d 01 f0 ff ff 73 01 c3 48 8b 0d a7 54 0c 00 f7 d8 64 89 01 48
[ 19.216651] RSP: 002b:00007ffce44b0158 EFLAGS: 00000246 ORIG_RAX: 0000000000000139
[ 19.216652] RAX: ffffffffffffffda RBX: 0000564b0bdf7a10 RCX: 00007f5b8040a9b9
[ 19.216653] RDX: 0000000000000000 RSI: 00007f5b80595e2d RDI: 0000000000000012
[ 19.216653] RBP: 0000000000020000 R08: 0000000000000000 R09: 0000564b0be00530
[ 19.216653] R10: 0000000000000012 R11: 0000000000000246 R12: 00007f5b80595e2d
[ 19.216654] R13: 0000000000000000 R14: 0000564b0bdb24c0 R15: 0000564b0bdf7a10
[ 19.216656] —[ end trace a4c52714855b0e6f ]—
[ 19.222159] amdgpu: probe of 0000:30:00.0 failed with error -22

Does anyone have successfully run an APU with x470d4u?

Yes, I for example had a 2000 series APU working on my board. (Regular X470D4U - not the 2-2T)

Just wonder, do i have to enable some special options in bios? Actually i am running truenas scale alright, just i cannot enable GPU accerated ffmpeg.

Search for IOMMU, enable it if it isn’t.

Did you end up trying the 1700 on X740D4U? I’m in a similar situation as I recently swapped my 1700X with a 3800X on my main PC and currently looking into rebuilding my little home server utilizing the 1700X. Previous home server setup was also FM2+ where I then tried to downsize to an ASrock J4205-ITX. Oversight on my part as it is currently maxed out with a couple VMs so now looking into a rebuild.

I see support for first gen Ryzen on the spec page but no 1000 series are listed on under the CPU support list. I did see a serve the home review where they had success with a Ryzen 1600 so I guess it should work.

Not yet. My limited finances dictate a long-ish term approach, so I recently got me a R5 4600G APU (Renoir based) to replace the 1700 in my desktop as well as 2x 16GB RAM sticks. It’s a step-down in terms of cores (and threads) but it allowed me to (finally!) ditch the GT710 GPU I had to use. The board is still on hold, I’m hoping to be able to purchase it next month. Having said that, prices have gone up recently (what hasn’t! :rage: ) so the aforementioned Gigabyte 3151 SoC board is increasingly becoming attractive again, despite its high(er) cost. It is probably better suited for the intended workload and has more high-bandwidth connectivity, despite its smaller size, being based on EPYC. As I have a 2nd server enclosure (2U instead of 3U for the main storage machine) I may reallocate the X470D4U board to this smaller chassis, maybe running distcc instances or something. Not decided yet.

From what I learned in this thread Asrock unofficially supports the Ryzen 1000 series up to and including BIOS 3.50, the 4.xx series BIOS has ditched the 1000 series in favor of the 5000 series CPU’s.

HTH!

Yeh, from what I have read so far it seems that it should work. Currently trying to decide between the X470D4U or repurposing the Asrock X370 taichi in my current PC which gives a good excuse to swap to a X570 taichi on my PC. The X370 taichi has all the connections I need, especially the 10 SATA ports and I already have all the external pci cards like dual Nic etc to repurpose. In terms of spending, the X570 taichi is currently cheaper than the X470D4U but getting IPMI for that price is very tempting…

Hello everyone!
Im currently specking out a build around this board the X570D4U-2L2T version if I can ever find it in stock any where. Ive got a few questions about ram and the cpu cooler Im thinking of using.

First off this build is going to be my all in one home server. I want to run proxmox as a base and then run truenas, a few game servers, a few home services (think home assistant and plex stuff like that), and a few other home lab things as well. Ill be using pci pass though for a few things, namely the hba card and the gpu when it gets added to the system.

Proposed build:
cpu: ryzen 9 5950x
cpu cooler: Noctua NH-D15
memory: 64 or 128G
hba/raid: 3ware 9650se-8lpml in jbod mode. eventually this will be upgraded to a hba that supports 24 drives instead.
gpu: future upgrade something close to a p4000 for transcoding/editing
boot drive: Samsung 980 500GB M.2 (or something similar, a m.2 drive of some flavor)
storage drives: some super old seagate 2tb drives I have laying around. will add more drives later on
That last pci 1x is likely going to be used for a tv tuner
PSU: EVGA P2 1000 W
case: fractal meshfy 2 XL (plan on maxing out the drives here over time)

Questions about components:

  1. Is this cooler going to fit if I use all 4 ram slots? I did some scrolling in this thread and saw that there was one person using it. They also had stands for it as well are those really needed? I dont believe I would be able to use them since I would have pci cards in the way.

  2. From what I read of the user manual 2 slots is fine for 3200 but if you use 4 slots it drops down to 2666. I have heard that ryzen loves fast dual rank ram and I think I will need a lot of it even if I just start off with 2x32gig sticks due to budgeting. Has any one done any benchmarks on how much the slow down actually effects performance?

  3. About ram it seems like the KSM32ED8/32ME has been marked EOL(and I cant find any to buy) being replaced with KSM32ED8/32HC. The HC version is not on the qvl list but has any one had this work for them? It seems from the posts here that this board and ecc ram seem to be … finicky. With how expensive the ram is I would like to buy something that is known to work if possible. If any one has suggestions for other ecc ram Im open. Im pretty new parting out ‘server’ parts so Im sure there is a ton of brands Ive missed the qvl list is quite short for his board though.

Currently looking for a low profile cooler for this board. As for clearance I plan to get some Nemix ECC sticks which seems to be standard height.

I was looking at the open air bench/X470DU setup Wendell had in the forbidden router series. Does anyone know which scythe cooler he used? Initially I thought is was the Scythe Shuriken 2 but the fan looks like a 120mm size, so I assume it’s the BIG SHURIKEN 3?

I’m running a 5750G with working ECC RAM. I’ve also tried a 5700G with the same RAM (so ECC was actually disabled).

[Solution below!!!]

Anyone ever tried GPU passthrough with Proxmox on X470D4U? After OS bootloader EFI loaded, display outputs to dedicated GPU even if there’s no cable connected.

The primary GPU is already set as Onboard D-SUB in setup.

===

Edit: It turns out that CSM must be enabled for Sapphire RX580, or the above symptom will bother you!

Quick update: the dice has been rolled, I’ve (finally!) ordered my board. At just over 300 euro it’s not exactly cheap, especially for an X470 board. And that’s with free shipping! It’s not in stock at the vendor, but the manufacturer has stock, according to the vendor website. Takes 2-7 business days, so that’ll be about 2 weeks. I hope… :roll_eyes:

(for those readers in USA/Canada/etc: in Euro-land, suppliers must display the total price the customer pays, mandated by Law. Hidden fees, unreadable small print, etc are illegal. Shipping though is usually applied separately, and as the shop I ordered from has a brick’n’mortar store they offered a pickup option. Both were free, so guess which one I choose :stuck_out_tongue: Webshops usually have a flat-fee rate for smaller items although the rate increases when products get bulky)

Small recap on it’s future use: it’ll have a Ryzen 1700 (non-X) and 2*16GB RAM, running Linux from a conventional Samsung 2.5" SATA SSD with an 8TB RAID1 (2nd drive still to purchase) as secondary backup server. I’m also considering running a build-server on it for Funtoo, perhaps on some VM’s. The system will be housed in a (re-used) 2U rack enclosure with a 500W ATX PSU, but it won’t be running 24/7. I may even try making an FTP server for Linux boot images.

1 Like

So . .anybody try the Ryzen 7 5700x on the X470D4U yet?

Am I right in saying that this board only supports PBO and not PBO2 ?

I was specifically looking at limiting max temperature through the settings offered for Ryzen 5000 series.

For now I’ve just set PPT to a lower value in order to reduce power and thus heat generation.

It depends on which BIOS you are on. Some are very upfront and newer ones are buried.

But this board only support PBO NOT PBO2.

So what does ASRock have against proper ATX? I like the idea of an R7/R9 server board, but I need a few more PCIe slots.