Return to Level1Techs.com

ASRock Rack has created the first AM4 socket server boards, X470D4U, X470D4U2-2T

CRS326-24S+2Q+RM looks like a heck of a switch, and for less money than I expected. I bet it has noisy fans though.

If you want to use the web interface and you don’t need really advanced networking features, I suggest you make it boot into SwOS. Modern MikroTik switches can dual-boot between RouterOS, which is extremely complex, and SwOS (SwitchOS) which is much, much simpler. I’m not sure how that affects their management software though.

1 Like

I changed the installed 3 OEM fans on the back to a total of 5 Noctua NF-A4x20 PWM fans.

Obviously the 3 on the back pushing air out. On top of that I added 2 fans pulling air in to the PSU side of the chassis where there are small holes in the side panel. Just wanted to be on the safe side since a ServeTheHome review of that switch mentioned that 3 Noctua fans might be too little to handle the 69 W theoretical total load of the switch.

The board has 4 PWM fan headers (so only 3 are used by default), the 2 extra fans are powered with an Y fan adapter using the extra fan header. The Noctua fans spin up reliably and even with 5 of them at full speed compared to 3 by default the noise is much more bearable.

Also, they are not triggering the red fault LED at the switch’s front (read a couple of times that after-market fans could lead to that when modding switches).

But I would never put such a switch next to my desk, I would rather make absurd custom-cooling solutions voiding any warranty before taking that kind of noise permanently.

I just want to note, as you are a new user, if you do @ and then a username it’ll pop up in that person’s notifications. If you highlight text, you can quote it with the popup quote button.

Good luck!

1 Like

After disabling PFEH, I’ve just tried running memtest86 and memtester on Linux (kernel 5.4 and kernel 5.6) with unstable memory settings. The result is “as I feared”… No corrected errors were detected. I did manage to detect an uncorrected error on Linux for the first time (usually Linux just crashes and reboots).
But that doesn’t really help us any further, as you can get those with non-ECC memory too…
Atm it seems like, although it should be possible, Asrock Rack didn’t correctly implement ECC in their BIOS.

I’ll also try sending them a new mail with our updated findings when I find the time.

That’s a bit of a bummer if true. I had it in the back of my mind to get some ECC memory down the line.

This board is still going strong in my case - I’ve finally got around to migrating to Ubuntu Server 19.10 from Windows Server 2019.

BMC Fan controller doesn’t work at all. All Fans stuck at the same speed.

It took me a while to notice this, I wasn’t paying attention. Anyone else this problem?
There are no default values set for fan control, and I don’t see any setting for fan control either.

BMC firmware 1.90
qaDG36oYt8

Hello! I am writing with the help of a translator, so do not scold. This motherboard worked for us for a month, and when the system rebooted, it just stopped loading. Nothing is displayed on the monitor; the debugger dr.Debug shows error 88 (the instruction does not even have such a code). We tried all the options, resetting the CMOS and even the processor set another, nothing helps. Maybe you have an idea what is the reason? This board is not being sold anywhere, I think the repair will also be delayed, and the server is very necessary in the conditions of the COVID-19 virus.

My noctua fans seem to be spinning down okay…
image

The fans that came with the case seem to be at full speed though. :thinking:

Weird inconsistencies between fan speeds (FAN1 is CPU fan)
image

Have you got any response from AsRack regarding ECC reporting issues?

Did you also try removing the CR2032 battery for about 10 min or did you perform a CSMOS reset by jumper/switch?

I had one unit (just RMA’d it a short time ago) where such a thing also happened and (external) reflashing the BIOS and BMC flash chip helped.

I finally rma’d it since it corrupted the BIOS/BMC images every few weeks.

Have another unit that has been operating reliably hardware-wise within the limitations of the buggy firmware since last July.

@aBav.Normie-Pleb Would you go with these boards again despite all the issues if you need another motherboard?

Yes, since I’ve decided to move away from Intel if possible and there is still no other AM4 board with proper IPMI remote control on the market (I don’t consider the ASUS Pro WS X570-Ace to have proper IPMI remote control).

Also, I enjoy having ECC and Intel’s Xeon prices are still shitty and you don’t know how many mitigation patches are going to pile on top of each other in the future that are further reducing their performance.

Maybe with Milan there’s going to be a wider range of motherboards from more “seasoned” manufacturers/BIOS developers that are more usable for a homelab situation.

Really sucks we dont get more options

1 Like

Noop.

I have FreeNAS 11.3-U1 installed and it becomes unresponive every 24 hours or so… while troubleshooting the issue I discovered an oddity with the date/time in the IPMI settings. The time seems to randomly adjust itself by some random amount (most frequently to UTC). I’ve tried changing the NTP servers, completely turning off auto-update date/time, and everything in between. The BIOS date/time matches what shows in the IPMI when it changes. No other settings in the BIOS/IPMI change so I feel like it shouldn’t be the CMOS battery.

Any ideas?

I’m using an NTP server in the local network that seems to work - did you try this or are you using one of the many public NTP servers on the internet?

So I’ve been looking at these for a long time. . Finally decided to purchase a 1600AF. Was just going to use a b450/x470 board to save a couple of bucks but most of them have some type of limitation. Been leaning more towards this board.

My use case is for Unraid. Would love to have ipmi but it’s not absolutely necessary. Server will be in my basement. Don’t really plan on using Plex, but maybe. Just want NAS and some Dockers and VMs.

My question is this. After reading all the issues in this thread where do we stand with everything? What still does/doesn’t work? Trying to decide between one of these or maybe a x470 taichi (in case I want to switch it to a gaming PC later on to replace my 5820k).

An another questions, where were you lucky to get one of these boards in EU? I see Scan.co.uk for a ridiculous price and a bit better price at Lambda-Tek.com, but that is all I could find and both offers are out of stock.

Another thing I was thinking about, what about VRM temperatures? From photos it looks…subpar.
Also, was memory support (maximum frequency when running 4 sticks of RAM) improved with time and BIOS revisions?

After these new findings, I brought Asrock Rack in contact with AMD US (because AMD TW wasn’t helping them). I didn’t get an update yet since then… I’ll post it once I get something worth posting :wink:

Can anybody confirm that the the X470D4U’s backplate is glued to the motherboard?!

Finally got my second unit back from the retailer RMA process and wanted to test the low-profile Noctua heatsink with a 3700X.

Unscrewed the four srews securing the two heatsink brackets but the backplate doesn’t move a bit. When looking closely you can see some “goo” between the backplate and the PCB.

Is this normal?!

Edit: Yes, the entire surface of the backplate is covered with double-sided sticky tape.

Heated the board to about 60°C for ten minutes, then I could wedge a plastic spudger between the PCB and the backplate and slowly lift the backplate from the PCB.

Are all AM4 backplates like this? Was my first time removing a non-Intel backplate.