Return to Level1Techs.com

ASRock Rack has created the first AM4 socket server board

amd
server
ryzen
#81
  • Right now my only complaint is I can’t get the VGA out to work, but the IPMI’s KVM basically fills that role. Plus I’m using an old VGA monitor with a cable I’m not 100% sure if works so take that with a grain of salt.
  • The BIOS/UEFI looks like a standard no-frills UEFI, a better way to view all it’s options is to view the manuals available on their website.
  • I haven’t messed around with features like Image Redirection and Remote Media, but the interface for those seems to be pretty simple.
  • The built-in Dr. Debug hex display was useful when it hung entering into the UEFI Setup the first time, just did a reset and everything worked.
  • I haven’t timed it, but disabling CMS/Legacy boot sped up boot times quite a bit.
  • FreeNAS works, but I didn’t have doubts about that.
  • I have 6 of the 8 SATA ports used, works well. Intel Optane NVMe boot drive works as well.

Not really sure what else, feel free to ask me questions and I’ll my best to answer.

Update: VGA works, possible my connections weren’t tight enough.

3 Likes

#82

Hitting the rack as it’s approaching bedtime for me but I’ll ask first thing in the morning. Going to edit this post so keep a look out.

1 Like

#83

This is a LOW END server board.

Chances are most deployments of it will not have 64 GB, will not use multiple M.2, will probably have 4 or less SATA drives connected to it, will not need 10 GbE, etc.

Think: home user home-lab, small business NAS/print server, etc.

Think “under 1000 dollar” server build in its entirety at the low end, and small home lab build at the high end.

Ryzen 3000 series on this sort of board will kill a lot of the need for TR4 in a home lab scenario IMHO.

0 Likes

#84

While this may be a low end board, I would guess a lot of these will end up with 64gb of ram and more then 4 sata devices. How do I know this because people going to this board are doing it for the igpu and ipmi, else there is no reason to get it when the regualar boards support ecc.

Highly disagree these dont have enough lanes, while it will remove some it wont remove all of the need.

2 Likes

#85

I would agree, but for someone that’s been using desktop boards in their servers it’s a welcome change. I definitely think it’s a niche product, but I’m apparently in that niche and love the features it offers.

2 Likes

#86

Sorry it has taken so long to get back to this thread. Busy weekend.

  1. Is the VGA output just not able to send any signal or is there a defect in the connections? What do you do think would be causing that?

  2. Have you had a chance to really dig into the BIOS yet and see which features are on by default or if there is any RAID interface?

  3. Any chance of any other hardware use through PCIe slots yet?

  4. Any hiccups in first booting up or using a feature?

Also how confident are you in this board? Do you think that this could be a good contender in the market or is ASRack putting this out there as a “feeler”?

0 Likes

#87

doubtful that vga works if there is not a cpu installed that has an igpu

0 Likes

#88

It has an ASpeed AST2500 on board, so it should not need any integrated or PCIe vga.

0 Likes

#89

Should it work for more than the ipmi?

0 Likes

#90

The datasheet suggests the chip supports it, not sure if it is implemented to work though.


If I am reading the manual right, it should work.

2 Likes

#91

I had disconnected the monitor after it initially wasn’t working, but just tested it again using the same cable and everything worked right away.

I haven’t messed around much with the BIOS, I got the system booting and have left it alone. I will say the 2666Mhz RAM I got from their QVL list is only running at 2400Mhz, I haven’t messed around with overclocking it. I also haven’t messed with any built-in RAID because I would rather use something like ZFS. If you want information on these, a better source would be their manual downloads. They’ve got one for the board, IPMI, and RAID.

Not sure what you mean? I have one of these in a PCIe slot.

First boot took a quite a while then hung on a hex code 62 according to Dr Debug. Not sure if it had anything to do with it being a PVT board, but I followed the manual and did a reset. It booted just fine after that.

I’m not really sure what you mean by this, but the build quality is as good as any other I’ve used. I didn’t see any after manufacture changes to the board.

In my opinion this is a very niche product. Unless they get a lot more demand than expected I doubt there’s going to be any any more. So I guess a “feeler”?

1 Like

#92

Thanks for the reply! I’m still waiting for it to hit a retailer before I buy but this is definitely on the list.

0 Likes

#93

Do you have a wattmeter/ups? What’s the power usage under idle/load (with only OS disk).
I’m presuming you are using the 1700X you mentioned.

0 Likes

#94

I actually have a 1700 in it. I also own a Kill-A-Watt, so if you’re still interested I can do an idle monitor, but with just an OS disc I won’t have something like Plex to do the under load tests.

3 Likes

#95

I’m just curious about the idle power usage of the base system, that way I can compare it to the other processor options. I’m less concerned about load power, because if I’m doing work then it is what it is, and frankly literally anything else will be a significant upgrade

My own use case for such a board is mainly to control a bunch of drives with ZFS the majority of the time (which any 4+ core cpu can handle fine), with some occasional hosting of VM’s/containers and moderate workloads. But the majority of the time it’ll be idle, and the disks should be the majority of the power usage. I’m still weighing the potential cpu options

I’m currently using my old primary computer as my NAS. It’s an Athlon X4 860K/A88X-Pro(refurbished) I got for a bargain bin price. I was initially skeptical that it would hold up, but it’s really earned it’s gold color scheme. However lower power consumption, ECC and IPMI are definitely inclining me to retire the A88X to backup duty.

1 Like

#96

I heard that this board will only work with Ryzen 2nd gen procs. You might want to verify that the 1 gen will work with it just to be safe.

0 Likes

#97

I’ve been running this for nearly 2 weeks now with a 1700. It’s also supposed to support 3rd gen with a BIOS update.

3 Likes

#98

I have been incredibly busy as of late so I haven’t had the time to take down the system and try it without any drives. I can tell you I have one of these connected as a UPS and even with all of it’s drives connected as well as a cheap 5-bay external USB DAS, UniFi Security Gateway, and UniFi 60W 8-port switch with 2 APs powered off of it and while idle it’s only registering the first bar of load on the LCD.

In all honesty I doubt a motherboard affects power usage much, so if you just look at idle power usage of the Ryzen’s and whatever hardware you’re going to run you’ll be in the same ballpark.

Edit: This is the most stable my NAS has ever been. I’m unsure if it has to do with ECC RAM, the new Motherboard, or FreeNAS updates, but I’ve yet to have the system freeze like it used to on a fairly regular basis. The only thing I feel this motherboard is lacking are USB ports, but those could be added with a PCIe card.

1 Like

#99

Looks like Newegg have it listed for $250 USD, not a bad price really providing it does actually do a good job and last a long time.

I also contacted ASRock Rack to ask about Australian availability and was told mid April, it’ll cost $380 AUD + GST and be availible from Wireless Professional Solutions for any Aussies interested.

2 Likes

#100

301.73€ and 64€ shipping, that makes half the TR4 boards more affordable…

0 Likes