Return to Level1Techs.com

ASRock Hyper Quad m.2 card only recognizes first SSD

So I’m setting up a new build, but I’m having some issues using my Quad m.2 card that comes with my TRX40 Taichi motherboard.

I’ve got 4x ADATA SX8200PNP 2TB drives installed in the card.
The card itself is installed in the PCIE4 slot as the manual states it’s the recommended slot.

However, I can only see 1 of the SSD’s, both in the BIOS and my OS (testing with Ubuntu 20.04)
Is there any magic setting I need to enable to see the rest of the drives? I’ve looked at the switches on the card and they seem to be set correctly.

I’ve tried other PCIE slots in trying to figure out what’s going on, but get the same result in each one.

Any suggestions?

Pretty sure you need PCIe bifurcation set on the board. Would look into that.

2 Likes

Thanks, I’ll have to check how to enable it in the BIOS, is there a code name for it?

After poking around in submenu after submenu, under the AMD PBS category I was able to set the PCIE slot from x16 to x4x4x4x4, thanks!

2 Likes

Very nice, so if using an expansion card like this you have to enable the bifurcation mode for the slot this kind of card is installed into.

I guess this makes sense since each SSD is only going to use 4 PCIe lanes.

Yeah, you have to dig in the bios settings a little, but that’s what’s needed to make it work.
Kind of weird the manual talks all about how to install the ssd’s in the card itself, but fails to mention the bios setting in both the motherboard and separate card’s manuals, just a hint on where to find the setting would’ve been nice. :slight_smile: