Asrock C2750D4I - No display output

Hi everyone,

I just finished putting together my freenas server based off the Asrock C2750D4I motherboard. I can't seem to get any display to work. The VGA port won't display anything on any monitor I try and the IPMI's remote control function sits at 0 fps for a few minutes before a "Video Socket Error" message comes up and then the program closes.

I am using two sticks of Crucial CT102472BD160B (in the correct slots by the way), a Corsair CX430M power supply, 6x WD red 4TB HDD and a HP dual gbit NIC.

From what I can tell it is posting fine and I can access the IPMI interface but when it comes to any sort of remote control I can't get it to work.

There are a few forum posts of people complaining about this but from what I can tell no fixes for it.

Can anyone offer some help?

Do you have a dedicated gpu laying arround, which you could try to test with?
maybe the onboard graphics is disabled in the bios or what not.

So I updated the BMC via IPMI and it didn't seem to solve the problem, but now the VGA port is working. I have no idea why...

So the current problem is no remote control of the system via IPMI?

What IPMI tool are you using or are you connecting to the interface through a web browser?

Through firefox. I can use all the other IPMI features, just not the remote control which is the feature I need the most. If you have any suggestions I would love to hear them, otherwise I will probably just have a play around with it after work tomorrow.

As it currently stands, freenas is up and running and there is 5 TB of files copying over from the old NAS. 120 MB/s, I'm pretty happy with that speed.

Cool stuff, Supermicro have their own program (called IPMIView) that may work for you. It is only available for Windows, but is super handy when you have more than one server that uses IPMI.

Worth a look and it may solve your problems. (Don't worry about giving company details on the download page)

Thanks! I'll check that out when I get some free time.

So, as a follow up. I have tried just about everything at this point, disabling any and all security I have and I still cant run the IP KVM. I've tried the supermicro program you suggested zanginator and still no luck. I guess I will just have to keep plugging in a monitor each time I need to use the shell.

Quick edit, for some reason it's working now. Again, no idea why. This motherboard seems to have a mind of its own.