Asrock C2750D4I Console Redirection

I've set up freenas and now I'm trying to get the console redirection to work but it keeps failing on capturing even during boot. I don't know what I'm doing wrong, if there is step by step instructions that would be appreciated!

Everything works seamlessly except for this.

Can you describe what you've tried?

I'm looking at my FreeBSD 10 rig to see what I've done. It's an AMT console rather than IPMI, but I believe the concept should be the same. Here's the relevant config info I have:

xeon-freebsd% pciconf -l | grep uart

[email protected]:0:22:3: class=0x070002 card=0x081815d9 chip=0x8c3d8086 rev=0x04 hdr=0x00

xeon-freebsd% grep console /boot/loader.conf

console="comconsole,vidconsole"

comconsole_speed="115200"

comconsole_pcidev="0:22:3"

xeon-freebsd% grep console /etc/ttys

console "/usr/libexec/getty std.115200" vt100 on secure

 

Note that I have set the speed to 115200 because that's what my BIOS is set to. Yours may be different. And of course the pci device will probably be different.

So, step by step, you can see I just found which pci device the uart is using the pciconf command, then set the tunables in /boot/loader.conf to set that device as the system console. To be able to log in on the console, you have to edit /etc/ttys.

On FreeNAS, there is a web gui way to add loader tunables (http://doc.freenas.org/index.php/Tunables), but I'm not sure if there is a convenient way to edit ttys. The file might even be correctly configured by default, especially if you are using one of the serial images. If not, you'll have to do a little research to make sure that /etc/ttys is actually the right file to change. Either pfSense or FreeNAS or both do some tricks to discard edits in /etc and the actual config file resides elsewhere. I can never remember which one...

 

Thank you for your response Freq, I have followed the tunables but don't know where to go next after that...This is my first IPMI board so I have little knowledge on how to set it up. The first two commands didn't return any results but the third did:

[[email protected]] ~# grep console /etc/ttys

# For virtual consoles, the correct type is typically cons25.
# If console is marked "insecure", then init will ask for the root password
console none unknown off secure
# Dumb console

Should I peruse the bios for this?

I would first check your bios to make sure that serial port redirection is enabled (or whatever your bios happens to label "turn on the ipmi console device", and also make a note of what baud it is set to. Because you got no hits from pciconf, I suspect the feature is disabled (on my board it was disabled by default fwiw). You might have to try an alternative method of grabbing the port if you find that it is actually enabled. Here's /boot/loader.conf.local from a FreeNAS virtual machine I have:

[[email protected]] ~# cat /boot/loader.conf.local

comconsole_port="0x2f8"

comconsole_speed="9600"

boot_multicons="YES"

console="comconsole,vidconsole"

Looking at the ttys file, it looks like FreeNAS does things a little differently because of its special console interface. Also I'm not sure if it is only the USB img that has the volatile /etc or if all installs do this, but for me the correct place to make edits to ttys is in /conf/base/etc, not /etc. But it seems like this file should not need any changes as long as the bootloader is correctly setting the serial console. The only reason you might need to change it is if your bios won't let you set the ipmi serial baud to 9600, in which case you will have to edit the following line:

grep sercons /conf/base/etc/ttys

sercons "/usr/libexec/getty freenas_serial9600" vt100 on secure

To be able to change that file you'll have to use something like vi or ee (ee is probably easier if you don't know vi), and you'll have to remount the root filesystem rw:

mount -uw /

ee /conf/base/etc/ttys

Note the possible bauds:

grep freenas /etc/gettytab

freenas_serial9600:

freenas_serial19200:

freenas_serial38400:

freenas_serial57600:

freenas_serial115200:

There is probably a way to set this within the web interface, as well.

I went into the bios and changed states for console to see if that was issue. I first need to get the bios to show remotely to move onto freenas since it all starts there. I will continue to play around with it to see if I can get a response, thank you again for helping in this I really appreciate it. When I do the grep freenas /etc/gettytab I get the manual tunetable that I set in: ipmi_load="YES" and for grep sercons I get: sercons "/usr/libexec/getty std.115200" vt100   off secure.

You shouldn't have to do anything with gettytab, I was just listing the possible getty modes you could set in ttys. There is no reason that ipmi_load="YES" would be in gettytab either, I think you meant /boot/loader.conf.local

After you've managed to get the IPMI hardware turned on, add the tunables I showed you and edit ttys so that it is "on" instead of "off" and you should be golden. :) BTW, it looks like the easy way to make those changes is to just go to Settings->Advanced and turn on the serial console from there. :o

mine did this you have to make an exception for it in java otherwise it just straight up blocks it without any kind of warning.  also SOL must be enabled. hope you've fixed it by now, just in case you haven't 

Ooooooooooook, sorry for the 'late reply but it's working now, only firefox though which I don't mind.