Return to Level1Techs.com

Asrock B450 and NVME?

I got my Asrock B450 Gaming ITX/AC board today and wanted to use my old Corsair MP500 120 GB drive in it.

But something is really weird.
First of all, the m2 slot is only mentioned in the manual as its on the board. None of the settings or features are mentioned, or even shown how to use it. Did not even come with the screw needed.

I have a screw, and installed the drive.
But its like 1 every 20 boot that the drive shows up?

Have Asrock really made a board where they kinda admit the NVME slot is more for show than for actual use?

The fact is, I used to have a Asrock board 3-4 years ago when I bought this drive, and it worked.
Since then I used it in a Asus board, where the drive also works.
I bought a external drive adapter for nvme, where it dont work in + now it dont work in this board.

I have not seen NVMe with so spotty support before.

Ill imagine if I could find a NVMe drive on the boards QVL list it would work, but everythig above really makes me not very comfortable with what this board can do and cant do.

Anyone have similar experiences?

Nope the slots worked fine on every board i have used. Maybe you got a bad board, was it a 2nd hand board?

1 Like

Well, it should be brand new. But the box had no sticker, so could be a refurb or a return, cant tell. This just seem odd. I can find lots of redit and similar post that there is something going on with B350 and 450 Asrock boards apparently

Contact the seller since its recent purchase

Hmm yeah, i can see that because its registered as a new board, then its asrock directly i would have to contact. Im thinking maybe just find another NVMe drive to test with, one from the QVL list, because if that wont work - then the board must be defect and Asrock would have to do something (now they could avoid doing anything as my drive is not one of the ones they tested)

Yeah if its new always deal with seller first as they can usually just swap it out compared to waiting on slow AF RMA from any company

I just ordered a WD SN750 WDS250G3X0C-00SJG0 drive, its on the QVL and its not very expensive. If this works then i guess I wilk ebay the corsair as “maybe it works, maybe it dont”

And if the SN750 wont work, then i will talk to the seller and can return the new drive.

This is not exactly what I was hoping for.
Should have been a super easy build, but cant even install windows as the drive dont really ahow up reliably

Just to check, have you updated to latest BIOS? This might resolve your issues. If the WD solves everything though, then chalk this one to a faulty drive. 1 TB NVMe is becoming so cheap now it’s no problem whatsoever to afford one, though still not the cheapest drives…

yeah i dont want to update the bios, because asrock dont recommend to do that with the CPU i have.

that alone also seem little strange, but its on their site so did not want to take the chance.

anyway, i popped in the SN750 and it works in the first try.
the MP500 still works in my Asus board?

So I have to say, its the Asrock board thats strange here, pretty sure my old SSD is not faulty, its just old and some newer tech dont support it (that dont makes much sense to me but whatever)

its solved, now I need to sell the old ssd as i clearly have no use of it

For what it’s worth, updating the BIOS may or may not help. I had a nearly identical problem with a Patriot SSD ON my Phantom Gaming 4 a few months back. I’m farily certain the Patriot and MP500 use a similar if not the same Phison controller. I took the shotgun approach. I updated BIOS, tried 2 different NVME drives, used RAM that was on the QVL even dropped in my old 1600X. None of it helped. I ended up just using a SATA SSD. I don’t use my old Patriot drive. I’m sure I’ll find a build to put it in one day.

I will likely never buy ASRock again. I ended up buying a new X570 Aorus Elite and I’ve had no issues with it.

Have/would either/both of you contact asrock about this. It could be a simple compatibility issue that they can fix in bois/software.

M.2 as a standard does get revisions so it could be that the asrock boards only support the newer standard for some reason and have some sort of backward compatibility issue.

I did contact ASRock for support. I have a whole email thread with them. Board was purchased used and they would not RMA it.

I did update the BIOS, it’s currently running version 3.40 and I was advised not to update further unless I was going to upgrade to Vermeer.

I appreciate the input but at this point I’m done putting energy into it. It was a $60 X570 motherboard, so it is what it is. I wasn’t even going to reply to this thread until I saw we were both using very similar SSDs.