ASRock AB350 Gaming K4 Motherboard Review + Linux Test | Level One Techs

IOMMu for guest graphics passthrough works on this board! But it is purely accidental that it does! If you give up PCI3.0 NVMe , you can use the PCIe 3.0 x4 slot for the HOST graphics adapter.

This is a companion discussion topic for the original entry at
1 Like

The board is not actually a 6+3 phase power delivery sadly, it should have the same VRM as this board, it's still a solid power delivery set up though, just maybe not as good as the 4+2/3 set ups on some other boards depending on stuff

I have the board and it's been working fine for me, a recent BIOS update let me hit 2400mhz on my Ripjaws V 16GB kit, awaiting further revisions so I can hopefully get to the magical 3200mhz.


Thanks for the video guys, really interesting stuff and glad to see some more people paying attention to the b350 boards. A couple of questions:
1 - Is that a thermalright true spirit 140 in the video? Any chance you could share performance numbers on a r7 chip with that cooler if that's the case?
2 - in terms of the VRMs, as @Streetguru noted before it's really only a 3+3 if I'm not mistaken. That said I'm actually pretty interested in the board and I've been wondering about temperatures/performance and all that so it was great to see you mention that they get "toasty" but not too hot. Do you happen to have any specific temperatures or anything to note there?
3 - I may have missed this in the video, how were RAM speeds with overclocking? Were you able to manage 3200, or not quite? I've heard of a couple of people having issues with hitting higher speeds on this particular board and streetguru's post seems to confirm that.
It's really interesting to consider using the board for something like a home server, I've been trying to figure out a good board to cram a gpu, infiniband card, tv tuner, second nic into and potentially m.2 (not a huge deal but it would be nice!), but I've been coming up short, at least on b350, seems like this board might offer more options in that regard. The search continues.

I just bought this board but haven't gotten IOMMU to work just yet. It seems my Sapphire 7950 does not support EFI.

@wendell What method did you use to pass through the card in the x16 slot? I would appreciate any hints in the right direction.

Are you able to blacklist/pcistub the x16 graphics card at boot and swap to the x4 card? That part working first is key. After that your card must support efi . You can boot from a graphics rom not installed on the card itself or possibly flash update your graphics card?

Rumor has it, that the upcoming May 2017 AGESA version UEFI updates is supposed to have IOMMU friendly enhancements included.

Ryzen, in addition to NVME also has support for Sata and USB 3.1(gen 1). I have never thought about this before but if that is the case, USB and Sata would also need a share of the x4 PCIe lanes. Wouldn't the NVME connection only have x2 PCIe lanes available or is the distribution of lanes configurable in the UEFI?

Shame that they don't include the REFCLK adjustment

So apparently there is some low speed whatever that doesn't use pcie at all. The x300 chipset leaves all x8 available for whatever the vendor wants to do with them.

The USB is literally on cpu.

Yes I am able to blacklist the card. I am using Proxmox 5.0b1 with only one GPU in the x16 slot. I got it working now, without EFI it seems. Need to do some further testing though.

are you sure?

I know that USB has 4 port support on chip, but from looking at the diagrams, the CCX cores, memory controller and IO controller are the 3 subsystems that have their own 32 Byte/cycle interconnects to the data Fabric.

I thought the IO controller handled the available x24 pcie lanes and split it up to:
The x4 chipset connection.

Two x8 connections that are combined to make a single x16 slot for single GPU or stay at two x8 on x370 in SLI mode.


the remaining x4 to support the NVME, Sata III and 4 ports USB 3.0 (5G) .

The chipset that is connected to the first x4 I listed has the USB 3.1 10G and additional USB 3.0 support and additional sata support.

What I don't know is how much freedom there is to allocate the nvme/sata/usb pcie resources that are available from the x4 Lanes. Is Asrock B350 just choosing to ignore the native USB and Sata ports all together and just providing x4 to NVME?

The Taichi has sata express port presenting access to x2 of the cpu lanes to augment the chipset sata ports. How are they managing the allocation to different types of devices?

Taichi doesn't have sata express, it was a mistake in the uefi to have the option.

I suspected that because nvme pcie and all pch devices were in iommu group 0 that Ryzen is, now or later, going to get a chipset later that is pcie 3.0 x8. How kick-ass would that be? No bottleneck -- you could offer all the resources of x370 and have all the pcie 3.0 resources you can. Shake a stick at.

I asked Robert hallock about it and he said an OEM could do something like that right now today with the x300 chipset because it doesn't use any of the 8 pcie 3.0 lanes coming off the cpu. So I expect to see Soho server appliances based on Ryzen with x8/x8/x4/x4 with plx or some such.

I have the Pro4 M ver. of this board and I'm not getting the good feelz everyone else seems to be getting. Boot times are atrocious; upwards of three min at times and I cant get this board to boot with ram clocked at anything over 2133. In windows the A-tuning software just refuses to run at all and AMD's Ryzen master will load but is all washed out and non-functional! Here's mah infoz

black screen before booting? that strongly suggests there is some problem with the ram. have you tried single stick of ram just to see if it does other stuff differently?

There is a bit of that but it looks like the hand off from uefi to Windows is where the problem resides. On my MSI Z97 rig it boot to desktop so fast I couldn't even get into bios w/o the boot to bios software. Here, I'm looking at the initialization screen for about 10 sec then black for 5-10 sec followed by 1-2 minutes of spinning dots below the ASRock branding. This was a fresh win 10 install. I'll check the single stick of ram when I get home tonight.

Just wondering about the nvidia thing... is there a reason why the driver just exits when it's in a VM? Or is it just nvidia being dicks to customers (again)? Is it a security thing or something? Couldn't imagine anything why this would be a thing...

also @wendell can you add an annotation that the VRM is actually 3+3 and not 6+3? Maybe a link to the AHOC video above? Some people not all that much into this stuff may be confused by differing information on this board.

6+3 phase pwm doesnt exists.

Most B350 boards use the ISL95712 4+3 phase pwm.
Or the Richtek RT8894A 4+1 phase pwm, (used by Msi only).

Remember that Ryzen is basically a high tech sort of lego set. A CCX module is a building block. A memory controller is a building block that has per channel modules behind it. A pcie 3.0 x8 module is a single block and they have used three blocks in the "IO controller". The Infinity fabric is the large flat lego base board that you build everything on.

AMD is just dividing the third x8 lanes in two and sending one half to the pch which breaks it up further with a switch to allow shared double duty of those x4 lanes that would remain under utilized otherwise and one half to the nvme slot or what ever is in fashion when a new motherboard design comes out. There should be no reason why a MB vendor could not delete the direct NVME and just make an x8 pch switch to utilize the lanes more efficiently.
For all I know, AMD may actually be doing that already and the pch switch is actually part of the pcie module on the chip but because of the logical arrangement on the motherboards they are using traditional labels to describe the functionality.

I think it is nvidia being dicks.

They don't want you to use a geforce card but spend more money and buy a expensive quadro card, which is basically the same hardware. The Quadro drivers do not kick you out of a VM.

It used to be possible to change one of the resisters on the keppler gtx 600 cards and it would identify itself as a quadro and run the quadro drivers. I dont think that mod works any more on the newer cards.

I was hoping someone with this board could tell me what distro/kernel(s) and if acs patched or not works with IOMMU.

I have an AsRock ab350m pro4 and OpenSuse tumbleweed (tried 4.10 and 4.11) won't even load when IOMMU is enabled.

AsRock wants more info/proof before they look into this for my board.

uefi updated? I used fedora 4.10 and it worked fine.

svm was enabled, as was iommu

by won't load, what error are you getting?

I have that board as well and it does take an unusually long time to boot. Haven't timed it but if I cut the power and turn it on it is well over a minute before the Asrock splash screen showed up. It's not as bad on a reboot.
I did manage to get my ram up to 2400. It's F4-3200C16D-32GTZKW

1 Like