Arch virt-manager/Libvirt not detecting ovmf

I'm trying to do PCI passthrough i curently got what needed install im using virt-manager as you can see from the screenshot virt-manager can find OVMF.

Any tips on getting OVMF to work ?

Have you restarted libvirtd?

sudo systemctl restart libvirtd virtlogd

If so, give the whole PC a reboot and try again. I've always had to restart services after installing OVMF.

To clarify, virt-manager is just the front-end. libvirt is the backend that handles running the machines and whatnot. when you're telling the system where to find OVMF, you're configuring libvirt. virt-manager hooks into the API of libvirt, allowing you to easily administer it with a keyboard and mouse.

So it stands to reason that simply closing and re-opening virt-manager won't do anything.

1 Like

I just tried that and still no go for some reason libvirt is not finding OVMF any other suggestion.

Maybe double check there isn't a second entry for nvram = [ in the config, and remove those commented out lines inside the brackets?

Alright it still doesn't work is there a disadvantage if it use bios mode instead of uefi mode?

The only advantages that I'm aware of is EFI boot mode for Windows which means faster boot time.

I'm not a pro on EFI vs BIOS though.

Hi i have tried and had success and failure with pci passthrough on arch. i have the same problem. I found out that ovmf package on arch have a bug. So it is recommended to install ovmf from AUR.

Her is a link that helped a little

I have had successful pci passthrough on arch and run stable but the ovmf was big problem. I must say that i found fedora to be better for pci passthrough because ovmf is dependency for qemu in fedora. So i have never had any problems with that. If you have any questions on pci passthrough i can try and help you if you want.

I, more or less, manually install OVMF, mainly because I'm experimenting with new distros. I've been using Solus lately, and I've found that it has the highest level of stability for GPU passthrough I've ever seen.

Yeah, I've been finding that Arch, while being easier for some things, has major problems with others and this makes arch even more difficult to work with than something like Fedora.

1 Like

@SgtAwesomesauce @habbis Thanks for the input ovmf not working is not a big deal if regular bios mode work. Now have had a successful PCI passthrough with Debian stretch with intel igpu and AMD r9 390. Should i try a other distro again to get this set up working?, Currently my set up would be AMD r9 270 host and r9 390 for vm but it not working. Essentially my r9 390 is stuck using Radeon module and can't blacklist Radeon driver then i get no post, if i switch to a other distro will it be slightly easier than Arch Linux?

Oh, you're going to have to forcefully unbind the device after boot. If you have an nvidia gpu, I'd recommend using that for host, that way you can blacklist radeon.

Alright i will try with my current setup in Debian Stretch instead of ARCH since i had success in the past if i cant make it work with dual amd GPU then i will enable my Intel HD Graphique.