Arch on Acer C720 Chromebook ((Help))

So, I'm trying to install Arch on my new Chromebook.

I enable developer mode, and enabled legacy and USB boot.

I press Ctrl+L to get into seaBIOS, press escape, then press 2 to boot to my USB drive.

SeaBIOS changes to a higher resolution, and gives me the following output:

Booting from Hard Disk...

early console in decompress_kernel



Decompressing Linux... Parsing ELF... Performing relocations... done.

Booting the kernel.


And then it just stays there, and doesn't do anything after that.


Can anyone who has successfully installed arch on this thing, or knows about Linux -cough-(Zoltan)-cough- help me out with this?

don't own a chromebook or anything but you could try to use the installed kernel on the usb stick

It doesn't even get past boot, I cant boot to the USB to run anything. When using the option to boot anywhere at all, it freezes. Even when I tell it to boot to the internal SSD. I have to skip the boot options completely by pressing Ctrl+d

did you flash the bios? because from my experience with my acer 710 i couldn't install a linux distro on it like a normal pc. google has seemed to of locked the bios down. 

i used this guide. 

although i'm not sure what's going on with the 720 and how close it is to my 710. 

Ahh, i may try that. I saw it on a video about how to install windows 7 on it, it should work for linux as well, thanks.

That's odd. You can try flashing a newer version of coreboot then and hope that it solves the problem.

it's not a bios and your guide is not for dual-boot but for a chroot

i never said it was for dual boot. and the link was to help him become more informed on the subject. i was just passing along something i found through playing with my chrome book. so instead next time why don't you contribute to helping instead of pointing out shit that isn't relevant to the post.  

I just installed arch again on a c720 without hickups.

There are a couple of things I can think of:

1. What image of Arch did you use? Was it an older one? You really should use a recent one.

2. Did you do a hashcheck on the data before you dd'ed it to the USB?

3. Most probable: USB flashdrive hickup. Maybe rewrite the MBR on the USB drive, and while reformatting afterwards with a fresh partition, do a check to see if there aren't any bad blocks on it. I'm pretty sure that there is a data integrity problem on your USB drive that is causing the freeze.

Let me know what it did after trying again with a fresh USB stick, I'll keep an eye on the thread.

Okay, Ill redo everything when I get back home.  I did use the most recent build from this month.


Yeah, then it's probably the USB drive that has a bad block.

Well, I remade the image with dd, using a different USB stick, same problem. I got curious, and removed the stick, and pressed Ctrl+L to get into SeaBIOS, and tried to boot into my internal SSD, and it did the same thing, even with no USB drive.

If I dont press anything at boot, or press CTRL+D, it works and boots into ChromeOS fine.

Leads me to believe there's something wrong with my SeaBIOS.

Yup, that's most probably a BIOS problem. I didn't see it on any install and just asked my colleague that did the installs of the dozen C720's I bought, he's betting on a borked BIOS or a hardware problem.

I got Chrubuntu to work just fine, though. (Just tried it last night)

And it loads through SeaBIOS. 

I am very confused, and will have to work on this further. Damn google and their stuff.

Chrubuntu runs in a chroot on ChromeOS so it makes sense that it works.

Like I said, update coreboot and SeaBIOS (shouldn't be a problem at all. pull the latest source, build it, flash it).

Chrubuntu isnt chroot, you're thinking of using crouton. Chrubuntu uses legacyboot. chrubuntu actually installs grub and uses it for booting. 

What if you would use the GRUB of Chrubuntu to boot Arch? For instance, you could take the light MATE OS from the mate community, which is only about 300 MB, and start it up with the edited Chrubuntu GRUB. If that would start, it would pinpoint the problem.

Woops, right. My bad.

zoltan ,your idea worked. 

I just modified the grub entry in ubuntu to boot to my USB drive. And I now have Arch booted on my chromebook. Now to install.

Thanks for taking the time to help, everyone.

Great, have fun!

I threw Gentoo on the C720 touchscreen that I grabbed to play with, it took more than an hour to just compile firefox... yeah well, that was a waste of time... lolz.