APU build+ New Ghz 7770 problems

So i got an APU build, the A10 5800k, wich works fine for 720p and 1080p gaming for my needs, but recently i wanted to crank up my settings without breaking the bank so i went and bought a 7770 installed it, downloaded latest drivers and rebooted, then i noticed something funny, my FPS in several games were horrible, instea dof going up they went down....... could this be cause bad drivers? or why? i did everything the right way, only thing i could think off is drivers might be the issue, any ideas?


when i say bad frames i say bad!!! 1 to 9 FPS wich i didnt even get on my APU alone lol now with a more powerfull GPU i get less then 10 in some games O.o

uninstall your gpu drivers, run driversweeper, re-install gpu drivers.

If everything was done correctly, then the only think I could think of is that the bios and OS might still be trying to crossfire. Make sure that you set the correct GPU settings in the bios as well in the AMD control panel. Then give that a try. Good luck.

I think Sweeping the drivers would work miracles indeed.

I use http://sites.amd.com/us/game/downloads/Pages/catalyst-uninstall-utility.aspx .

Doesnt miss a single spot.

well i ran the driver sweeper and re installed and nothing, its got to be the bios or the games now xD, i can run Deus Ex human revolution just fine high settings and good frames ( 35 to 60, i can run WoW ( dont judge me im just trying it lol ) at Ultra with a lot of things turn up at like 50fps, League i can play at solid 60fps all high also, but theres one MMo i cant play at all, Tera on that one i get like 1 to 6 FPS no matter what settings i used, i turned everything down and still same fps then everything up and same, i tried another free MMO and got like the same 1 fps, and dont really have more games lol to try it out but yeh, dunno why :/

btw my motherboard came with a genie Bios GUI wich is like so troublesome to find my GPU in it lol anyway to go to a regular bios on this mobo?

MSI Socket FM2/amda75 microATX motherboard

I don't know about that man :(

my guess is that the game or the system is trying to run it in sli, but simply cant.... Try the AMD control panel settings if you cant find it in the bios. I also think its really strange that it is working in other games, but not that one... Good luck. Keep updating and maybe someone else with a similar board can advise you.

thanks and yeh i find it weird also, but i dont mind it as much now ill just not play those games, for now.... xD

and i do plan on upgrading my motherboard and cpu but thats gonna be maybe next year or dunno, what i have now is more then capable enough for all my gaming and none gaming needs.

anyways im a light gamer so any recomendations on good games? i like em all lol.

driver sweeper dosent help you when removeing  AMD catalyst drivers it dosent fully remove it you need to use the Catalyst Un-install Utility here---> http://sites.amd.com/us/game/downloads/Pages/catalyst-uninstall-utility.aspx

Then reboot and install AMD Catalyst 13.10 that you can find here--> http://support.amd.com/us/gpudownload/windows/Pages/radeonaiw_win8-64.aspx

You whont have a problem useing a A10 with a HD7770 

when i use the catalyst uninstall utility my screen goes black after a min and i waited like 2 mins and never came back on untill i rebooted, and i did installed those same drivers u linked me, any ideas why my screen went black? should i wait and see if it pops back up? hummmmmmmmmmmmmmmmm.....

you need to have patience you are removeing the video display driver then windows looks for a standard driver for the display this can take a cuple of minutes you just need to wait.

Just out of interest have you got the monitor pluged in to the video card or the motherboard?

i got my monitor pluged into my video card, and i noticed it says windows 7 only compatible, im runing windows 8 , does that afect it? and ok ill try waiting it out see if it works

I have tryed to stay away from windows 8 to me its just a MS fook up that rivals vista there has been meany strainge bugs in w8 so i wouldn't rule it out if all else fails a reinstall of windows can work wounders.

The A10 with a HD7770 shud give good performance(a hell of a lot better than 1-10fps)

IKR and ima do some retries in the drivers and see what hapens im downloading the latest beta drivers wich are 13.10 beta as u said ill let u guys know what hapens

well, i ran the uninstall utility, it said it finished correctly, i installed the latest drivers and still nothing, i guess my pc doesnt like free games xD, WoW runs just fine,and league runs fine, but my 2 free MMOs dont, ill just wont play em, i havent much anyways before, my steam games play fine.

It could just be bad optimization with those games....

Here are some games to try out:

Shadowrun Returns: strategy RPG

Skytim: if you havent already... you definately should (open world, action RPG)

FTL: you become a space captain!

thnx, FTL looks good and i heard a lot of great things about skyrim but havent played it, but i will definately give it a try, and yeh i heard the code for Tera is really messy, if that makes sense, so that might be it.

so after a long time and thinking about my APU, im almost decided to just buy the AD750k quad core cpu wich is basically the same as the a10 5800k without the graphics, because the one game i wanna play just wont play with my GPU :/

i dont wanna upgrade anymore as of right now but if i wanna be able to go and play that one game, i will have to change the APU for a regular CPU and this one is my only option xD

just need a little push from you guys , its not expensive but its still 80 dollars xD