Return to Level1Techs.com

Aorus Master X570 Ubuntu & Bluetooth

I’m a week into setting up my Aorus x570 with Ubuntu 19.10 and for the most part its been fine. If anyone has the Aorus Master with Ubuntu 19.10 I’m hoping you can confirm the following (otherwise it’s a me problem).

[1] Bluetooth did seem to work initially but got turned off. Now I can’t enable it to save my life. I have tried a fistful of cli commands as well:

sudo systemctl start bluetooth
sudo rfkill unblock bluetooth
sudo apt-get install pulseaudio-module-bluetooth
sudo pactl load-module module-bluetooth-discover

I have tried plugging in the antenna as well as not.

[2] The headphone jack on the rear of the case is borked. I’m currently using the jack at the front of the case which works. Ubuntu seems to think the only audio port at the back is spdif.

Any feedback would be great.

I’m not sure if there is a connection here but in System Settings under the Power mode there are two options to allow the WIFI or Bluetooth services to be turned off to conserve power.

If I toggle these off (ie, I do not want these services to be turned off to save power) it actually shuts off those services. This is not expected behaviour.

Now I’m wondering if this is somehow related to my not being able to turn on Bluetooth at all.

Poor wording on Canonical’s part:

Still no bluetooth.

Some progress. When I run the following in the terminal …

~$ systemctl list-unit-files|grep -i bluetooth

… I get this result:

bluetooth.service enabled
bluetooth.target static

But as far as the gui is concerned there is no spoon:

I had a similar issue with my Asus Strix x399-e gaming. Power off the computer, then disconnect the the PSU from the wall or flip the PSU switch to off. Leave it off for 1-2mins, reconnect the PSU or flip the switch back on, and power on the machine. Let me know if the bluetooth comes back on. Its annoying but I saw people reported the same issue and fix even on windows with the board.

1 Like

Thanks terroreek,

here is where I am now – bluetooth is working!

BUT, I actually did 2 things at the same time so I’m not sure which one worked (I did power off completely as you suggested).

The second thing was to set bt_coex_active=N and I suspect this is what fixed the problem. My exact problem is defined in this post by someone under similar conditions, the solution is quite thorough.

I had the same issue. I am running Pop! OS based on 20.04LTS. Struggled for 3 months without a solution and used terroreek’s turn off and on trick and it worked. Dang! How is this even possible?!

Thanks-a-lot terroreek.

1 Like