Return to Level1Techs.com

Aorus Elite x570 can't enter BIOS

Hey everyone,

recently I wanted to change some settings in BIOS, so i reset my system and when I press the delete button, the screen just freezes and doesn’t go anywhere from there. It’s just the aorus logo and the BIOS options (enter BIOS, qflash etc). Otherwise the computer works fine, with no issues if I don’t try to go into BIOS.

Any ideas?

Specs:

Ryzen 5 3600

rtx 2070 super

x570 aorus elite

2x 3200 8gb ram from hyperX

1 Like

use the ‘fastboot’ in gigabyte app center to boot into the bios for you?

I’ll try that

It didn’t work, it’s stuck the same way it was before

do you have multiple monitors?

nope

can you try and move the port your monitor is on to another spot on the GPU?

I would update the bios with the @BIOS utility if it isnt up to date.

If you have any usb hubs disconnect them and connect m/kb directly. If that does nothing try clearing your cmos. This will force your system to enter the uefi.
If you haven’t done so already try updating your cmos with bios flashback if you can’t enter it still.

Alright, so I tried disconnecting all devices/ peripherals except for the most necessary. I also cleared the cmos (I don’t know what that’s supposed to do, because it only caused a longer boot and a different color of lights). Still experiencing the same issue. I’m really starting to get worried

I also updated (I think successfully) to the newest bios version using the @BIOS utility

Are you using windows?

yes

Hold left shit and click restart. Troubleshoot>Adv options>uefi

Lol shift*

I tried that, its still frozen at that stupid screen

You might try flashing a slightly older bios version in case something is buggy with the newest

got another gpu you can try?

seems to me like the board is bad somehow but ive had funky things happen with certain gpu and monitor combos before.

Well, it has worked just a couple day before, I just installed a new cooler, and the bios worked that time (6 days ago)

thats bizarre man. i’m out of ideas other than to just start changing hardware/tearing the system down to the bare minimum to see if it will boot into bios then.

Like without the gpu? I wrote to the gigabyte support, but I have no idea what they could suggest to do.