Anyone using ryzen 5 3600 with the msi x570 unify : I tried everything... ram at 2133 mhz

It’s been a month I have been battling against this problem, still no luck

I have a g.skill trident z neo 4x8 3600 kits (and previously lpx vengeance 2x8 and neither would work)

And xmp profil won’t work, manual OC won’t boot.

The only time I can have 3600 is when I have only 1 stick on SLOT 2, and one stick alone! 2 sticks = 2133, 4 sticks = 2133

I did alot of memtest…

4 sticks =

stick 1,2,3 (one by one, on slot 2) = 0 errors

stick 4 on slot 2 =

I even had a gigabyte gaming x motherboard before this and still no luck, I upgraded the PSU too, the only thing I didn’t change is the cpu

I have the last chipset drivers, I have the last bios version…


Have you tried a lower than 3600 MHz clock? Maybe 3000MHz?

You have added stress on the memory controller due to the 4 sticks.

What voltage is the memory running? What timings? Do they match what’s printed on the heat spreaders?

1 Like

Did you try reseating the cpu? Could be making bad contact (I see you tried two mobos so probably not super helpful, but worth a try) Did you contact Memory and mobo manufacture.

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.