Anyone use Subsonic?

I'm having trouble with my subsonic installation on Nas4Free

I had this working on build 5.2.1 but once I upgrade to 5.3 the "feature" went away. I am having trouble getting my video podcasts to play from the podcasts menu in subsonic. Each time I click on a video podcast it never enters the log, the action is not registered as an error is even happening. I've checked the logs and nothing is recorded. This means the videos fail to play. I've recreated this server jail numerous times on my NAS and on a vm with the same result. I've tried reinstalling all the supporting codecs and nothing gets this to work. Strange thing is, on my vm with 6.0-beta1 installed I can get a video podcast to play if I add it to the media collection but nothing else plays (even music has the same error on this install) from the podcasts section of the server.

Any ideas of where to start? I've used the same process to install this server 10-12 times now trying to see if I am missing a step or some sort of dependency is missing. here is a link to the guide I use to install it, obviously I change the version numbers to suite the updated installer:

Any ideas?