Anyone use Atom text editor? How do I fix the autocomplete?

I’m using Atom because it’s open source and free and all that.

How do I make the autocomplete not terrible?


Keep hitting the button till you see the thing or just, you know, type the word and not worry about it.

1 Like

Edit the autocomplete settings (there’s a bunch), or use emacs.

1 Like

Wait you can do that? Oh man I’ll have to fiddle with that some. This is actually the reason I stopped playing with Atom.

1 Like

Atom has some similarities to emacs in that respect. Emacs is configurable via init files programmatically, has configurable packages etc. atom has similar functionality, though probably not as mature.

1 Like

Problem is that I’m done typing the word, I hit enter and it changes it to the top suggestion. It happens with end, which maybe makes sense because the autocomplete for if or while or whatever give you the end automatically, but it also happens with booleans, as if you need to type trusted or structure more often than true. nil corrects to natively.

Yeah, I know. I just can’t believe how half baked it is out of the box.

Fiddling with settings, enabling Use Strict Matching and disabling Include Completions From All Buffers helps a lot.

That’s the trouble trying to please 1000 people who want that one thing working 500 different ways. You have to configure it for how you want it. Emacs doesnt even have autocompletion on by default.

1 Like