Anyone else had problems with a cifs share and steam libraries?

Hi, I am trying to have my steam library on my NAS server by doing a cifs share. I am running Manjaro. I have been having trouble with permissions, specifically trying to get execute permissions as I cannot add the steam library without execute permissions. My /etc/fstab file has this:

// /mnt/NAS cifs uid=user,gid=user,exec,defaults 0 0

I have tried restarting to let fstab load however this doesnt have an effect. I have been struggling to work this out, any help is appreciated.

just spitballing here, but can you try it with french symlinking explicitly enabled?
steam requires symlinking functionality that isnt enabled by default on CIFS.

Following a guide (correct me if I did this wrong) I added this to the end;


No effect, I still cannot add a steam library (No execute permission)

Ok, I have done more testing. I am able to execute .py files on the NAS without problems, I am not sure if this is useful or not.

I don’t remember when I added it but I have this in my Samba smb.conf:

acl allow execute always = yes

Do you mean;?


I tried accessing the file and its empty

Use mount -a instead of rebooting. If you get no output then the mount is working.

I always have weird issues I can’t never seem to understand with cifs. I recommend nfs as an alternative.

How would I use nfs? just replace ‘cifs’ with ‘nfs’?

I have enabled nfs on my server

So long as it’s shared via nfs already the fstab format looks like:

ser.ver.ip.add:/full/path/to/share/ /path/to/target/ nfs defaults 0 0

Based on this. /mnt/NAS nfs defaults 0 0

Wherever storage is needs to be the whole path from the root of the drive.

1 Like

Thank you very much! I was looking for an alternative to cifs but couldnt find anything

1 Like

Does that work for executing your steam games?

yeah, thanks

1 Like