Any Sway/Wayland Users? I try Wayland about once a year

I recently had a weird issue with the amdgpu driver and constant crashes. Wayland ran stable, so I gave Sway another shot on my main desktop. I used it for a good 2~3 weeks but ran into a ton of issues and wrote this blog post about them:

I switched over to an nVidia card and went back to X11, but I’m curious if there are any Sway users on here, specifically Sway users with hidpi (4k) displays. Did you have to deal with any of the issues I ran into? How many of you stuck with Sway and how many went back to i3?

1 Like

I try Wayland every once in a while and get pissed off at it and end up going back to X every time

I hate having to jump through hoops to do stuff like screen record because it was designed by security idiots with a penchant for inventing problems amd using them as an excuse to lock it down and make it hard for people who just wanna do stuff

Its frustrating


Yea, that’s pretty much been my experience as well. Simple things like dialog window types don’t exist … I can understand wanting that macOS level of security, but the implementation doesn’t seem to solve any of the right problems.

Wayland / Mutter on an RX 6600 @ 1440p here. No real complaints. Amazing what a mature desktop does for ya. :grin:

It’s been so long since I’ve used Gnome I had to look at up. I didn’t realize that was the Gnome window manager. :sweat_smile: I think the last one I used was … whatever came after Sawfish … man I’m old.

But yea, I’ve heard Gnome/Mutter does work better with Wayland and in my blog post I did mention how KDE seems to have solved the scaling issues Sway has. I like tiling window managers too much to switch back though.

I’ve been using it for about 1.5 years now. 3900X and currently a 6900XT, did have a 5700XT previously. I don’t have any mesa issues like you do other than the known fencing issue that can cause crashes and is supposed to be fixed with kernel 6.2 I believe.

  • It seems like swaymsg is more about the display and not so much the port.
  • Have not tried flameshot but just use this bindsym $mod+p exec grim -g "$(slurp -d)" ~/Pictures/$(date +'screenshot_%Y-%m-%d-%H%M%S.png')
  • PyCharm works mostly okay for me with the environment variable.
  • Only use 1440p, not 4k so can’t comment. Fractional scaling was just added to wlroots but that won’t fix xwayland.
  • Not sure what you mean for system tray. You using swaybar or waybar? I use the latter without any issue.
  • Floating windows is an issue, is what it is I guess.
  • Haven’t tested the monitor issue.
  • Only reliable way for gnome-keyring to unlock is to use GDM which is less than desirable. I had it working without GDM at one point but don’t know what changed, maybe an update at some point. My only use for gnome-keyring over another is for VSCode git authentication.

I’ve been Wayland only for a few years now. I have mostly had AMD GPUs (Rx 390, VEGA 64), or Intel integrated graphics on the laptops I’ve had. I used KDE Plasma on my desktop for a long time and more recently have switched to Gnome across the board since I use my laptop more. The only issues I have had were with Electron apps (used to be default was xWayland). The defaults have mostly worked fine in the last 12 months or so. I still use VSCode almost daily. I use 150% fractional scaling on my laptop and it works great. My desktop is 1440p and I generally haven’t needed to use fractional scaling there.

I used Sway for a little bit. It took a lot of fiddling and eventually I gave up on it. There’s newm which seems like a good option for my laptop and is up my alley, but I haven’t tried it out yet.

In other Good News™: Wayland finally supports fractional scaling, hooray…


Tell me about your amdgpu crash, as I’m seeing one on Fedora 37 with Gnome. Does your crash sound like these issues? I’m hoping to get more attention on this issue as my system is pretty close to unusable now.

Looks similar. Unfortunately I switched to an nVidia 970 I got used. Haven’t run into stability issues, but it is good to see those issues; will add my own kernel dumps to them. Hope it gets resolved.