Antlion modmic help

Recently bought the antlion modmic 4.0 to use with my Sennhiesser 558 headphones. When i go to plug in the mic to the motherboard it wont even register in my settings that anything is even plugged it. Same thing happens when i plug it into the front panel mic jack. Tried the mic on my mac to make sure it worked and it indeed works. My next course of action was to buy a cheap(6$) USB sound card that had both a headphone and mic jack on it. The mic works when plugged up to the USB sound card. Only problem is the mic sounds like i am talking into a fishbowl or cup. A very muffled sound. This mic is not of potato quality and i feel like i am doing something wrong on my part. A friend tells me i should go buy a decent sound card for like 30-50$. I have a 50$ best buy gift card so i am not to worried about spending the money. 


I guess i really just need a second opinion on what to do next. Should i buy a better sound card? Is the cheap 6$ usb sound card causing my mic to sound like a potato quality?


This is a custom built PC i just put together about a month ago. I have been using a USB headset by razer which had an awesome mic but terrible sound quality


I7 4790k


GaG1 sniper z97 Gigabyte

16gb G. skill sniper

Corsair h100I

240gb SSD intel

WD 1tb Black 

750 EVGA supernova G+ Look down through the paragraphs and a suitable fix might be there.

I looked there but only found a link the took me to a page that is over 6 years old. I did try those steps but those are more for if you computer registers the mic. Mine wont do that without the usb sound card adapter

Make sure your mic in connection is enabled (and not muted) in your audio settings/audio manager.

Where would this be located at? i have everything enabled in the sound settings unless i am missing somthing

Usually in Control Panel>Hardware and Sound or Control Panel>"your driver's audio manager"  

Looks like that motherboard uses creative drivers.  If you can't find anything or nothing works, you can try and update/reinstal your audio drivers.  See if that helps.

For some reason it was disabled in my audio driver. Now that i solved that problem and its plugged directly into my mic jack, it still sounds like i am talking into a fish bowl. :/

I don't know.  From what I've heard of it (never used one myself), the modmic sounds fairly decent as far as a basic mic goes.  It could just be a poor quality input on your motherboard (though, I would have expected it to at least sound different, if not better, with your cheap soundcard).  What are you using to test it?  It could just be an issue with the program or the record settings.

I am basing this off using teamspeak and in game. People said it improved a lot after i got the mic jack to work but i still am getting nowhere near the quality all these you tubers and reviewers have.

Check TS settings.  It has various audio settings like noise removal, auto gain, echo reduction etc.  Turn everything off and see if it improves.  Also try recording yourself in another program to test the sound, just to be sure.  It could still boil down to a poor quality MB input though, or the mic could just be a lemon.