Another Linux noob here with annoying problems!

Hey guys, long time viewer of the tek, and bee viewing the site for a while but I've largely been inactive on the forums. But I do need help, and I'm confident you guys can help me!

 

So, I've recently purchased an Acer Aspire V3 771G-9809 http://www.newegg.com/Product/Product.aspx?Item=N82E16834215672R

I was having some trouble getting any distro's of Linux to install, and I've encountered the classic 'black screen' issue when attempting to install, and using 'nomodeset' in the grub line wasn't working, and neither was 'acpi=0' !!

So, I attempted to use the lubuntu alternate installer (12.10 x64) because I heard it works on machines with problems like this, and it works!!! It ran the installer and will now boot into the OS! unfortunately I still get a black screen after the lubuntu splash screen /cry.

I attempted to edit the grub line after 'quiet splash' and add 'nomodeset' and it hung at the splash screen. Then I attempted to add 'acpi=0' to the grub line and it got past the splash screen, but I got the black screen issue again. So, I tried adding both, and it hangs at the splash screen. WHAT DO I DO?!?! I have been praying  to great Odin's beard for aid, and he has yet to answer my calls. tek syndicate! You can help me!

Go in the bios, disable the nVidia GPU, install/configure on the Intel GPU only. After that, reenable the nVidia GPU in BIOS and disable the Intel one, the system will boot through on VESA drivers, and you can use Jockey to install the proprietary nVidia driver.

Ubuntu was not a great choice, it doesn't support nVidia Optimus (and that's not the only problem it has). Find a distro that does, my favorites are Fedora and Manjaro Linux. Manjaro Linux 0.8.5 supports nVidia Optimus, has automatic proprietary driver installs, supports kernel switching, has steam and flash and stuff preinstalled, and is Arch based, so runs fast as fuck. Fedora is the industry standard enterprise grade bleeding edge GNU/Linux community distro by RedHat and the Fedora Community, it runs everything including secureboot UEFI things, on modern high performance hardware like your laptop, I personally would install Fedora 18 with Yum Extender, Fedora Utils and Gnome Shell Extensions for a really balling modern stylish system with a high productivity factor (and steam, flash, nvidia drivers, etc... install in seconds with Fedora Utils). I use Fedora 18 with select packages from updates, rawhide and Fedora19 repos as my main OS myself, in fact I'm typing this on my Asus Intel+nVidia laptop in Fedora 18.

Zoltan thank you! Thanks for your recommendation and everything I really appreciate it! So, is this the version of fedora you were talking about? http://fedoraproject.org/get-fedora I'm down to try it, and I didn't know that Ubuntu didn't support nvidia optimus? So fedora will support nvidia optimus out of the box?? Thats fantastic. I really hope this works out well then! So, I shouldn't have to disable the nvida GPU in the BIOS when I install fedora, right?

Yes, that's the Live distro that will allow you to install Fedora18. Once you boot that up, you can run the Anaconda installer to install it to your HDD, it's very easy and fast.

Fedora will install the FOSS drivers for both the Intel and the nVidia GPU and it will run out of the box. Then, once you have installed Fedora Utils, you can use that to install the proprietary nVidia drivers, and when you reboot after that, Fedora will switch to the nVidia driver and keep it going unless you tell it not to. If powersaving is not a priority, I would keep it at that for maximum performance. If you want to maximise the power management, you run Powertop to get recommendations on power optimisation of all parts of the computer, and you copy those recommendations into a file (just look at the fedora documentation on powertop, no use in me writing this all down here), and your computer will be extremely well power optimised, including GPU optimisation with or without optimus. My computer is fully power optimised, and for a 17.3" laptop with an SSD and a HDD and an nVidia graphics card, the battery lasts a really long time (like 6.5 hours with WiFi on, screen brightness maxed out, only nVidia card active, etc...). I don't like Optimus myself, because it costs a lot of graphics performance for only a very small gain in power consumption, but it does work if you want it to.

If you use an SSD, don't forget to enable trim for home and root. You have to do that manually. It takes like 30 seconds and is very easy, but it needs to be done after install.

Awesome! I'll have to check out Powertop. Do you know where I can find some information on how to set up my power usage the best way? Because I use this laptop at school, and power optimization is important. 6.5 hours is awesome. When I was running windows 8 I'd get like 3 hours on power saving lol.

First you install powerop, easy way is to search for it in yumex, fastest way is to CLI:

$ su -c 'yum install powertop'

you run powertop from the CLI with the -calibrate and -html parameters, and let it scan the system for a while, basically the longer the better, so definitely a few minutes. It will measure the individual power consumption of every part of the system, including USB ports and stuff, really everything, and will make a full analysis. Then it will make a nice table with CLI recommendations per part, and save that as a html file. After that, you can copy paste the exact recommendations into a script file that will run these when the computer starts. You don't even have to think about it, the suggestions powertop gives are already commands that will just work.

After that, reboot the system and run powertop again without the calibrate and html parameters, just to get a screen overview, and check if everything is optimised.

It makes a huge difference in battery life, but costs nothing in terms of performance and comfort. My EeePC 1005p would do about 8 hours in Windows 7 with Asus SHE enabled and the screen brightness really low. Now in Fedora 18 it gets almost 13 hours and the screen brightness is a lot higher, the performance is better, and I have twice as much RAM in it as when I was running Windows, and RAM is a big power drain for an EeePC like that, and I could do better if I were to use an SSD instead of the HDD that's in it now, but I use it as a photo bank so I would have to get a pretty expensive SSD, which is just stupid for such a cheap netbook.

I have an Asus N-77 and an Asus A75, both with 17.3" screens, both with nVidia GPU's, both with Intel chips, both with Samsung SSD + Seagate 7200 rpm HDD, one with a Core2Duo+GT220m+840, the other with an I7-3630qm+gtx650m+840pro with optimus. The N-77 lasts for about 5.5 hours, the A-75 for about 6.5 hours in normal use with discrete graphics. I've tried the A-75 with IGP, it makes a difference of less than 20 minutes of total battery life, but the graphics are way less attractive, and some processes go slower, because the IGP is used by the CPU to accelerate certain tasks when it's using the discrete graphics, but that functionality doesn't work efficiently when the system is switching from discrete GPU to IGP all the time because of optimus, and the IGP is not that great on a 1080p screen to be honest, whereas the discrete GPU is.

Okay, great I'll try that and let you know how it goes! I've got fedora installed and running! I had to use nomodeset for the installer, but once it was installed it booted right in with no problems! 

This distro is a lot different, and I'm still getting used to it, but right now my power consumption is ridiculous and its only using the integrated graphics haha. I'm gonna use powertop and try to get everything installed and working properly. I'm messaging you from the laptop on fedora now! :D

damn. so i installed fedora, updated, installed the nvidia proprietary drivers, and then uninstalled the nouveau drivers and when i reboot it fails to boot and I can't figure out why. I've tried a ton of stuff on the internet, it just boots to a black screen. damn. I'm trying to fix it but I'm going in circles. I boot in runlevel 3 and uninstall the nvidia package and re install it and it does the same thing. the nouveau driver is already uninstalled too. Idk what I'm doing wrong. :(

 

If I boot with 'nomodeset' it starts to boot and stops at 

"[ OK  ] Started GNOME Display Manager."

I don't get it that you have to boot with nomodeset like you said you did the first time also. That's just weird.

Did you disable the Secure boot and therefor revert to legacy BIOS or something, taking out other EFI functions at the same time that may affect the hardware detection? Something just isn't right. If you have UEFI, leave secure boot on, Fedora 18 uses it.

Did you install the proprietary nVidia driver with Fedora Utils? Don't install it manually, use Fedora Utils, just to make sure you have all the parameters set up right.

The nouveau driver should not be uninstalled when the proprietary nVidia driver is installed, that's not normal.

Very strange what happens there. Did you check the Acer Website for maybe a different linux proprietary driver that's needed? But I honestly don't think that the driver is the problem, I think something else is wrong, Fedora doesn't uninstall drivers. They may appear vanished if there is something wrong with the drivers, for instance if proprietary drivers are not allowed or if they are not properly signed or if they cause SELinux mayhem, but they are not uninstalled. Maybe it's something deeper also, did Ubuntu flash anything on your hardware somewhere? Did you change something in BIOS?

Maybe first reset the BIOS to default settings. Then try to install again from scratch. First thing after install, do:

su -c 'yum upgrade'

su -c 'yum install yumex'

su -c 'yum update'

reboot, then after reboot

su -c "curl http://download.opensuse.org/repositories/home:/satya164:/fedorautils/Fedora_18/home:satya164:fedorautils.repo -o /etc/yum.repos.d/fedorautils.repo && yum install fedorautils"

to install fedora utils, then use fedora utils to install nvidia proprietary drivers and steam and flash etc.

it should just work, it should install the drivers, switch to them, install akmod-nvidia for the updates, etc.

There is no way in hell Gnome Shell should ever not detect the right mode unless there is something wrong somewhere deeper. I've installed Fedora 18 on exactly the same Acer laptop as yours without any issue whatsoever, and that was already based on the technical release candidate 3 back in december or january, and that was really as simple as putting in the CD and installing it.

Hmm, yeah I did change to Legacy BIOS. I'll switch back to UEFI, and then re-install with your instructions. Thanks for being so patient with me! I'm just new to Linux, and I'm having a tough time getting used to it haha.

Just thought of something: you did reinstall grub2 in Anaconda, didn't you, Fedora's GRUB is different from Ubuntu's. Every trace of the Ubuntu install has to be gone, including the GRUB, because it will screw up your system.

yeah, i do have fedora's grub now. The Ubuntu partition was deleted and formatted.

Weird, if I try to boot from the LiveUSB that I made, it tells me that it can't load the kernel when I'm in UEFI BIOS. Damn. Seriously, I appreciate the patience lol. I'm reloading the iso onto the USB and trying again. I'm just trying to learn here haha.

That's not right, it should just work. Fedora uses a shim with the Microsoft key, for the system there is no difference between Windows 8 and Fedora18. Did you import any other security keys manually? If so, delete them, that's not right. You just don't need them, after using the shim, Fedora will generate a hardware specific key for your system and add it's own layer of secure boot security that is hardware specific instead of being a well published microsoft key that every hacker has access to.

My guess is that there is something wrong with the GRUB, when you start the PC, do you get a full colour graphical interface immediately with like a window in the center where the GRUB menu items are (which would be the Fedora GRUB2), or do you get a text only monochrome on purplebrown background type GRUB menu (the Ubuntu one)?

If you don't find the culprit setting that blocks Fedora immediately, I would suggest doing a system restore in Windows 8 after resetting the BIOS to default factory settings. Then everything will be like it was when it came from the factory. Then just pop in the Fedora 18 DVD and install.

I get the GRUB2 menu that you described. I've wiped Windows 8 off the hard drive completely for now. I was going to try using some version of linux as my main OS on there to force me to learn it a little better. I'll load Windows 8 back on there later. So, I'm starting over with the Fedora 18 USB key. (I've been using Linux Live USB Creator) and I'm gonna re-install under the UEFI BIOS everything reset to stock.

So, under UEFI BIOS it won't let me boot from my Live USB, but under Legacy it will? but I still need to boot with nomodeset so that I can get a display. :( I'm gonna try installing again, and doing the package installs the way you instructed.

Yeah probably a good idea, USB is faster than DVD.

When you boot the live-USB after restoring the factory settings in UEFI-BIOS, fire up the disks app and reformat the drive completely, trash everything and make a single maxed out ext4 partition with some name. Even remove the "boot" flag of that partition.

Then in Anaconda, repartition as Fedora suggests. I hope it works.

Will do. I've got midterms today, so I'm gonna have to do it when I get home tonight. I'm new to teksyndicate.com, is there a way to thank you like buy you reddit gold or tip you with BTC? haha

So, after setting the BIOS to default settings and UEFI I attempted to boot from the Live USB. However, it gave me some error message, like I must load the kernel first or something. So, I wiped the hard drive clean on my desktop, stuck it back in, and attempted to load up the live USB. It still gave me the error message on UEFI, so I switched back to Legacy, without changing any other settings and it loaded perfectly. I got into the live session, installed, and rebooted no problems. I followed all of your other instructions to the tee and when I installed the nvidia proprietary drivers from fedora utils and rebooted it worked! I then proceeded to install the akmod-nvidia package, and then rebooted, and I got the same problem. A black screen on boot. So I added nomodeset and saw that it failed on the same error message on boot! :(

 

"[ OK  ] Started GNOME Display Manager."

So, naturally, it booted fine BEFORE I installed the akmod package, so I did ctrl-alt-f2 and did yum remove akmod-nvidia and removed it. Now, I get past "Started GNOME Display Manager." and it stops at 

"[ OK ] Started WPA Supplicant Daemon."

After rhgb quiet in the grub menu it says a couple things like "nouveau.modeset=0 rd.driver.blacklist=nouveau video=vesa:off vga=normal" should I try setting vesa:off to on? because vesa is the intel driver, correct? 

Your patience sir or madam, is to be admired. Thank you so much!

haha, you probably broke the nvidia driver by installing the akmod-nvidia, it was already installed with fedora utils, there is no official proprietary nvidia driver in the fedora repos because it's not open source, fedora utils uses an external repo with a community adapted driver pre-packaged specifically for Fedora.

no worries, just install yum extender, open it up, search for nvidia, uninstall all the driver components, reboot (the VESA drivers are generic drivers, they are not the Intel drivers, the Intel drivers are open source, they are incorporated in the kernel, you just don't have to worry about them, they're just there, just like the VESA drivers, which work with any card that can handle a 1024x768 resolution), then use fedora utils again to install the nvidia proprietary drivers, and it will work, you don't have to install anything else after that, or you will break it.

 

The UEFI business is worrying though. Fedora uses the Microsoft signed key to shim the secure boot, so it just works when windoze 8 works. Have you checked whether there is a BIOS update available. The first version of that laptop was sold with W7, and had no UEFI BIOS, it was added afterwards when it was sold with W8. Also check the UEFI BIOS signature list if the Microsoft key is still in there, that it was not erased or something. If secure boot blocks the booting of an operating system, you get a red window on the screen, if it's not that, secure boot is not the issue, but UEFI itself may still be buggy for some reason.

WPA Supplicant has nothing to do with graphics, it's part of the Wi-Fi subsystem. It will not cause a problem unless a firmware update was interrupted during install or something. Have you done the yum upgrade? Maybe start yum extender, it will give a list of all available updates on start, click select all and install if there are any. I wouldn't worry about the WPA_Supplicant daemon, with modern WiFi modules everything will just work with Fedora.

What kernel are you on (you see that in GRUB or you can type "uname -r" in terminal)? Is it 3.8.8? If not, you need to update the system. If the system shows no updates available with yum extender and uname says you're not on the 3.8.8 kernel, type "rpm -q kernel" in terminal to find out which kernel versions are installed on your system, and see if the 3.8.8 kernel is in the list.