AMDGPU Opensuse Tumbleweed Setup

I'm having trouble trying to get amdgpu to work as intended, I did many clean slates to see if it would work out of the box however a problem still persists, everytime I move a window, a video plays, or simply using the KDE interface, there is multiple screen tearing.

I have a two monitor setup (BenQ RL2455HM 24in LED Gaming Monitor), running opensuse tumbleweed, I've also tried to make sense of how xorg works and tried to configure it that way, alas that wasn't a solution. I've tried to find help from the main thread for amdgpu but only got one answer about the composer @zoltan and it didn't work. So I'm making a seperate thread for this specific problem I'm having, yes, I did my research used googlefu, went to amd, opensuse forums, xorg wiki and arch wiki.

UPDATE 1: (Posting video of issue and configurations)

Video of screen tearing:







X11 Dir



grep amdgpu Xorg.0.log

grep VGA


So please, if you can help me that would be greatly appreciated.

Probably your monitor is not getting fed frames at its native frequency.

Did you check whether the monitor's native frequency was recognized? If it was, is it set to that frequency? If it's not, you need to add the mode and generate the VESA code for it, and it will be solved. Sometimes it happens that certain pieces of hardware are not properly standards conform because the manufacturers think their product is not going to be used outside of a certain consumer use case scenario, and if that's the case with a monitor for instance, it might not declare it's native mode.

Is there a config I have to create to set a specific frequency or do I have to change it manually through physical monitor controls? I'm continuing my search and so far it's all in the /etc/X11/ directory.

If you wish I can post all my configs for you to inspect.

No one?

Oops sorry didn't see you had actually posted.

Have you checked the frequency?

If it's not matching, and the correct frequency doesn't show up in the GUI as preconfigured, you have to generate a VESA mode code for it, to add it as a mode that can be selected at boot. It's not hard. Just do a web search for "GTF" and you'll see how it works.

That doesn't seem to be screen tearing? That's literally glitching. Which might be because you have a 390x unless I'm mistaken amdgpu is still experimental on that card.

You may find Linux 4.10 helps. You may also find you want to make sure you have the latest mesa and llvm.

You'll also find you'll still have tearing (actual normal tearing) while your on Xorg though not as noticeable.

I have a 390X and I've not been able to get OpenSUSE or Gecko Linux to work properly either. I'm not sure what they do differently but it just doesn't work well with that card. At least not yet.

It's the architecture of the card. It's not fully supported by the drivers yet (it's experimental in the kernel and has to be specifically turned on, unless it's been anabled recently.)

1 Like

Just stating the obvious here: you tried setting force full screen repaints in kde display settings?
Or tried other compositors like compton with --vsync drm or --vsync opengl flags?

Thank you all for replying, that kinda sucks that's it's not just me that experiences this on a 390X, I did force screen repaints in the KDE composer just a fyi.

Is there anything I can do on Opensuse tumbleweed? Or do I have to wait for a stable-ish build for my card? Is there any other linux distro that already has this up and running?

As far as i'm aware, no. (unless you know how to program GPU drivers?)

What release is the 390x? (SI, CIK?) if its either of those the amdgpu drivers are highly experimental and disabled in most distros.

I'm not sure what you mean by release, how can I provide that information for you?

Looking up these two

Apparently the 390x is a Grenada XT (Hawaii XT), so apparently a HAWAII card. the xorg site says thats a Sea Island card (so CIK/CGN 1.1), the driver support is experimental for amdgpu.

This suggests its enabled on opensuse

But i dunno. and if it is, it experimental theres nothing you can do but keep up to date and hope it gets improved (it is) or move back to radeonsi

Ok, thank you.

I'm ok leaving it on amdgpu, it's bearable. At least I now know that it's at this stage and not knowing that it's only me that's having the problem, again thank you for clarifying this.

Does it happen on all desktops? What about KDE with wayland?

I'm not sure, I just use KDE plasma.

The login options should give you an option (maybe) for plasma with wayland.

Ok, I'll check that out when I get back.

I don't have weston installed.

weston is just a demo. What you need might be something like plasma5-wayland-session or the like. Search 'wayland' with zypper