Amd r9 390

English isnt my first language, so i am sorry if my grammar isnt perfect.

Wanted to try out Linux again, tried it on and off a couple of times.

But after i have gotten my 390 i cant get a single distro to work, as soon as it has booted in, it black screens.

tried on

ubuntu 14.04, 16.04
manjaroo 16.10
fedora 25

Anybody have any idea what i can try?

i can tty1 if i am fast.

After installing I had this issue with Manjaro. I had the same distro installed with a 660ti and it worked. Tried reinstalling it and it did not work, it gets to the log in screen but does not properly display things. If you find a solution please tell me!

Did you install the gpu after the install or before?

I've had a similar issue. I also have a amd r9 390. I swapped it and used an older 7970 and I had no issues with the older card but the 390 does not want to work.

Lazy GPU's

1 Like

It needs to get off it's ass and get a job!


@nillerzen @BlueYak13 What kernel were you guys using? Fedora 25 is probably your best bet to get this to work. Maybe @Eden can provide some insight, as he has an AMD gpu

I'm not sure which kernel I was using. I assume the latest. I downloaded the most recent version of Manjaro Budgie edition.

I had the same issue with an HD7870XT (GCN 1.0). The graphical installation would work, but after a reboot I'd get a black screen. I was however able to get it running on arch linux with fglrx (the outdated proprietary AMD driver). The open source drivers wouldn't work on arch for me either.
However these old proprietary drivers are suboptimal. I had poor html5 performance in firefox and had to use an old xorg version. I decided to rather run with my (much less performant) integrated r7 graphics in the A10 7890k.

Since your card has the GCN gen 2 architecture there is experimental support for the amdgpu driver that would have to be manually enabled in the kernel. But that is seems to be a rather complicated procedure.
I'd also believe that you won't have much luck, if not even the older (but still maintained) radeonsi driver works... :/
let's see what @Eden has to say.

If it's a display issue, I'm thinking it's most likely a driver, kernel, or hardware issue. Have you tried installing Manjaro using the Non-free drivers? Using one of the official versions featuring either Plasma or Xfce may work. If it does, the issue is almost certainly that it need the proprietary drivers. Not sure why that would be, though...(Non-free drivers are proprietary (should come with Catalyst Control Center, if not Crimson))

After install or during?

Based on this information, in Fedora 25.

At the GRUB boot menu press e

Add the following to the end of the linux line


Press Ctrl+X

This should boot the computer i think.

update the system

dnf update

add the polaris-gfx repo

dnf copr enable mystro256/polaris-gfx

update the system to the new stuff

dnf distro-sync
dnf install xorg-x11-drv-amdgpu
dnf install mesa-libvulkan-radeon

You might need to add extra grub parameters, if you still have issues try adding the following to the end of the linux line as described above when booting

amdgpu.exp_hw_support=1 modprobe.blacklist=radeon

If that works add it to /etc/defaults/grub in the line GRUB_CMDLINE_LINUX="rhgb quiet" the following

amdgpu.exp_hw_support=1 modprobe.blacklist=radeon

and run

grub2-mkconfig -o /boot/grub2/grub.cfg
1 Like

AMD has largely only been working on the 480/Fury side of things, the 290/390 cards often get forgotten and BIG regressions and bugs crop up within MESA often.

However in saying that Blackscreens can occur on NVIDIA cards, for example my Linux install atm has a blackscreen with my two 980Ti cards because I enabled multi-gpu mode which apparently doesn't like (I was trying to get SLI working which apparently is a major undertaking to enable correctly for Linux)

I have an R9 390, and I installed several different distros with it before finally landing on openSUSE, and I don't recall having any trouble with it. I believe Fedora and Manjaro were among the ones I tried, and had working.

With my 390X, I sometimes have to add radeon.dpm=0 to my boot script in order to get passed the black screen thing. It's been resolved with distros with newer drivers/software though. Out of all the distros I've tried, Antergos has worked the best for me with my card.

I could get Fedora25 installed using the iGPU, then ran the stuff you suggested. switched over to the 390 and it works for 10-20 seconds with a lot of artifacting then stops displaying anything.

any idea what could fix this?

And thank you everybody for helping me with this problem.

Have a look at the logs

Journalctl -xb -p err
Cat /car/log/Xorg/Xorg.0.log | grep EE

Should give you output.

Add | fpaste

To have it upload it for you and give you an URL.
I'm on mobile so commands may need tweaked.

i have no xorg.log file in the var folder, guess that is what /car/ was supposed to be :)

i have to startup using my iGPU is this why?

Sorry my phone changed some of the words, sense you might need to check it.

Var log Xorg Xorg.0.log

Or something similar. Google should tell you the exact path

journalctl -b _COMM=gdm-x-session > dump.txt did the trick, couldn't find the xorg.log anywhere on the system.

EDIT: i was hearing some wierd fan noises "sudden spikes in RPM" and checked xsensors. it reported radeon at 93 celsius, even tough i had it disabled in bios.

Replying to this thread so hopefully someone else can get some help for this.

I made it kinda work a month ago but forgot to post here.
I will try and remember step by step what i did.

Most of the info i got to help me with this is from this thread.

i did this using Ubuntu gnome 17.04 some beta version.
i think this will also work on 16.04 with a kernel update to 4.10

Booting up with radeon.dpm=0 kinda fixes the issue but forces you on a single power stage.
Doing anything graphically intesive here will give artifacting and maybe crashes.

to be able to get the other power stages working i used this tool.

and this gnome extension to control power stages.

Since it has been a while since i did this i cant remember if i did anything else to make it kinda stable, but all the info i used came from the first link i posted.

This issue is now 3 years old and unresolved so i dont tink it will ever be.

if someone needs help with this i can try, but i am really green with linux.

1 Like