Return to Level1Techs.com

AMD R9 390 finally usable on Linux!


#21

Is it possible that the firmware for your card is not installed? I was reading this bug report where people are experiencing similar issue with AMDGPU. Might be worth checking if your distro has the correct firmware for your GPU.


#22

I’m currently using Elementary Juno, which is basically Ubuntu 18.04. That bug says black screen, i actually get a display but my monitor is unrecognized and the resolution is locked at something stupid 720p i think.


#23

Here is a couple of benchmarks I’ve done on 4.18.7, Its the last kernel to work for me. Performance is not the best.

Tomb Raider

Counter Strike


#24

Oh wow. I thought it had always worked. I really did dodge a bullet getting a 970 for cheaper a while ago then. Sad to hear. But glad to see it works!


#25

@Shecks Have you managed to test the latest Kernels that have been released? I’m going to give it a go tonight. I’ll update with info.


#26

Yes, I’ve been updating to each new kernel as it’s release, I am currently running kernel 4.19.9 (latest stable release for Fedora 29).

I am still running with the amdgpu.dpm kernel parameter completely removed. I’ve just checked this kernel with both amdgpu.dpm=0 and amdgpu.dpm=1 and the issue is still there, I can only boot with the option omitted from the command line.

Other than that, my PC is stable and I’ve had no issues running without amdgpu.dpm

You mentioned that you are not getting a black screen on boot so I am not sure if it’s the same issue but have you tried disabling the graphical boot loader to see if there’s any differences and if you get any errors displayed? On Fedora this is done by removing the rhgb kernel parameter, but I am not sure what the equivalent is for Elementary Juno, but I assume there is a similar option.


#27

I was using 290s and a 270 with no problems on earlier kernels, but I haven’t played around with it since about 4.15 or so.

I was using radeon.cik_support=0 amdgpu.cik_support=1 and radeon.si_support=0 amdgpu.si_support=1 kernel params in the grub config, but not amdgpu.dpm or amdgpu.dc.

I guess they added some new stuff later and broke it?


#28

Yep, they definitely broke something, at one point (pre kernel 4.18.x) I had to use amdgpu.dpm=1 or my GPU would hang as soon as it tried to change power states, now I have remove it completely or my PC doesn’t get past the mode switch during boot up, there’s no performance issues without the switch though, so I guess they only half broke it.


#29

Ahh that must be the wattman-like functionality is it?


#30

I think so, it’s Dynamic Power Management and it’s taking them a long time to get right :frowning:


#31

~~I’ve tried multiple combinations and omitting the parameters again but no luck. Replacing quiet with verbose and adding plymouth:debug shows some boot code with the famous red hat green OK outputs but the screen goes black again without warning. My guess is that getting the console in framebuffer mode with higher resolutions breaks the kernel.

Its a kernel crash because I can’t SSH into the system. Any useful info that could help me a kernel stack trace if there is one. The motherboard doesn’t have a serial console.~~

Update: Upgrading the kernel to 4.19.8-1-default (from 4.19.5-x) and omitting dpm fixed it!


#32

Anyone else had any luck on the latest Kernel 4.20? Also Happy New year to all! sorry im late xD