Return to Level1Techs.com

AMD CPU and swapping RAM causes system to freeze, is that a bug?

#1

Hi there, I’m making this just because I want to understand if I just discovered a bug in the kernel or what and I’m asking for help in testing or rather just people that can help me understand what’s the issue there.

I’m making this forward to AMD CPU/AMD Platform users

I personally own a Ryzen 5 1600 CPU, MSI B350 mobo, 8GB of Kingston HyperX RAM, and I have noticed when my system starts to swap out even small quantities of system RAM to the swap partition, or even when just using ZRAM, the system just completely freezes up.

Of course is expected to have system slowdowns when swapping out memory, but this is a completely unresponsive system that lasts more than ever. No TTY access can be made, no SSH. Only sysrq keys seem to work.

There is NO OOM killer in action, since it happens even when small quantities of swap memory is used.

I tried the same tests on Windows, and this does not happen. But even when using the same Linux distribution on my Intel laptop, it doesn’t even slow down a second, and even when swapping out HUGE quantities of RAM like a couple of GB’s.
I just tried firing up a Virtual machine here, the PS3 emulator, and something like 50 youtube videos to quickly kill my 8GB of ram, and slowdowns occur, but this doesn’t lead to my system being completely unusable on Ubuntu in my laptop. Only in my AMD desktop this occurs, and not on the Intel laptop with ubuntu. Not on my AMD desktop with Windows with the same tests.

Just for the record, of course my swap partition is on the SSD, the SSD make is the same as my Intel laptop.
And both my RAM and SSD is healthy.

I’m using Ubuntu 18.04 LTS.

So far, the reproduceability is something like 70% of the times.

I also tried specific tests with the stress command, to swap only a couple of megabytes. And this happens too.

Another thing I noticed, is the SSD led going like it’s being 100% used. Even when just using ZRAM only without a swap partition on the SSD. Strange, huh?

Now I also filed a bug on launchpad, in case you are interested in more info about that…

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1833281

1 Like