AMD Athlon 3000G good for ZFS file server?

Last I checked craft computing had some good videos on it, maybe a bit outdated at this point but will probably be good enough

Then bonus is BSD is rock solid stable (the basis for truenas) and its not eating glue in the corner like linux is

1 Like

BSD is rock solid until you introduce hardware they never tested with.
Both OpnSense and FreeNAS had about a 50% success rate actually working on my weird hardware choices.

1 Like

Thats pretty much the meme of every Open Source OS TBCH. Ive encountered situations in both linux and unix with this.

Overall if you have old enough hardware its support is usually there the 3000G is no exception and works just fine with freebsd and truenas

1 Like

Tested with? Please clarify

First version of FreeNAS I tried was a complete mess on my supermicro H8DCL-6F motherboard. I can’t remember the specific issue, but it was unusable. To be fair the Opteron 4000 series was garbage, nobody bought it, and I can’t imagine anyone testing against it, but that was the very first time I’d tried to use BSD anything outside of installing it and poking, and it was broken. A later version seemed to clear up whatever was wrong.
First version of OpnSense/pfSense I tried, actually rather recently, was broken for the specific Quad-port gigabit Intel server NIC I tried in passthrough from ESXi. Broken like, latency spikes into the seconds and massive packet loss. It didn’t do this for passthrough to Linux. That was a little surprising since the card came from a Dell that’s more common than dirt, but whatever. That was the second time trying to deploy anything BSD. It was fixed in the next major release. I’ve found BSD just doesn’t play nice with basic hardware more consistently than Linux. Once you get it working it’s great, but a 50% ootb success rate means I do a LOT more testing on anything BSD based before I’m willing to call it functional.
I think BSD’s capacity to test against various platforms is probably just super limited, and as such their quality control drops once you leave “normal” hardware options. That’s just a guess though.

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.