AM4 Motherboards and Linux..?

Hello LevelOneTechs;

I am a long-time linux user building a new Ryzen PC and need help with the motherboard. I’ve searched this and other forums and I can’t be sure that certain motherboards will work on linux with the newer LAN and, (I think) audio chips.

I found a thread on reddit where several users reported Linux distros unable to sense LAN and audio systems on the new motherboards, specifically 2.5 Gig lan and sound problems.

Have these problems been resolved on B550 motherboards booting into linux? And can anyone recommend a B550 board that will load linux and run right out of the box?

1 Like

I have a 550M board, the “MAG B550M MORTAR WIFI.”

Everything works, but lm-sensors doesn’t have compatibility for the NCT6687D fan controller. I’m on arch, so 5.8.whatever. So basically no fan control in userspace, but the bios does fine at managing temps for me.

I’m working on a pull req to add support for the NCT6687D, but I have no concrete timeline on when I’ll have it working.

1 Like

Thanks! This forum wont allow me to post links. I’m interested in 3 boards on Newegg. The MSI Pro, The AsRock extreme 4, and the ASUS Strix A model. I’m planning on a 3700x CPU, no overclocking.

I just built mine up last week. The build was:

Everything worked out of the box with a fresh arch install. Depending on your distro of choice, some things may not work, as other distros ship with a further behind kernel and packages. Temps have been low, build times have been fast. Overall pretty happy with how it turned out.

I just checked the specs of your board on Newegg. You have older LAN and audio chips, 1000Mhz lan and ALC887. The MSI pro board I’m looking at has those as well. I’m thinking about going lower end to ensure linux compatibility.

I believe the issues with the 2.5G realtek nic should be solved with the new kernels?
But of course there are also boards with intel nic’s.

But what is your budget?

Low end motherboards says nothing about linux compatibility by the way.

My Asrock X470 taichi works 100% out of the box with modern distros.

I did have some funkiness with the wifi for a while (worked fine, and then some firmware/kernel issues screwed it around for a while), but that’s sorted by the looks of it.

Network adapters are generally pretty well supported by Linux fairly rapidly these days, as network appliance stuff is Linux’s bread and butter. Putting out a network chipset with no linux driver is pretty stupid for a manufacturer to consider.

i’m using a addin 2.5gb NIC with Xubuntu 20.04 LTS on my asus prime x570p works out of the box from what i can tell but, it’s been a minute since i’ve checked.

i don’t think down grading your purchase would bode well 12 months in the future or longer when linux has full support and you want 2.5g networking or better sound.

Thanks for the info. The redditt thread with all the posts about boards not working with linux were posted in march-april, when b550 first launched. Of course Id rather have 2.5 gig LAN and better sound. From your posts it sounds like linux will fire up without a hitch on most b550 boards several months after launch.

As for my budget and use plans, I’m using my new computer for recording, video editing, and light gaming. However I am not a tech expert. I can hunt and peck and insert code into terminal. That’s about the extent of my linux skills.

That said, I loathe micro$hit and big-tech. Linux will be my OS, so I made this thread asking about boards that would allow me to build a system that boots up linux with a minimum of complications.

I appreciate everyone taking time to assure me linux runs on b550. One more thing, I am deciding between the ASRock Extreme4, AsRock Velocita, or the Asus Strix b550-A. Any recommendations on which would be best for a pure linux install - that is to say no windows?

Yes several months after launch, it’s not super often they get beta or dev access to hardware like say apple or microsoft gets.

LINUX ASIDE, there is a price to be paid by going cutting edge windows or otherwise.

Looking at the three cards, the ROG Strix B550-A seems to score quite a few wins over the rest of the cards provided.

Network: B550-A runs on an Intel I225-V is known to have good Linux support, the other two run Realtek whom work, but not out of the box so you need to hunt down and install drivers. Realtek is fixed in kernel 5.9, but kernel 5.8 is what ships with Ubuntu so… :man_shrugging: Of course, if you run a rolling distro like Manjaro, Arch or Debian unstable, then it should work pretty well out of box, just make sure the install media ships with kernel 5.9.

Other than that, seems like the ASUS board has an integrated graphics so you can troubleshoot without graphics card, which is a nice bonus, and more USB 3.2 ports (same amount of USB ports, just more high speed ports). It also has two front-facing 3.2 ports for what it’s worth. Only bad thing about it is that the number of fan connectors are limited to three, the other two have five connectors each. This could be overcome if you daisy-chain, but could potentially be a problem depending on the number of fans.

<extra> For completeness sake I want to throw in my own goto brand Aorus B550 Pro in there as well, which has quite a few strengths over the ASUS board (twice the fan connectors, $20 cheaper) but no USB 3.2 connectors and again Realtek kinda ruins the out of box experience. We all have our preferences though! :slight_smile: (yes, I admit it, I am an Aorus fanboi, their cards have served me surprisingly well) </extra>

Anyway, based on the data go with the Asus Strix B550-A, it is the best OOB for now. In 3-6 months this might change!

Hi all, If you are looking for NCT6687D support in Linux lm-sensors, I wrote the kernel module to support it.

You can take from my github repo -> Fred78290/nct6687d



Any suggestion for X570 + addressable RGB?

My god, thank you!

I had a half-finished one, but this is great!

I’ll test it out on my board later today. Thanks!

Follow up reply:

It failed at first 5.9.1-arch, but then I updated to 5.9.6-arch and it worked. Happy to pull my pacman.log and split what all changed, but on 5.9.1 it was failing to modprobe nct6687. Full error was:

modprobe: ERROR: could not insert 'nct6687': Exec format error

After updating to 5.9.6, everything installed nicely, and the sensor module shows up:

Adapter: ISA adapter
+12V:           12.10 V  (min = +12.10 V, max = +12.12 V)
+5V:             5.01 V  (min =  +5.01 V, max =  +5.02 V)
+3.3V:           3.38 V  (min =  +0.00 V, max =  +3.38 V)
CPU Soc:         1.03 V  (min =  +1.03 V, max =  +1.03 V)
CPU Vcore:     544.00 mV (min =  +0.42 V, max =  +0.54 V)
CPU 1P8:         1.85 V  (min =  +1.85 V, max =  +1.85 V)
CPU VDDP:        0.00 V  (min =  +0.00 V, max =  +0.00 V)
DRAM:            1.21 V  (min =  +1.21 V, max =  +1.21 V)
Chipset:         1.02 V  (min =  +1.01 V, max =  +1.02 V)
CPU Fan:        622 RPM  (min =  622 RPM, max =  833 RPM)
Pump Fan:      1675 RPM  (min = 1675 RPM, max = 1704 RPM)
System Fan #1: 1107 RPM  (min = 1101 RPM, max = 1107 RPM)
System Fan #2: 1108 RPM  (min = 1108 RPM, max = 1108 RPM)
System Fan #3: 1158 RPM  (min = 1158 RPM, max = 1158 RPM)
System Fan #4:    0 RPM  (min =    0 RPM, max =    0 RPM)
System Fan #5:    0 RPM  (min =    0 RPM, max =    0 RPM)
System Fan #6:    0 RPM  (min =    0 RPM, max =    0 RPM)
CPU:            +47.0°C  (low  = +43.0°C, high = +47.0°C)
System:         +29.0°C  (low  = +29.0°C, high = +29.0°C)
VRM MOS:        +23.0°C  (low  = +23.0°C, high = +23.0°C)
PCH:            +32.0°C  (low  = +32.0°C, high = +32.0°C)
CPU Socket:     +22.0°C  (low  = +22.0°C, high = +23.0°C)
PCIe x1:        +25.0°C  (low  = +25.0°C, high = +25.0°C)
M2_1:            +0.0°C  (low  =  +0.0°C, high =  +0.0°C)

So, here’s a board it’s been successfully tested on, MSI MAG B550M MORTAR WIFI Micro ATX AM4 Motherboard, running:

 🤖 ~/code/nct6687d (main)$ uname -r


Edit: One detail I forgot to add was it’s likely my fault the modprobe was failing… I may have used the wrong build environment when building for 5.9.1. Checking my history, it looks like I had linked 5.9.6’s build environment in the Makefile. Oops.

1 Like

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.