All sound stops, websites crashes when i take my headset off. GHOSTLY

I have a very very weird problem with my Beyerdynamic Qpad Qh1339 headset. Its almost ghostly...

I have alredy had it replaced once but the problem is still here. It appears on multiple computers and not only at home.
lets say if im listening to music on soundcloud, i take my headset off and the music stops, the soundtrack on the website stops and starts a loading icon as if my internet dropped. The only way to get the website to work again is to reload the page.
Lets say im playing a game. i take my headset off and all sound in the game stops until i reload the game.
Its almost as if there is a sensor in my headset that reacts to being specificly taken off my head.
I can shake the headse and move it aroundt all i want but the only way to make the sound stop is to take the headset off.
This problem happens periodicaly, as in happens often for a week+ then its fine for a week+
I have bought the kingston hyper x headset to use for the week it usualy happens as it only happens with the qpad qh1339 headset

im completly weirded out by this... i have no idea whats going on 

Windows 7?

Which system do you have? 

Windows 7 has a common issues with memory leaking audiodg.exe this is causing similar issues as you describe.

Especialy systems with a realtek lan chip, seem to suffer from this. its called DPC latency. I have a similar issue, with my FX8350 and Asus M5A97 EVO R2.0 mobo, and try to solve this for allmost 2 years with no luck. I did a latency test, with playing audio in winamp and monitored it with a program called latencymon, i had allot of spikes in the reds, and then latency mon, gave me an error caused by the lan chip most likely, because wenn i disable the lan chip, i did not had any lag spikes anymore.

So i assume you have a similar problem.

Windows 8,1

Currently trying to solve the problem over at


You have your headset connected to the onboard soundcard of your Asus crosshair V Formula Z mobo?

Edit: i saw on LTT, that you have reinstalled windows, and it seem to work now?

I linked an article about DPC latency on your LTT thread by the way. lol ☺

Yes and yes :p

Fingers crossed i hope that solved your issue.

Mines is not solved lol. But i know my problem is related to Windows 7 mainaly.