(All) Serious Failures?

So i recently just spent an entire day fixing Xampp, while trying to run it at start (I'm running Linux Mint 17) I accidentally destroyed half of the damn application, so I really screwed up, had to re-install and build the website back up...

So my question is, do you guys have one, or several, major screw ups that might be seen as funny, or just plain sad? (I will cry with you)

Oh and side question, what font do you use on the forums?


Thanks In Advance!

yeah. i was pretty new to linux. using ubuntu server at the time and i wanted to chown a directory. ended up chowning entire drive to www-data:www-data recursively. had to reinstall after that screw up

my biggest failure would probably be when I built my first gaming PC. (not some frankenstein build from the various junk Dell computers we used to have laying around)

I had everything installed and (I thought) hooked up. Pressed the power button for the first time and nothing happened. So after hours of taking the computer apart and putting it together again and troubleshooting and looking around online (which is how I found tech channels on youtube) I discovered that I had not connected the front IO connector for the power switch. Major facepalm.

The first time I installed the stock cooler on an Intel CPU, I forgot that thermal paste existed, so when I took it back off (because the system wasn't working, unrelated issue) I thought the CPU had gotten so hot it blistered it. I left for vacation just after, and I only realized when I was showing my electrical-engineer brother a picture of it did I realize that the "blisters" were reflecting light, instead of the surface being cracked and peeled. Oops. It's hard to notice the details when you're paranoid.

Had played around with linux, installed a couple disto's, but one day I saw Arch. I thought hell yeah, lets try this. I felt pretty confident, spent a couple hours configuring and couldn't figure out why it wasn't working. The guide I was following wasn't the best, and then at 2 a.m., it dawned on me that I was trying to install Arch on the cd. hahaha yeah...

Oh that's terrible.... hahaha

Wouldn't it have been better to just run a Lampp server? 

yeah no that kinda got me too. like why set up xammp when you can just install lamp and have the same stuff

The difference would be?

much easier to install lamp stack than go through the hassles and screw up stuff with xampp

Well? I am one of those poeple that has forgotten to install motherboard standoffs. :) It was my first pc build. Imagine my relief when i discovered that i had just made one of the classic noob mistakes.

just got a linode server for my portfolio running and I spent an hour staring at the terminal trying to figure out why the hell the new user I created mysteriously vanished and I couldn't assign a password to it. 

After I listen to some music and looking at the terminal for the hundredth time, I realized that I was trying to set the password at 'passwd'

lol!... this is going to be a long night. It's to be expected since I'm going into this completely blind but I didn't think I'd hit a brick wall this soon. 

When i installed xamp it installed it under /opt/lampp/ and the executable is named lampp, did xampp just rip off lampp?

its the same stuff. Linux, Apache, Mysql, PHP. Xampp comes with Perl but that can easily be added to a lamp stack. i assume you downloaded xampp from its website, whereas apache webserver is in most repos. as is mysql server, and php. perl may already be installed but if not, easily gotten through repos as well. again, very easy to do lamp server with things that are already in the repos instead of trying to install a different program that then basically has the exact same stuff in it.

Ah ok, it was just quick and easy, so i took that plunge, and it worked out ok, you know, other than erasing half of it..

I once installed my boot loader to a USB drive during an install.

I shut down my PC during a kernel upgrade.

I locked myself out of the INI system (Systemd) not sure how I did that.


Lol did the exact same thing but my IO connecters were plugged in incorrectly.

I badly messed up flashing my phone once. It was a brick for a few very scary hours, no recovery, no download mode, no rom (as I had already destroyed it in prep), no backup to reflash... It was a mess but some going back to the very beginning fixed it. I basically had to re root and re flash the entire phone and recovery. 

I did a similar thing too, my RAM wasn't pushed in far enough haha.

While flashing OpenWRT on to an old Netshit router, mid way through, power went out. Bricked the damn thing. I now have a second UPS for my workbench.