Aggregating Documentation

Added BSDs

This needs to be in a stand-alone repo on Bitbucket or Github.

1 Like


1 Like

Maintaining documentation is easy, no one does it though. I would be happy to maintain a repo.

Yes, when I first posted it, it was maybe 1/4 as long as it is now.

I was thinking it could be a Github ‘Gist’. I’ve never made a gist before. Would that be appropriate? Happy to make a repo for it as well.

Yes. I was not aware that Github had branded the word repository in to Gist. Sometimes you just gotta laugh. This would work well though.

You can still have a repo. A gist is more like bitbucket… a piece of code instead of a full blown application.

I’ll take a look at it and do whatever makes the most sense.

Are you interested in contributing/editing?

1 Like


1 Like

Awesome. I’ll get it set up and link it here when it’s ready.

I think I want to keep it in markdown so that it can be easily viewed on Github and possibly integrated into a Raneto site.

Of course, I’m totally open to suggestions on general formatting or anything else.

Let’s do it!

Hey sorry, I’ve got it like 95% set up. I spun up a vm to see how it looks in Raneto and played around with that for a while.

I was almost done and then I started getting notifications from a NAS that was hanging from a half-dead drive. I got that fixed, but now it’s 2AM, so I’m gonna finish it up tomorrow.

I did decide to go with a repo and not just a gist.

1 Like

Let me know how I can help if need be

Hey, the repo is up on github. The info is at the top of the thread ↑

I called it docsDoc which is probably more lame than it is clever, but at least it’s short.

@dot404, if you have a better idea for a name, let me know.

Funny, I was just working on installing node on my lappy. And for some reason I am having a hell of a time getting it installed. Currently using Ubuntu 17.10. Taking a look at the interwebz and this seems to be a common issue on 17.10.

Running this command:
curl -sL | sudo -E bash -

I get this:
Error executing command, exiting

I ran it through a bash verification tool that I found online and for sure has some errors in it.

I should not really be surprised. However Node has always been one of those things that just works.

You also don’t have Node as a requirement in your repot.

Nice work. Text editors might be worth adding as a section . . .

Yeah, I’m a little out of my element here. I usually just do sysadmin stuff. I spent a good amount of time getting Node running on an AWS instance today. I tried RHEL 7.4, Fedora and finally settled on Ubuntu 16.04. I was wanting to run it properly with PM2, but couldn’t figure out how to install Raneto globally… kept getting permissions issues on all distributions. Ubuntu gave me the most up to date node version, so I went with that and just used the npm built-in server.

The INSTALL script I wrote up will get you from a vanilla Ubuntu 16.04 to running docsDoc in Raneto on port 3000 with no further intervention (including installing Node and Raneto). The update script will refresh the content directory. I wrote it pretty quickly, so it’s not a work of art, but it definitely works on the AWS instance.

Again, out of my element a little. I use GitHub exclusively to store/deploy scripts I use for sysadmin stuff. I’m hoping to learn more about using git to actually collaborate.

Do I need to set a requirement parameter somewhere, or just document it in the README? Sorry if that’s a stupid question. I googled it briefly but got a bunch of unrelated stuff.


Yes, definitely. The more I flesh it out, the more things I think to add. There’s really no software section at all beyond operating systems, so that’ll be coming in the future.

Spent $12…

1 Like

Nice! My original issues stem from being on Ubuntu 17.10. Will investigate further when I get home.