Return to Level1Techs.com

After updates Manjaro no longer recognises media keys from my mouse

So ive got a really odd issue. I was just chilling, listening to some music and saw there was some updates. Ran the updates, checked my uptime and decided it was time for a reboot. After the computer was back up i pressed the mouse button i have assigned as pause/play music and it took a screenshot??? And my next track button just shows me a :no_entry_sign:

This is extremely annoying as im very used to having it there for convenient play/pause…
Its not mouse side, works perfectly fine on my windows 10 Surface Pro 4.
Its not something thats assigned software side, the key configuration is saved to the onboard memory of the mouse, it just seems like the OS is no longer understanding what its seeing? Already checked the media keys and screenshot keys assignment in the system settings and they are just as untouched as they have always been so nothing strange there.

Anyone know what to do about this?

Running Manjaro 19.4 Cinnamon DE

Thanks for the help, really want this fixed :frowning:

Which packages got upgraded? You can find out by running this command:

grep -i upgraded /var/log/pacman.log

You only need to include the latest upgrade, the command will show all upgrades before that one as well.

1 Like

So, more than likely, Cinnamon pushed the maintainer’s defualt configurations which overwrote your shortcuts. You will need to go back into your system shortcut manager and set those up again.

On Debian and ArchLinux, I am usually prompted when the package wants to overwrite or update a configuration file that I customized. It is very possible that pacman warned you that this has changed (if your system defaults to yes to all of the things). I would recommend piping or tee-ing the output of an upgrade to a log file so that you can read what happened during the upgrade for situations like this.

Its not set up through the OS though, its just like a media key on a keyboard and saved to the onboard mouse memory. If i take the mouse to any other computer it works just as it should so i dont think its got anything to do with defaults as i never touched those settings to begin with.

Alright, will check that and reply again. I think Cinnamon might have had an update as some icons have subtle changes but there is probably quite a list seeing as i only run updates once every one to two weeks because i use my desktop so little :frowning:

Okay. With that said, those media keys have to equate to command clicks in the OS. They don’t “just work” by themselves; they are mapped through something and most OSes will allow you to setup shortcuts or override what those buttons do.

Things like libinput will attempt to handle click and key events from known hardware and deal with the quirks. My guess is that your system updated libinput or evdev and, short of undoing the update or configuration file overwrite, you will need to manually reassign them in cinnamon. If you want to get it working now, this is what I would recommend looking into. Then I would work on figuring out why it broke.

I don’t use Cinnamon, but you could try running cinnamon-settings which should get you to the system settings and look for something like keyboard shortcuts or keyboard, or shortcuts and see what is configured there.

1 Like

Sorry for taking a while to reply, its a long list of stuff that got updated:

[2020-12-04T17:42:44+0100] [ALPM] upgraded alsa-card-profiles (13.99.3-1 -> 14.0-1)
[2020-12-04T17:42:45+0100] [ALPM] upgraded archlinux-appstream-data (20201020-1 -> 20201128-1)
[2020-12-04T17:42:45+0100] [ALPM] upgraded c-ares (1.16.1-2 -> 1.17.1-1)
[2020-12-04T17:42:45+0100] [ALPM] upgraded util-linux-libs (2.36-4 -> 2.36.1-3)
[2020-12-04T17:42:45+0100] [ALPM] upgraded ceph-libs (14.2.8-1 -> 15.2.6-1)
[2020-12-04T17:42:45+0100] [ALPM] upgraded util-linux (2.36-4 -> 2.36.1-3)
[2020-12-04T17:42:45+0100] [ALPM] upgraded libpulse (13.99.3-1 -> 14.0-1)
[2020-12-04T17:42:45+0100] [ALPM] upgraded js78 (78.5.0-1 -> 78.5.0-2)
[2020-12-04T17:42:45+0100] [ALPM] upgraded libjpeg-turbo (2.0.5-3 -> 2.0.6-1)
[2020-12-04T17:42:45+0100] [ALPM] upgraded libcups (2.3.3-3 -> 1:2.3.3op1-1)
[2020-12-04T17:42:45+0100] [ALPM] upgraded libx11 (1.6.12-1 -> 1.7.0-1)
[2020-12-04T17:42:45+0100] [ALPM] upgraded librsvg (2:2.50.1-1 -> 2:2.50.2-1)
[2020-12-04T17:42:45+0100] [ALPM] upgraded libxkbcommon (1.0.1-1 -> 1.0.3-1)
[2020-12-04T17:42:45+0100] [ALPM] upgraded xorg-server-common (1.20.9.r21.g5c400cae1-1 -> 1.20.10-0)
[2020-12-04T17:42:45+0100] [ALPM] upgraded libinput (1.16.3-1 -> 1.16.4-1)
[2020-12-04T17:42:45+0100] [ALPM] upgraded xorg-server (1.20.9.r21.g5c400cae1-1 -> 1.20.10-0)
[2020-12-04T17:42:45+0100] [ALPM] upgraded perl-http-cookies (6.08-3 -> 6.09-1)
[2020-12-04T17:42:45+0100] [ALPM] upgraded gnupg (2.2.23-1 -> 2.2.25-0.1)
[2020-12-04T17:42:45+0100] [ALPM] upgraded gpgme (1.14.0-1 -> 1.15.0-1)
[2020-12-04T17:42:46+0100] [ALPM] upgraded mesa (20.2.2-2 -> 20.2.3-1)
[2020-12-04T17:42:46+0100] [ALPM] upgraded cinnamon-desktop (4.6.4-1 -> 4.8.0-1)
[2020-12-04T17:42:46+0100] [ALPM] upgraded pulseaudio (13.99.3-1 -> 14.0-1)
[2020-12-04T17:42:46+0100] [ALPM] upgraded cinnamon-settings-daemon (4.6.4-1 -> 4.8.1-1)
[2020-12-04T17:42:46+0100] [ALPM] upgraded cinnamon-menus (4.6.1-1 -> 4.8.1-1)
[2020-12-04T17:42:46+0100] [ALPM] upgraded cinnamon-control-center (4.6.2-1 -> 4.8.0-1)
[2020-12-04T17:42:46+0100] [ALPM] upgraded python-xapp (2.0.0-1 -> 2.0.2-1.1)
[2020-12-04T17:42:46+0100] [ALPM] upgraded xapp (1.8.10-1 -> 2.0.0-2)
[2020-12-04T17:42:46+0100] [ALPM] upgraded cinnamon-screensaver (4.6.0-1.1 -> 4.8.0-1)
[2020-12-04T17:42:46+0100] [ALPM] upgraded cinnamon-session (4.6.2-1 -> 4.8.0-1)
[2020-12-04T17:42:46+0100] [ALPM] upgraded cjs (4.6.0-1 -> 4.8.0-1)
[2020-12-04T17:42:46+0100] [ALPM] upgraded libxkbcommon-x11 (1.0.1-1 -> 1.0.3-1)
[2020-12-04T17:42:46+0100] [ALPM] upgraded enchant (2.2.11-2 -> 2.2.12-1)
[2020-12-04T17:42:46+0100] [ALPM] upgraded webkit2gtk (2.30.2-1 -> 2.30.3-1)
[2020-12-04T17:42:46+0100] [ALPM] upgraded muffin (4.6.3-1 -> 4.8.0-1)
[2020-12-04T17:42:46+0100] [ALPM] upgraded nemo (4.6.5-1 -> 4.8.0-1)
[2020-12-04T17:42:46+0100] [ALPM] upgraded libimagequant (2.13.0-1 -> 2.13.1-1)
[2020-12-04T17:42:46+0100] [ALPM] upgraded cinnamon (4.6.7-1 -> 4.8.0-1)
[2020-12-04T17:42:46+0100] [ALPM] upgraded cinnamon-translations (4.6.2-1 -> 4.8.0-1)
[2020-12-04T17:42:46+0100] [ALPM] upgraded cmake (3.18.4-1 -> 3.19.1-1)
[2020-12-04T17:42:46+0100] [ALPM] upgraded qpdf (10.0.3-1 -> 10.0.4-1)
[2020-12-04T17:42:46+0100] [ALPM] upgraded libraqm (0.7.0-2 -> 0.7.1-1)
[2020-12-04T17:42:46+0100] [ALPM] upgraded imagemagick (7.0.10.38-1 -> 7.0.10.45-1)
[2020-12-04T17:42:46+0100] [ALPM] upgraded cups-filters (1.28.5-1 -> 1.28.5-3)
[2020-12-04T17:42:46+0100] [ALPM] upgraded cups (2.3.3-3 -> 1:2.3.3op1-1)
[2020-12-04T17:42:46+0100] [ALPM] upgraded dconf-editor (3.38.0-1 -> 3.38.2-1)
[2020-12-04T17:42:46+0100] [ALPM] upgraded dhcpcd (9.3.2-1 -> 9.3.3-1)
[2020-12-04T17:42:47+0100] [ALPM] upgraded etcher (1.5.110-1 -> 1.5.111-1)
[2020-12-04T17:42:47+0100] [ALPM] upgraded hidapi (0.10.0-2 -> 0.10.1-1)
[2020-12-04T17:42:47+0100] [ALPM] upgraded firefox (83.0-1 -> 83.0-2)
[2020-12-04T17:42:47+0100] [ALPM] upgraded libsigc++ (2.10.4-2 -> 2.10.6-1)
[2020-12-04T17:42:47+0100] [ALPM] upgraded glibmm (2.64.2-1 -> 2.64.4-1)
[2020-12-04T17:42:47+0100] [ALPM] upgraded gnome-desktop (1:3.38.1-1 -> 1:3.38.2-1)
[2020-12-04T17:42:47+0100] [ALPM] upgraded intel-ucode (20201112-1 -> 20201118-1)
[2020-12-04T17:42:47+0100] [ALPM] upgraded lib32-util-linux (2.36-1 -> 2.36.1-1)
[2020-12-04T17:42:47+0100] [ALPM] upgraded lib32-libx11 (1.6.12-1 -> 1.7.0-1)
[2020-12-04T17:42:48+0100] [ALPM] upgraded lib32-mesa (20.2.2-2 -> 20.2.3-1)
[2020-12-04T17:42:48+0100] [ALPM] upgraded lib32-faudio (20.11-1 -> 20.12-1)
[2020-12-04T17:42:48+0100] [ALPM] upgraded lib32-libjpeg-turbo (2.0.5-1 -> 2.0.6-1)
[2020-12-04T17:42:48+0100] [ALPM] upgraded lib32-libpulse (13.99.3-1 -> 14.0-1)
[2020-12-04T17:42:48+0100] [ALPM] upgraded lib32-librsvg (2.50.1-1 -> 2.50.2-1)
[2020-12-04T17:42:48+0100] [ALPM] upgraded lib32-mesa-vdpau (20.2.2-2 -> 20.2.3-1)
[2020-12-04T17:42:48+0100] [ALPM] upgraded lib32-vulkan-intel (20.2.2-2 -> 20.2.3-1)
[2020-12-04T17:42:48+0100] [ALPM] upgraded lib32-vulkan-radeon (20.2.2-2 -> 20.2.3-1)
[2020-12-04T17:42:48+0100] [ALPM] upgraded libva-mesa-driver (20.2.2-2 -> 20.2.3-1)
[2020-12-04T17:42:48+0100] [ALPM] upgraded lightdm-slick-greeter (1.4.1-1 -> 1.5.0-1)
[2020-12-04T17:42:48+0100] [ALPM] upgraded lightdm-settings (1.4.2-1 -> 1.5.0-1)
[2020-12-04T17:42:49+0100] [ALPM] upgraded linux-firmware (20201120.r1785.bc9cd0b-1 -> 20201124.r1786.b362fd4-1)
[2020-12-04T17:42:49+0100] [ALPM] upgraded linux419 (4.19.158-1 -> 4.19.160-1)
[2020-12-04T17:42:49+0100] [ALPM] upgraded linux419-nvidia-430xx (430.64-77 -> 430.64-79)
[2020-12-04T17:42:54+0100] [ALPM] upgraded lsof (4.93.2-3 -> 4.94.0-1)
[2020-12-04T17:42:54+0100] [ALPM] upgraded lutris (0.5.7.1-1 -> 0.5.8-1)
[2020-12-04T17:42:54+0100] [ALPM] upgraded manjaro-release (20.2rc-1 -> 20.2-1)
[2020-12-04T17:42:54+0100] [ALPM] upgraded mesa-vdpau (20.2.2-2 -> 20.2.3-1)
[2020-12-04T17:42:54+0100] [ALPM] upgraded nemo-fileroller (4.6.0-1.1 -> 4.8.0-2)
[2020-12-04T17:42:54+0100] [ALPM] upgraded nemo-preview (4.6.0-1.1 -> 4.8.0-2)
[2020-12-04T17:42:54+0100] [ALPM] upgraded nemo-python (4.6.0-1.1 -> 4.8.0-2)
[2020-12-04T17:42:54+0100] [ALPM] upgraded nemo-share (4.6.0-1.1 -> 4.8.0-2)
[2020-12-04T17:42:54+0100] [ALPM] upgraded nodejs (15.2.1-1 -> 15.3.0-1)
[2020-12-04T17:42:55+0100] [ALPM] upgraded opencascade (7.5.0-1 -> 7.5.0-2)
[2020-12-04T17:42:55+0100] [ALPM] upgraded opera-ffmpeg-codecs (86.0.4240.183-1 -> 86.0.4240.198-1)
[2020-12-04T17:42:55+0100] [ALPM] upgraded pix (2.4.11-1 -> 2.6.0-1)
[2020-12-04T17:42:55+0100] [ALPM] upgraded pkcs11-helper (1.26.0-2 -> 1.27.0-1)
[2020-12-04T17:42:55+0100] [ALPM] upgraded pulseaudio-bluetooth (13.99.3-1 -> 14.0-1)
[2020-12-04T17:42:55+0100] [ALPM] upgraded xorg-xprop (1.2.4-2 -> 1.2.5-1)
[2020-12-04T17:42:55+0100] [ALPM] upgraded qt5-base (5.15.1-3 -> 5.15.2-1)
[2020-12-04T17:42:55+0100] [ALPM] upgraded python-pyqt5 (5.15.1-2 -> 5.15.2-1)
[2020-12-04T17:42:55+0100] [ALPM] upgraded pulseaudio-equalizer (13.99.3-1 -> 14.0-1)
[2020-12-04T17:42:56+0100] [ALPM] upgraded pulseaudio-jack (13.99.3-1 -> 14.0-1)
[2020-12-04T17:42:56+0100] [ALPM] upgraded pulseaudio-lirc (13.99.3-1 -> 14.0-1)
[2020-12-04T17:42:56+0100] [ALPM] upgraded pulseaudio-zeroconf (13.99.3-1 -> 14.0-1)
[2020-12-04T17:42:56+0100] [ALPM] upgraded qt5-declarative (5.15.1-1 -> 5.15.2-1)
[2020-12-04T17:42:56+0100] [ALPM] upgraded qt5-multimedia (5.15.1-1 -> 5.15.2-1)
[2020-12-04T17:42:56+0100] [ALPM] upgraded qt5-styleplugins (5.0.0.20170311-24 -> 5.0.0.20170311-25)
[2020-12-04T17:42:56+0100] [ALPM] upgraded qt5-svg (5.15.1-1 -> 5.15.2-1)
[2020-12-04T17:42:56+0100] [ALPM] upgraded qt5-tools (5.15.1-2 -> 5.15.2-1)
[2020-12-04T17:42:56+0100] [ALPM] upgraded qt5-wayland (5.15.1-1 -> 5.15.2-1)
[2020-12-04T17:42:56+0100] [ALPM] upgraded qt5-websockets (5.15.1-1 -> 5.15.2-1)
[2020-12-04T17:42:56+0100] [ALPM] upgraded qt5-x11extras (5.15.1-1 -> 5.15.2-1)
[2020-12-04T17:42:58+0100] [ALPM] upgraded rust (1:1.47.0-4 -> 1:1.48.0-1)
[2020-12-04T17:42:58+0100] [ALPM] upgraded steam-manjaro (1.0.0.66-2 -> 1.0.0.67-1)
[2020-12-04T17:42:58+0100] [ALPM] upgraded system-config-printer (1.5.13-1 -> 1.5.13-3)
[2020-12-04T17:42:59+0100] [ALPM] upgraded thunderbird (78.5.0-0.1 -> 78.5.1-0.1)
[2020-12-04T17:42:59+0100] [ALPM] upgraded timeshift (20.11.1.r1.g3391f69-3 -> 20.11.1.r3.g08d0e59-2)
[2020-12-04T17:42:59+0100] [ALPM] upgraded vulkan-intel (20.2.2-2 -> 20.2.3-1)
[2020-12-04T17:42:59+0100] [ALPM] upgraded vulkan-radeon (20.2.2-2 -> 20.2.3-1)
[2020-12-04T17:43:02+0100] [ALPM] upgraded wine-staging (5.21-1 -> 5.22-1)
[2020-12-04T17:43:02+0100] [ALPM] upgraded xed (2.6.2-1 -> 2.8.0-1)
[2020-12-04T17:43:02+0100] [ALPM] upgraded xf86-video-intel (1:2.99.917+912+gad5540f6-1 -> 1:2.99.917+913+g9236c582-1)
[2020-12-04T17:43:03+0100] [ALPM] upgraded xviewer (2.6.2-1 -> 2.8.0-1)
[2020-12-04T17:43:03+0100] [ALPM] upgraded yelp-xsl (3.38.1-1 -> 3.38.2-1)

The ones that stand out to me would be libinput, cinnamon-desktop, cinnamon-settings-daemon and cinnamon-screensaver.

I guess something in there has messed up? @Mastic_Warrior mentioned that libinput updating could break something, but as this isnt a shortcut that i have ever configued OS side or even on a Linux client for that matter i dont see how it would be that unless the deafult behaviour pushed to my client was that the pause/play music key is screenshot and the next track is disabled? That sounds pretty wacky for a deafult configuration to me.

There were some udev rule changes in that new version of libinput which may have impacted how your system interprets the key input. If you run the dbus-monitor command in your terminal. does it detect the media keys being pressed and if it does what is the destination?

1 Like

Well, pressing the play/pause key that now screenshots spews forth about two full pages of stuff.

Not 100% on whats supposed to be the destination but here is what comes after the “destination” part to the next “;”

destination=:1.20 serial=4691 path=/org/cinnamon/SettingsDaemon/KeybindingHandler

I assume that this means that the cinnamon settings daemon that was also updated is to blame? :slight_smile:

Okay, that’s good to know that it is recognizing the buttons. You might need to remap the keybindings in the Cinnamon settings to get it working. Also there should be a program in the repos called Piper that lets you set keybindings on your mouse, I’m curious if that recognizes the buttons as being set to media key controls.

Piper says they are configured to be PLAYPAUSE and NEXTSONG just as they should be. Pretty cool program tbh, knows everything about my mouse and even displays the model :smiley:

Then it’s probably in the Cinnamon keybinding settings. They might have gotten unmapped in there.

Interesting. I had a libinput update on Void which broke Sway (it was saying there were no input devices detected - I start sway from a tty) and because I was lazy to look on the issue (I don’t use elogind or dbus), I used my Pi 4 8gb (with Ubuntu 20.10) for another month as my desktop (with my /home folder from my Void PC mapped via sshfs, I need my files). The Pi 4 isn’t a bad PC, but Ubuntu just drives me insane (and JWM had some tearing, like all Xorg WMs on my TV and Sway just wasn’t accepting anything I threw at it on Ubuntu, no Alacritty, no bemenu and not even dmenu was working).

In any case, I had updated to libinput 1.16.3_1(not sure what previous version I had). Wow, I sure am glad I got out of Manjaro, why is Ceph even there? Did you install it? I kinda doubt it. Manjaro just ships with so many packages - and I absolutely abhor having 1 or 2 gb of updates in one go once every 1 or 2 weeks (I prefer smooth and steady updates).

they are correct in the settings menu, i even tried setting them again to no change at all :confused:

Ceph says it was installed as a dependency for another package, ive got a bunch of stuff installed. Not entirely sure what brought it in but it didnt ship with Manjaro.

Im very happy with Manjaro, its the nicest OS i have ever used at least. Suits my needs and wants very well :slight_smile:

1 Like

Whatever works for you.

(oh, and in the end I fixed the Sway thing, I’m on my Void system at the moment, but I completely forgot what I did, but it was related to Sway).

1 Like

The RPis have come a long way. I have Pi4B 8GiB that I use as a 4 disk NAS. If Manjaro is not your taste but you want to use something like it, why no try Arch since it is the base of what Manjaro builds on?

@bananasplit_00 Seems that you issues can be related to the following packages: libxkbcommon, libxkbcommon-x11, libinput, cinnamon-settings-daemon, linux-firmware, and/or linux419 (why such an old kernel?).

So as I mentioned, there is something that has remapped those buttons. If you did not set it, someone made that decision for you and set it up as a default. These things don’t just magically work, unfortunately.

This means that there is something stored in the GTK equivalent of a registry (Like MS Windows Registry). Open up gconf as root or using sudo and drill down to that path and see what is stored there. Could be that Cinnamon updates are in conflict with that is in the registry.

Also, why are you running such an old kernel? I beleive 5.2 is the current LTS. With a new Linux-Fireware and libinput and evdev/udev, could be that there is an issue with how those event are handled and interpreted in the kernel now or the support for the new hotness has not been back ported to 4.19 yet.

Because i dont have the time to make my setup work with a newer one. Getting this config stable took ages to begin with. Hoards of graphical issues, drivers not working, other shit. Took insane amounts of trial and error of swapping kernels, graphics drivers.

Might upgrade but upgrading could also just bork my desktop until i have some time to fix it.

See now this seems reasonable, ill check that out

Since you are dealing with LTS releases, I would assume that you would run into minimal issues and also, you’re going to have to deal with it sooner or later if you intend to ever update. Running older software, especially out of date software can cause more issues in regards to stability and security. With that logic, you should not be updating your system at all or at least you should be managing and scrutinizing all updates!?

With that said, if the kernel update breaks, just revert back to the one you are using now.

I was saying this from the beginning!?

I kinda have a love-hate relationship with Arch (well, I’m kinda neutral at this point). What I want on my Pi 4 is Void Linux. I have built an aarch64-musl version for it, but it uses some Pi 3 hackeries from a Void contributor in void-mklive (Void’s ROOTFS and image building tool). The problem with it is that I can’t seem to get video acceleration at all (I tried adding both in the /boot/config file, both the kms and the fkms options, but Sway wouldn’t detect any video acceleration and would ask for kms option in boot and JWM would startx, but freeze on startup). But the good people at Void are already working for official RPi 4 support, I’m following them on GitHub.

As for Arch, I just don’t want to update everyday or every 2-3 days anymore. I’m doing Ubuntu updates on my Pi twice or three times a month. Last time I had Arch was on my work laptop and because of the best merge between software bugs and hardware issues, Arch managed to screw the ext4 file system (something related with the PC date, but the date in the BIOS was ok). I don’t remember the exact error, I had no time to waste, I had to get work done, so I wiped Arch and installed Fedora (and been using Fedora on my work laptop ever since, from Fedora 30 to now Fedora 33). I almost had Void going, but couldn’t get some stuff working in time and had no time to waste. That laptop, when I gave it to someone else with Windows on it, had countless BSODs, even after a fresh reinstall, so I know it wasn’t Arch all by itself that managed to screw the file system, but I just don’t want to go through that anymore. This could have happened with anything else really, I’m aware, but Fedora worked ok for the time I used it on that defective laptop (around 2 months before I gave it away). And I kept my mSATA SSD on another laptop, so the SSD wasn’t the issue.

Again, I remember my time with Arch on my work laptop as updating very frequently and rebooting every time after an update, just so that I’d be sure nothing got screwed up. XBPS is so much better and I’ve got all I want in the main repo (well, I wasn’t using the AUR on Arch at all, but I would have probably used it when I found out about Abduco and DVTM, which I am now very dependent on). I guess I could try Arch on my Pi 4 just for testing (I’m running Ubuntu from a 32gb SD card). Once Void is ready, I will be installing it on a 2gb SD card (the boot partition) and an USB M.2 SSD (I already had Void installed like this, boot times were on-par with my PC, around 9 sec from cold to the tty, poweroff in 3 seconds, but I just couldn’t get video acceleration and hadn’t had time nor the motivation to fix that).

Edit: the file system breakage happened after an update, after I rebooted the system.