After boot OpenSUSE black screen of death


After updating I now have a BSOD (Black screen of death) I cannot go into other terminals and other kernal snapshots (same result).

Here's a picture, the cursor is not even blinking.

OpenSUSE 42.1 LEAP
Kernel 4.1.20/4.1.15
GPU: 390X

am running leap too on one machine.
Are you certain you used an old enough snapshot to boot from, or are all showing the same result?

The only snapshots I have are the kernel 4.1.20 and 4.1.15 when booting into it. Other than that I've got nothing.

Were you using BTRFS?

No, I use ext4.

I seem to have tweaked my system to store a LOT more snapshots (also made single ones myself)

ext4 on root filesystem? thought suse uses btrfs default

@edit: do you have auto-login enabled?

I changed it from btrfs to ext4 upon installation, auto

Then I wish you very much luck

Using Snapper on EXT4 filesystem is highly discouraged.

even though you don't have auto login enabled, this might be some help, gl.

And I assume control + f4 does nothing. Correct?

No extra terminal hiding somewhere?

Yeah, I cannot access other terminals when it arrives to the bsod. Why is ext4 discouraged? Isn't it the most stable?

BTRFS still has a tendency to be easily corruptible.

And snapper will no do anything for him to begin with because he can not even get to a terminal.

sure, but btrfs is very nice because it has built in snapshots and works very well. Not as good as zfs (freeBSD is very nice to have!) but still by no means unreliable!

I would burn a live iso of opensuse to a flash drive and boot from that.

From there you could mount the drives and try to update the system again. HOPEFULLY this is nothing more than a corrupt package.

Will it work even if their encrypted? Will it ask me for the password?

I might as well reinstall it, it may be a kernel to gpu driver issue since LEAP is new

On a laptop where sudden power losses are a common occurrence, then unfortunately BTRFS is extremely unreliable. For servers running off a UPS its obviously a different story.

And snapshots are not all they are cracked up to be either. You can only use them if your computer works well enough to get to a terminal.

And lets face it. For most of us, it is easier to fix a problem using a terminal than it is to mess about with snap shots anyways.


If the drives are encrypted then that is where I would put the blame of the problem.

If the gpu drivers were an issue, they simply would not load and you could still get to a terminal.

The kernel should not be an issue because you said you tried older versions that were known to work well.

So the odd man out is the drive encryption.

Uh, I wouldn't think so, I passed both prompts and it gets stuck trying to boot after that, it may also be kde.

in the past, yes. But lately I wouldn't see its more unreliable then ext4.

doesn't the same goes for every other repair you do?!

very likely. If you can, try to somehow change the default window manager

Ok, I unplugged my other monitor (I have two plugged in) and I still get a black screen but now I have a mouse cursor...yeah, I think it's kde.

EDIT: I'm gonna try to recreated my .kde5 profile to see if it works, wish me luck.

1 Like