Return to Level1Techs.com

Adata XPG SX8200 Pro linux driver

I have this 1TB nvme drive and it’s working fine in windows 10, but it’s not recognized in any flavor of linux even RHEL. meanwhile I have intel nvme drive on the same machine which is working fine with every linux distro. any suggestions?

Have you tried passing something like “nvme_core.default_ps_max_latency_us=200” on the kernel command line, when booting up Linux? I’d just picked up one of these drives recently and was having a similar issue - On a cold boot, the Arch Linux installer would recognize that there was a drive, but the nvme controller was reporting as down and wouldn’t accept the request to change power states, and the drive then disappeared and wouldn’t show again unless I performed a cold-boot ( with a warm reboot, the controller didn’t even show under lspci ). Passing that kernel parameter caused the drive to show and appear to be functional ( am trying to test it now, to confirm that )

1 Like

Thank you, this worked for me on Ubuntu 18.04! Simply add this command to the GRUB while installing then make it permanent by editing /etc/default/grub .

1 Like