Accessing windows shares with XFCE (Mint 18.1)

So I've done some searching, and beating my head against a wall trying to get this to work. I'm nearly positive it's something I'm missing. However I thought I'd ask those more knowledgeable than myself.

I'm trying to get access to windows shares in a windows domain and in a windows work group (not on the same network). I seem to recall that XFCE doesn't have a built in samba/cifs client. Is this still the case, or has time changed things? It doesn't seem to be the case since I can't access windows shares from my install. Unless I'm doing it wrong, which if I'm honest is most likely the case.

If by some miracle I'm not doing it wrong, is there a way that I can do this with the XFCE de, or am I boned? I'm not afraid to get in and get my hands dirty with this, but at the same time my search foo is lacking in regards to this topic.

I came across this recently as well and asked questions on various forums, but no answer so far.

For me it works as expected on Xubuntu but doesn't work on the XFCE-spin of Fedora 25. Both come with XFCE but they're not the same.

I've been noticing that XFCE is not the same on all distros. Granted I understand that they all add their own spin...but should it have more or less the same feature set regardless of the underlying system?

I'm also disappointed in the complete lack of updated info out there. Everything I'm finding dates back to like Ubuntu 12.04 and a few go back to 10.04.


1 Like

I was able to get it working using the Thunar file manager. I just used "smb://" and the file path

here is a walk through:

hope it helps

EDIT: sorry realized thats how to share a file using samba not access a file

I've seen mention of Thunar, but it was all in older versions and later (more current) posts said that Thunar was out of date and/or unsupported.

I haven't read the link you provided and I full intend to give it a shot, but I am just curious if you were aware of that or not.


Well I told you it was something I was doing wrong.... Do you sir have proven me right.

I just did this method and it let me connect no problem. Just when I think I'm getting my head around Linux, something like this pops up and reminds me how far I have to go.

I tried entering that in the address bar in Fedora and hitting enter would do absolutely nothing. It was just pretending that I didn't press it.

And actually this will solve another problem that I hadn't even started looking into yet, so thank you sir!

ok going to try to redeem myself

the arch wiki says you need the gvfs, gvfs-smb and sshfs packages to access remote locations I know in my arch install I had to install those separately from the xfce4 and xfce-goodies packages.

EDIT: "smb://" should work after installing those packages just tested it

I did do some package installs before I tried the smb:// trick so maybe those had something to do with it, maybe not. I'm going to try on a fresh install and see if Mint includes all the necessary packages or not.

No worries on needing to redeem yourself. You pointed me in the right direction to begin with and unwittingly solved another issue I was contemplating but hadn't tried to tackle yet.

Glad I could help! Sometimes I feel like my life depends on the arch wiki.

1 Like


Well Arch is my ultimate goal. I just need to get a better understanding of...well everything. I had a coworker a while back who kept telling me just to dive in. I know he's right, but for my use case right now I can't. I've been running Linux on my work machine for almost a year now and love it. I've got Virtualbox running my company Windows install, and it is only used an email client and occasional windows only tasks (I'm looking at you scanpst.exe)... |>_<|
It is nice having a VM that you can bog down with tasks and still have an OS that you can use to get your work done.

I really want to try the PCIe pass through options that everyone is talking about these days for gaming, but since I sadly don't do nearly the gaming I used to...I haven't invested the time into it yet.

Arch is not nearly as scary as it looks. You should just try installing it on a VM. The exercise alone is worth it you will learn a lot. For my every day machine I now use Manjaro which is just arch without all the configuring. I still recommend for everyone interested in linux should install arch once just for the learning experience. I find rolling distros in general to be more stable for gaming and newer hardware.

I like the idea of cutting my teeth with Arch on a you know of any good guides that would be worth taking a look at to get a better feel for the process?

I find this to be the best install guide for me just read through it as you install. Feel free to Message me if you have any questions. I find the grub boot loader to be the trickiest part.

1 Like

I think Jay LaCroix had a solid beginners guide. He also has one for UEFI install. Check it here:

So watch his series and have the ArchWiki installation pages open to read while you watch.

Great learning experience and installing in a VM is not the same effect as bare metal. I strongly recommend having a second computer at hand to search with until your Arch system is up. I always shill for Arch Linux running KDE/Plasma 5 - full disclosure ;)