A real stumper (network problem)

For the past few weeks I've been having lots of problems with my wireless connection, I have been having an issue where the actual information in that my router is sending is being interrupted. This very noticeable in youtube videos and games, in youtube videos the problem will cause videos to buffer infinitely and games will act like the connection will be interrupted but will not be able to recover from it. On my android tablet (running 4.4) if I pull down the settings area on the notifications bar and look at the wifi indicator when it happens I see the downlink arrow and no uplink arrow and then it alternates to no downlink arrow and the uplink arrow is showing, this repeats a few times. (also all of this happens without the connection actually dropping). This has been going on as long as I've had the router (a few weeks).

This is really starting to get annoying, I would like a second opinion on this.

This are some of the things I've tried so far:

I have power cycled both the router and modem

I have contacted the ISP (they said that everything was functioning properly on their end)

Messed with some settings in my router.

I've tried a known good router (results are the same as the router I'm diagnosing, but the WRT54G I have has to be piggybacked on the LAN of the problem router because the WRT for some reason doesn't want to actually connect to the modem anymore)

I have change settings in my router to use a public DNS

I the last thing I haven't tried is a factory reset of my modem


If all this fail I'm probably going to send the router in for RMA and I really don't want it to reach that point, I've already RMA'd enough this quarter


This is the router I currently have:


If you guys can help me figure out WTF is wrong with my network that would be awesome

Find an android app that will scan all the available wifi hotspots. Make sure yours doesn't overlap the channels used by neighboring networks.

Sounds like the channel that your wifi that it's on, might be heavily populated.

It is not though, the router can do a site survey and all of the other networks are on completely different channels

Try doing a firmware update on your access point

Already on the latest

Does it still happen when you use a Wired connection? if not then the problem would look to me to be the WiFi adapter in the Router. Do you have a old spare router that you can configure as a Access point to test? 

I have a WRT54G that is hardwired into the trouble router and problem same problem occurs on the WRT, but the wired computer "doesn't seem" to have the problem, I will also try a third belkin router I have lying around and jack that router directly into the modem (the WRT for some reason won't work with the modem, the internet and Ethernet light flash rapidly and no internet is broadcast)

Get one of the wi-fi analyzer apps for your phone and check what channels everyone is using, make sure you're not using a channel that overlaps with anyone else (use channel 1, 6 or 11) If you're using an in-between channel which overlaps with another channel then that can cause problems. You're much better off sharing a channel with someone than using a channel which overlaps because networks on shared channels can talk to each other and manage the traffic whereas overlapping channels just cause interference. 

Try playing around with different channels anyway, I was able to improve my wireless performance but using a different channel, but stick with either 1, 6, or 11. Also have a think about other devices which might be interfering with your signal, things like microwaves and most cordless devices operate on the 2.4ghz frequency and can mess up your wireless signal.

The channel I am one in 2.4GHz is 11 and on 5GHz is 157 and no one else is on those channels, it happens on the 5GHz too