990FX does not detect sata devices

I'm using an ASUS Sabertooth 990FX R2.0 and the bios does not detect any of my sata devices. The bios shows to be the current 2501 version. After the logo splash screen I get a warning message "The current bios setting do not fully support the boot device. Press F1 to enter bios (something or other...)" I'm then instructed to tweak the CSM settings in a paragraph under the warning message. This pops up even when no device is connected. I enter the bios, enable CSM and still no luck.

I'm using a generic dvd drive and a Kingston 120gb ssd. Under Advance>sata settings menu I see no devices in the 6 listed sata ports. The data cables and power cables are connected correctly and the drives are functional. I pulled them from a working system.

Another issue is usb device detection. I've used a uefi before and I know I can use a mouse to navigate. No pointer shows up on the screen. The keyboard has a usb to ps2 adapter and works fine, but plugged in a usb port, it doesn't work. I tried a bootable usb drive and it doesn't show up in the boot options menu, as well.

I've searched the forum and found similar topics but no solutions. A replacement bios chip is on the way in case I have a corrupted one, but I would appreciate some troubleshooting advice.

Try resetting to factory defaults or pull the battery?

did this issue occured after you have updated the bios?

Did that. Pulled the battery and left out for about 30 seconds. I also used the handy cmos jumper.
No change.

And you have tested your drives in another machine - or at least can hear then spinning up? You want to rule out a PSU problem too.

The board had the 2501 bios version out of the box. I tried the flashback process with the latest version from the ASUS site and using the ASUS video tutorial as a guide. Shows the same version after booting into bios and still no sata devices detected. Funny thing, though, the LED lights up and flashes on the thumb drive during flashback but not when it's in the port while navigating the bios.

Yup. Tested the drives on another machine and the dvd drive spins when powered. I only have one PSU at the moment, so won't be able to test the board with different one.

Forgot to mention on my initial post...

The board has 6 brown sata ports that I assume are controlled by AMD's chipset. Those don't detect the drives. There are two white colored ports next to those that are controlled by asmedia controller, I believe. The drives are detected when plugged into those, but won't boot to the install disc in the dvd drive.

It's not sounding too good for that board...

If it does turn out that you do need to get a new AM3+ board to replace it check out the latest Gigabyte GA-990X-Gaming. It looks like the cheapest 990 series board with 8 power phases, M.2 and USB 3.1 costing only abit more than 970 series boards.

I hope you manage to fix it though.

Hmm thats odd the 2501 bios is not the original bios which it left the factory with.
Did you boaght it new or used?
Wenn you boaght it new, then send it back for RMA or ask for refund.

Thanks for the input guys.

Bought this thing used thinking it was a steal. Just got the replacement bios chip in. Should have the latest update, according to the seller. Gonna install and try again. I'll post the results in a day or two.

If it turns out DOA, I'll check out those Gigabyte 990FX boards. I do want to get the most of the FX 8350 I got.

Thanks again.

Is AHCI enabled or disabled in bios, if it is enabled that might be causing some problems. when I enabled it on my gigabyte it wouldn't show my sata drives

AHCI is enabled by default. Tried your tip and it worked, as far as being able to detect a device connected to the AMD chipset sata port (brown ones), but doesn't detect the boot media on the disc. I used the Asmedia ports (white ones) and the devices were detected and the boot media as well. Alas, it won't boot into a Linux live disc or a Windows install disc, it just stalls while heating up the cpu and heatsink.

I installed the new bios chip. Had the same issues. I'm sure that it's some other hardware problem because the usb ports are not detecting any devices. Either the mobo can't power off the psu or the psu is not providing the 5v. The voltage monitor on the board shows 4.904v on the rail. I know those readings should not be trusted, but it should be within tolerance. I'm confident the psu is good because I pulled it off of another working system. I'll have to test it with a multi-meter to be sure.

Now that I have two bios chips, I'll try downgrading one to a previous version and test it. Hope to be able to post new results before too long.

Thank you to all that chimed in to help. This is a great community. Troubleshooting is frustrating but satisfying when it works well.

I believe there to be more problems related to bios, hope this picture helps in disabling ACHI and setting up your sata ports. tho I am using a gigabyte board so I don't know how different the bios is.

I know i’m reviving an old thread. But just wanted to know if you were able to solve this? i have the same board. Bought used. Everything works in the bios. Sata drives are detected if I change modes to IDE in the bios. But not AHCI. But no matter what, it won’t boot anything past bios. When any USB devices are installed, (i.e. Keyboard, mouse or flash drive) the system boots up but have a black screen.

Your post exceeds the 6 period for reviving a thread. See the FAQ for more info on our guideline for bringing back a thread. Even if you are having the same problem, we ask you to make a new thread. The op of this thread hasn’t been since 2016. Since your post is 3 years after the last post. This thread is now locked.