Return to Level1Techs.com

5700xt install on linux mint

So i thought i had the card working and while i could play some games there were serious issues happening and the driver wasn’t installed correctly. When i tried to uninstall the drivers I couldn’t even boot the OS. Now I have a fresh install of Linux mint and kernel 5.3.5 and the driver is loaded and working I believe but cinnamon keeps crashing. It seems to be a permissions error. I added myself to the video group but i get this error.

screen 0 does not appear to be DRI2 capable
screen 0 does not appear to be DRI2 capable
amdgpu_device_initialize: amdgpu_get_auth (1) failed (-1)

A thread i found regarding that error found that adding DRM_RENDER_ALLOW fixed the problem. Any help would be greatly appreciated.

I have seen reported successes with the pro driver. If you’re going to follow that up please do some research on it.

That is the pro driver that is now installed.

hmmm interesting are you on FOSS or Pro? You say pro but this seems to be just amdgpu (normal driver)

Try adding the ubuntu x swat updates repository to get the latest drivers

sudo add-apt-repository ppa:oibaf/graphics-drivers

and of course the latest graphics drivers helps. Do this in init 3 and update the system. If you have pro installed uninstall it first and see if you can get the system in a working state then use that repository. It should have the latest mesa for AMD and if i were you I would stay on the latest kernel (non RC) which I think that might be.

Will do however it will take me a while to get back on because no matter how I remove the driver it means a complete reinstall because i never get the system to boot the normal install again. I’ve manged to get a command line but there is zero chance the system will boot normally on that install.

1 Like

All you need is the command line though? Why reinstall? Just erase the drivers install the stock stuff and start over?

Oh and the reason i went with the new kernel is that i was told that anything below 5.3 the driver won’t work with that kernel version. I was told i won’t be able to get any game working and that’s exactly what I found in the past week.

1 Like

Yes you want to be on that kernel. Now if you install pro… use the command line to run as admin

amdgpu-pro-uninstall

I tried that, something screws up and the system hangs before the splash screen

okay then add nomodeset at the end of your grub kernel command line so you can at least boot. also erase quiet and splash so you can see whats hanging the system.

Its usually better to fix a system with a bad graphics install rather than reinstall the whole system IMHO… its also a learning experience.

I didn’t realize I hadn’t updated. I’ll finish and reboot just to be safe and see where i’m at

1 Like

I went with the fresh install because i’ve been trying to get this going for a week and twice i did install the regular driver (that’s when it wouldn’t boot the first 2 times. I forced it into the menu to try and repair the system but it was issue after issue and i never got the window manger back. This time i’m in the window manager it’s just cinnamon that’s borked.

1 Like

Well i removed the driver and i’m ready to reboot. Let’s hope i actually boot this time.

So it says KVM: disabled by BIOS
It hung and as you said I used nomodeset and removed splash and quiet. It went by too fast to read but I’m in command line

AHHH go enable SVM or all the virtualization settings. They must be disabled in your system. Admittedly this is strange. Worst case yeah just reinstall

Guess I’m bringing back the AMDGPU news thread because of this thread lol.

1 Like

Not sure how much time I have. Kids getting off school. Here goes. I reinstalled Linux Mint Tina. I’m going to update and then install the 5.3.5 kernel and then install the amdgpu-pro driver. Let me know if that’s not how I should do it. Download takes a bit. If I run out of time I will be on later tonight.

Its probably a niche case and not worth reviving

You can always try another distro with better bleeding edge kernel support such as Fedora? if Linux mint keeps giving issues and youve exhausted all the steps here. I know it runs fine in Ubuntu so Linux Mint should be fine but IDK… try the open source drivers in that ppa first

I’ve seen 4 posts total now about the 5700 and mint ower the last 2 months. Its worth the revive just for those users alone so they can get better updates than phoronix. Esp since most mint users can’t even reset drivers without a system reset.

Yeah mint really need to work on that. I dont use it anymore. It got to annoying… I hope the OP has luck with the solution possibly

1 Like