Return to Level1Techs.com

5700 xt what's happening now in Linux

So I thought I would start a thread after searching through threads where this is talked about but not seeing one like this where people can find what’s currently happening with the card.

I’m currently running Linux mint 19.10 with the Asus reference 5700xt. it’s working well but the fan curve should probably be higher. I can run unigen benchmarks and the scores are from high 40’s fps to 220 fps in heaven benchmark. When I try to run CS:GO on steam I can play it and it’s sort of playable but lots of stuttering. There are a few people who claim to have created software to control the fan curve but I haven’t gotten any of it to work. I have a few other games I’m going to try like Oil rig which I know for sure is native Linux and will post the results when I can. Video’s play fine. Urban Terror seems to work fine fps pinned to max obviously.

Keep us posted. I haven’t had much luck on my system either but I haven’t had a lot of time to fiddle with stuff

So far no luck at all with Linux mint. It did seem to sort of function if you just installed it on the regular kernel but not well. No games function properly. Always jittery and tearing. I also found out since I have used Linux exclusively for years that after trying to install windows 10 for a dual boot for a few games the kids like that windows 10 will not install on a sata or NVME SSD because the USB install cannot handle them. I get a message that I need a driver and it won’t install. So much for windows is easier, I’ve never once in my life had a Linux install USB fail to install.

For the windows thing make sure you are booting uefi and SATA is in ahci and not raid mode.currently majnaro works reasonably well if you get the bleeding edge mesa but it’s still a bit fiddly

Checked windows will not install. Asks for the driver and no option to download one. Doesn’t even tell you the hardware the driver is needed for just gimme a driver or get lost.

By the way I’m willing to bet that is why companies are shipping drivers with hardware.

As Wendell said, on Arch it does work and on Manjaro too BUT you have to figure out a way to get Manjaro installed first and update it. The ISO (I tested the latest KDE-version) does not boot with the 5700 XT but if you have Manjaro installed already and you boot into a non-graphical environment (boot parameter 3 gets you into a console) and you update all the software then the 5700 XT will work fine. Or at least as fine as it is out of the box, in my case it needs a lot of tuning.

1 Like

kernel 5.3.x is available in the fedora 30 updates repo as of today… maybe it’ll work…

but i have noticed that gnome shell uses a ton of CPU after booting… 25%-60% ( on my 3700x)

A little correction on my latest post, yesterday they released a new version of Manjaro with all the required updates. Well done, Manjaro guys. However, there still are some software issues on Manjaro for gaming. Rise of the Tomb Raider won’t start (I did a new install after installing this graphics card) and somehow Starcraft2 got broken. Hitman Absolution also won’t start but that might not be officially supported yet by Steam (Proton). I love Manjaro for regular desktop usage but I strongly consider to give Debian a shot because you get closer to the source with your gaming software.

1 Like

With the 5700XT? That’d be interesting to read. Would you consider keepin us updated?

I might be really dumb but couldn’t even make a graphics card work with Debian, said it was missing firmware or something… gave it 30 minutes jumping through forums and the sort, trying out stuff on TTY but didn’t work.

Consider the unofficial ISO with non-free stuff built in (guess that’s how it’s called).

I wasn’t talking about the GPU but about the software which Steam uses, Valve only supports Debian so other non-Debian-based distros have to put in extra work to get certain games to run. Something with the environment.

I have had a few examples of games which simply don’t run on Manjaro or are broken while I had no issue on Ubuntu. Two examples are Borderlands2 which crashes fast and Rise of the Tomb Raider which won’t even start. This with 3 combinations of hardware for BL2 (i5-750 + HD 7850, 3700X + HD 7850 and 3700X + 5700 XT). Another example is that after some update of Debian (and the following update of Steam) all of the sudden the in-Steam-browser was broken. I like both the Arch-base and the Debian base because both have roughly the same extensive software-repositories and yes, I would try the ‘unstable’ branch of Debian, or maybe popOS though I some issues with Ubuntu (I hate Snap).

What is going on with the 5700 XT is just a matter of when the distros upgrade certain packages in their repo’s. Here a part of a post from the Manjaro forum

The stable branch of Debian just runs behind way too much but once the less stable branch of Debian has updated this software then it might be interesting to try it out but that is offtopic for here.

1 Like

Have you tried Fedora? I’ve noticed no difference between Deb distros and Fedora with steam.

Definitely go with Debian’s unoffical ISO, it should be the official ISO, I love how Debian claims it’s for “awkward hardware”, ya because wifi adapters in a generic laptop or a mainstream graphics card is “awkward hardware”. It’s only because the firmware is proprietary nothing more.

Which is fine I respect Debian’s integrity, but the claim of “awkward hardware”, is dishonest.