5 gHz wifi not showing?


Recently my Asus USB-n53 wifi adapter has not been able to find my 5 gHz network.

I clearly remember using it a while back, and now it's not even showing. I've tried updating the drivers, as per other pages' suggestion. But the problem remains.

Can anyone help, or have been able to figure out the problem?


Thanks in advance.

Did you install drivers?

Does your Router have 5Ghz? and is it on/enabled/configured. Also 5Ghz and 2.4 will be separate radios in the AP/Router. Its possible the 5Ghz radio could have locked up/shutdown and its just doing 2.4. If your router has 5Ghz i would give it a power cycle. Note that the range on 5Ghz is not very far and sometimes will not make it out of a room with good signal. 

Thanks for the replies.


First - Yes the drivers are up to date, according to Asus' own page. Even tried the chipset drivers for the adapter as is stated to be a solution on another page. Neither helps.

Second - Both my router and the adapter clearly supports 5gHz, and the router even shows the network as being broadcast. My phone finds the network just fine. But as Xcomm states, I'll try moving my PC closer.


If your phone shows it does it show it when in the same room as the Computer that does not? Whats the signal like in that room on your phone. If the phone can see it in the same room with a good signal then I would think it should work. Is this in a back port on a desktop in a cabinet or anything strange like that?

OK, during the hollidays i formated the PC and tried moving it around. (Updated to windows 8.1 in the meantime.)

My phone shows the 5GHz network everywhere in my apparment, even where the PC is, but the PC wont show the network. The adapter is sitting in the back of the PC, and I've tried moving it to the front, but same results.

As far as I can recall, i've used the network on the PC normally is, but only recently lost the option for the 5GHz network.

I've checked to make sure the 5GHz is an option for the USB adapter, as per Asus' own page:

And all drivers is up to date, according to Asus and windows.