4k monitor split in two with Ubuntu

Hello, back again with another problem. I've gotten the Nvidia drivers to work, now my 4k monitor is showing up as two displays. Can someone help me?

I'm about to try the ultra-wide 4K with Ubuntu... I'll let you know if I have similar issues. Here is some interesting info. I'll try some of these and let you know. Do the same if you have time:

You should be happy about that. According to this incredible and amazing article over on Tom's, that feature is something that you should want, for whatever reason. Just learn to love it!



FYI, I just got two 4k Eizos, plugged them in to an OpenSuSE Factory loaded workstation with dual AMD FP graphics, and it just worked out of the box. You really should look at those Eizo's, I think they look amazing, and they're not that expensive for factory calibrated 4k displays. Maybe something for the Tek Enterprise channel to do a review on?

Thanks again @Logan, I checked out this article a bit ago and I ran into a few problems. I had to generate my own xorg.conf and I guess it didn't work properly, so no matter what I did to it nothing changes. Does the xorg.conf file have to be in a certain place to work?

/etc/X11, You will have to do stuff as root to get it in there since that's a system file.


For everyone who's a little curious about technical backgroud to this issue:

It gives you great insight about MST and 4k monitors. For everyone else tl;dr
Update to a newer kernel then 3.17, this solves some problem.

Here a presentation, a bit funny and even more insight:

Hey @Logan sorry to bother you, but did you ever get around to testing that 4k monitor with ubuntu?


Agree that would be a very interesting topic. +1