Return to Level1Techs.com

4K + HDR Capture Options

It depends on the EDID the source device picks up. If it only picks up the capture card, it will refuse to output above 30p, so your display also gets 30p.

This is why a splitter with EDID management is so important.

Hm right… forgot you probably wouldn’t be able to input 4K60 in the first place… unless using a splitter that always uses the TV’s EDID… but even then, still don’t know what the Decklinks would do :confused:

Man this is really frustrating :smiley:

Might just send a mail to Blackmagic support at some point, they should know what happens :slight_smile:

The only card guaranteed to work from Blackmagic is the 4 input only Decklink Quad HDMI. That’s it. Even then you need a HDMI splitter with EDID management. And the current Blackmagic solutions all do not Tonemap.

1 Like

Yeah, that card is also slightly on the pricey side :slight_smile:

Do you (or anyone else) have any videos around to demo the issue? I’d like to know how noticeable it is and whether it might be worth just getting a USB card now and waiting until other (i.e. cheaper) Linux options arrive for the use case.
Or did I misunderstand and the issue aren’t the recordings, but the devices handling of the signal?

It’s that some devices try to tonemap in real-time using THEIR Lookup Table (LUT) with no flexibility, or some just capture washed out HDR to SDR conversions and you have to use OBS filters to add a Lookup Table. (which is more computationally expensive, requiring a really good GPU)

The Ninja V allows you to process a LUT using dedicated hardware and downscale at the same time to ease the strain on the destination computer. And you can still record full resolution in the Ninja.

I realise how good those devices are but I can’t justify the cost for something I will hardly use :stuck_out_tongue:

Was just wondering if anyone had any examples of the frame rate issue :smiley:

Well, I know EposVox won’t explore it, but I could try to make a video about it when I’m better. Currently pretty down in the pits though.

1 Like

That would be cool :slight_smile:
Don’t worry it’s not urgent, this thread was mainly just to explore options and understanding :smiley:

So… I just wanted to give some feedback as to what resulted from this, in case anyone else stumbles on this when debating over the same issue.

So I ordered the AverMedia Live Gamer Ultra (GC553) about 6 weeks ago, and want to share my experiences.

TL;DR: It works well, with some caveats.


Note: Everything below applies to Linux, I have not extensively tested it on Windows, but on Windows the Audio was essentially unusable because it was constantly cutting out and/or desyncing (unrelated to the video resolution too, so it is not a bandwidth issue). One video I saw attributed it to the AMD/ASMedia USB Chips on AMD boards, but since it is working perfectly fine on Linux, this is most likely a driver bug in Windows. If you’re on Windows you’re most likely better of getting the Live Gamer 4K (GC573) anyway.

Initially I had some issues getting it to run at all. On first use it would display an image of the actual capture, then it would not display anything at all or throw me a “Resize not supported for this resolution” error (that EposVox also mentioned in his video), although that might have been a setting because it hasn’t happened since.
I then booted into Windows to do a firmware upgrade (even though it had to be manufactured recently because it was sold out everywhere previously, there was actually an update from a few months ago … ???), which unfortunately did not resolve the issue.

Thinking that the UVC driver might just not be up to date enough on Fedora (which I sort of doubted considering the device has been out for quite some time), I booted into a Manjaro minimal Live USB and the device magically worked on the testing application (V4L2 Test Bench), but not all the time.

Eventually I figured out what the issue was, and it turns out to be (probably) a UVC driver bug (or Kernel? I don’t know, doesn’t matter) that will not let the device re-engage with changed settings until the OS is rebooted.

Essentially, once a capture has been initialised you cannot change any capture settings. If you do, you will receive a blank screen and will have to reboot the OS. The same applies to restarting the capture software, the driver(?) cannot re-engage the device a second time.

What you will have to do is setup your capture settings, while doing so you will most likely not see any image however because the capture was probably already started with the default settings (OBS does that for example). You’d then have to re-boot, and see if your settings worked. Since I already figured out my settings in the live-boot I only had to restart once, but YMMV.

As for settings, not all the video modes are supported. These are the settings I used and they are working fine so far (in OBS too of course):

Note that BGR only supports 1080p (or lower) output, so capturing 4K is not an option. I tried a few of the other capture formats but they gave me fun looking images like this. I did not try all of them however.

If capturing 4K matters to you, you’re out of luck until there is better support for the capture formats. Capturing HDR is also only available using RECentral, so it is Windows exclusive as well and also requires an Nvidia GPU as of this writing.

As for image quality I can’t complain. The HDR tonemapping seems to be working fine, although looking at other streams of the same games it does not result in the same image as an SDR capture (I have not done any comparisons of HDR tonemapped vs SDR yet). That doesn’t mean it’s looking bad, just different then other streams I’ve seen. To get an idea of how it looks, you can see it here.

I haven’t noticed any frame-rate related issues (as described in the posts above) either, so either the device or OBS is doing something regarding that. Or maybe the PS4 Pro is outputting actual 60 Hz and not 59,97 Hz.

Also one note, and I don’t know how common that is since I didn’t expect it: Even for the pass-through to work it needs a USB connection. There seems to be no passive pass-through. If the card isn’t getting power, you will get no image on your output. There is also a small fan inside that has a pretty quiet humming, that shouldn’t be noticeable during gameplay where you have sound anyway.