3TB drive showing as 801.5GB in BIOS

Hello everyone!

I know this issue is somewhat common and there are many fixes over the internet for it. But none worked for me and i do think my case is different than those i've found online. Well, here's the thing. I just bought a 3TB Seagate Barracuda XT to use as a storage unit only ( Windows boots from an SSD). My motherboard is an Asus Sabertooth Z77. When i first set up the drive it showed in the bios as an 801.5GB unit and i thought this could be normal and later when id format it using windows it would show the full 3tb. However when i got to disk manager, Windows only recognized a 746GB drive. So i started googling. I found out that many people have this same issue. But normaly, in those cases, when you get to the disk manager there is a 2.7tb disk that you can only allocate 2TB and the remaining 746GB stay unused thanks to some partition limitation. So to solve this problem you must change your disk to a GPT type and it should work. However in my case, when i change the disk to GPT, the drive capacity actually shrinks to ~733GB. I've tried installing seagate disk manager, intel RST and other software solutions but nothing worked. So i began to think that the problem was something to do with the BIOS/motherboard since all these fixes show a striped 2.7TB in windows and not only a 746GB drive . Plus, they always say that your BIOS has to correctly recognize the drive first, which is not happening here. So i tried updating the BIOS, i changed every combination of settings in the bios regarding boot, SATA configuration (i enabled all UEFI settings, SATA behavior, secure boot, turned on/off the legacy boot) and even tested the disk in every sata port available in my motherboard (there are two storage controllers in this motherboard) . Nothing worked, the drive still showed up as a 801.5GB drive. So, basically, i ran out of ideas. Any help is deeply appreciated! Thanks!


Are you running windows XP?  I didn't think XP supported GPT.  

No, i'm running Windows 8.1 64 bit. This disk unlocker installer says it has no support for the Z77 chipset :( . But as i said, dont you guys think that this issue is something in the bios or the motherboard? Since it is not recognizing it since the BIOS? Another thing. Is possible that this is a problem in the drive? Only this 800Gb are funcional?

This is interesting to me, I just sent a 3TB Seagate Barracuda drive back for RMA for the same issue. But with mine, my mac only saw it as 800GB as well and could not format it with either the Mac OS or Windows 8.1