3700x active wraith fan

Does anyone have a fix for this in ubuntu?

I had a similar issue with a 1600/stock fan… I think i switched the cpu fan lead over to pump fan power and set a more reasonable curve in bios.

Did it stop the ramping cycle? I set mine to silent and it has done nothing

To solve this issue you can go into the BIOS and set up a curve that below 55-60°C keeps the fan at steady RPMs. Past 60°C you can have it ramp up normally. This solves the issue of Ryzen aggressively boosting and making the fan ramp up and down continuously.

Do ou track the thermals on the desktop with lm-sensors or something?

I’m on Windows so I used HWiNFO64, but sure you can use lm-sensors on Linux

Yeah. I couldn’t (at least easily) get control of the cpu fan so used a different header. And yes, monitor temps, maybe stress test for worst possible scenario to make sure your settings are adequate. I ended up buying a better, much quieter cooler - pretty happy with the fuma 2 - nearly silent.

I don’t know - i think something is up.

My son was playing trine (full Bore) and the computer shutdown. Everytime I turn a webpage the fan fires on. I wonder if i mucked the thermopaste. i assembled it in the tower so it was a little Janky.

The heat pipes aren’t even warm to the touch.

There is no way this system should be overloaded.

How do you change tha actual curve in the bios? I the data points are fixed.

Most of the time my cpu is <20% usage.

It sounds like you should start with monitoring temps to see where you’re at? If you happen to be using gnome, Freon is a great shell extension that adds temp voltage and fan rpm monitoring to the top bar.

For setting fan curves maybe look for vids or tutorials using your motherboard/bios.

Thanks for the advice, Freon is broken on 20.04


gnome extensions suuuuuck - i’ve installed lm-sensors and it doesn’t work on the CPU.

Try hardinfo

seams to idle at 16.8C (acpitz) )no matter what. i don’t know if its the sensor

65°C was the magic number, then ramped to 85°[email protected]% (lineally). set alarm for 90°C. A reddit thread said that the sensors where being triggered by intermediate temperature spikes.

And then i found this:

1 Like

Exactly, the CPU spikes up constantly and a cooler can’t soak that temperature spike immediatly so, if the fan is set up just linearly you get that annoying ramp up and down constantly.

Glad you solved the issue!

Ya I’m jumping in and out, slowly dragging down the 60% fan speed. I’m at 50% and seem to be handling it well.

Thanks for the advice - greatly appreciated

1 Like

You can also try to set the curve for other fans to improve the temperatures. For example, if you have a fan on the back and/or the top you can turn the lowest speed up enough so that they don’t make more noise compared to the CPU cooler but aid in the cooling significantly.

I’ve written a full sheet of paper with different fan speeds and temperature thresholds for all the fans in my system until I found a combination that acustically please me and don’t cook the system.

Another suggestion: take note of the settings on paper or save them as a profile into the BIOS so that if you ever need to reset it you can re-load the settings and be good to go.

That was my thought as well. I need to look at and understand push pull configs.

1 Like