Return to Level1Techs.com

32 bit Windows 10 ISO is not recognised on i686 KVM-QEMU VM

linux
helpdesk

#1

How do I tag this as #helpdesk

host: on opensuse tumbleweed.

Trying to create a VM via a KVM hypervisor with qemu. Install stops with no boot device found error. or if the connection types (SCSI? SATA etc) are messed with it enters into a bootloop with a splashscreen showing.

The ugly? Same ISO starts to install on an x86_64 VM.

here is what I have tried: Boot menu: enabled, CD -Rom enabled, ISO connected.
SCSI, IDE and SATA connection types were all tried.

to no avail.
Do you have any ideas? Thanks


#2

I added the tags for you.

Sounds like its a multi-image, one that contains both the 32 and 64 bit versions.

Question: why 32 bit?


#3

thank you !

MS offers different images for 32-bit an 64 bit systems. I would like to stick to 32 bits because this is an ivy bridge laptop with 8 GBs of ram which wasn’t enough for a 64bit VM in virtualbox.


#4

4 GiB of RAM is plenty for a 64 bit windows VM.


#5

allocated or total?


#6

When you create your VM only give it 4 GiB.

Virtual machines will hog all the ram the give them, it isn’t shared back into the host system, so it will show up on your end as “fully allocated”, when its actually not.


#7

ok, install is ongoing. 2 logical cores and 4 gbs allocated to the VM… youtube cannot maintain continuous playback. we will see how it goes


#8

From within the browser on the host? Browsers these days really do use way too much ram.

Also if you’re on the same hard drive, then you’re going to have a bunch of file/io and it will be a pain to use.

I suppose an intro of what you are trying to accomplish explicitly with the current hardware would’ve been helpful. Like, I want to use this box for development, small low-resources games from 2012, etc.


#9

Ivy Bridge Laptop, 2 cores, VM. That’s why youtube can’t maintain playback. You’ve very likely allocated all your physical cores to the laptop and it’s hogging them. Your laptop is then unable to use the 100% cpu (1 single core) that it needs to maintain steady playback. If you wait for the VM to not be doing anything intensive, you’ll be much better off.


#10

All the physical cores? as in the two logical cores assigned to the VM were on different physical cores?


#11

I’m operating under the assumption that you’re using a laptop with 2 physical cores. probably dual core, with SMT. So, yes. each logical core assigned to a VM will default to a different physical core on the laptop.

Keep in mind that unless you specify host-passthrough on your QEMU CPU type, QEMU will spend CPU time translating instructions in realtime from whatever CPU model is specified, to instructions that are compatible with your CPU. That may also be eating up extra CPU time.


#12

most certainly. Haswell, the rest was dead on. I am not at the point of attempting to set up passthrough for this VM. Samba is giving me enough headache already :slight_smile:

thank you