Return to Level1Techs.com

2200G and 2400G non-bootable under Linux


#21

Fair enough, I knew this somewhere in the back of my head.

I guess I would say I’m thinking more along the lines of listing software compatibility which shouldn’t be the hardware vendor’s responsibility, they (in this case) provide the architecture for developers to utilize, yes?

Maybe I don’t know enough about these interactions though and should shut up :joy: (more of an opinion than knowledge).


#22

By no means does AMD HAVE to support Linux or OSX or Windows for that matter at all. It sucks that they don’t but nothing more. They do have to (legally speaking) to say if it doesn’t support something when it is generally assumed that it does. If they had mentioned anywhere that it does not support Linux I would have at the very least waited. From a legal standpoint it’s not different than it not being supported on Windows. They don’t explicitly state it does support Windows but it’s assumed and for good reason.

Linux devs not fixing this issue is unfortunate but you can’t really blame them. AMD not working with them is pretty bad and the motherboard BIOS is is in bad state too so it’s likely that they rushed it. Again annoying and a bad way to treat customers but certainly not worse than any other company in this area. My biggest issue was what I see as false advertisement.


#23

I did link to the article saying that it is the exact issue I am having. In the article the issue is explained quite well, didn’t see much point in re posting same info.

When I say freeze I mean completely unresponsive (I mentioned no SSH possible). No keyboard, screen frozen at last image, power button has no effect, no connection to network. The journalctl log simply cuts off so not much troubleshooting possible. Will have to try the first command you listed and 4.16 tomorrow.


#24

I updated to Fedora 27 and there is a change. Kernel 4.15 now has booted at least once but the screen is divided in half and duplicated. The really odd thing is that screenfetch command in ssh that is setup to run on login is also executed twice, can’t imagine how that’s related to the screen being duplicated. This is very similar to what I got with 4.14.3 kernel (fedora 26) before. It still crashed after 10 min but it did not freeze like before but instead rebooted. That’s some progress, will continue troubleshooting tomorrow and report back.


Bought a Ryzen 5 2400G. need best non-bank breaking motherboard/ram combo for Media server
#25

For what it’s worth I’ve been going through a lot of headache and resting too. The stability seems very very board related now too. Try disabling power managmwnr, gear down mode on gugabyte boards, svm, and all forms of power maanagement. The MSI b350 and ASrock x370/b350 boards have been most stable. The Taichi from ASrock seems more stable. No real.gpu support tho.

Have you tried nomodeset to keep a text mode terminal?


#26

Glad to hear I am not alone. Will try disabling BIOS settings tomorrow, SVM was definitely enabled. I may try the Asrock Beta BIOS too while I am at it too. I was actually able to playback video on Kodi since upgrade to Fedora 27 but screen is still split in half and messed up. Resolution was fixed to 1080p (should be 4k) and refresh rate was 60 which is a lot better than what it was before.

I did add GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset" but it made no difference on f26 with 4.14 or 4.15 kernels. Will need to double check grub applied it or that the upgrade didn’t reset it to defaults.


#27

4.5 Beta BIOS seems to be faulty, after changing few common settings I got no video out at all not even anything before boot loader, just an active but blank screen. It happened on 2 separate occasion (after BIOS reset) with 5+ attempted power cycles. With default BIOS settings kernel 4.15 freezes, now with blank screen instead of frozen frame. 4.14 works as before until it freezes at some point.

I confirmed that nomodset is applied, with no apparent effect. Will have to try changing settings one by one tomorrow or downgrade to 4.4 BIOS if issue persists.


#28

Did some more testing, here are the results. This is with nomodset option.

4.5 Beta BIOS with default settings:

  • 4.15 kernel freezes on boot.
  • 4.14 boots with periodic freezes later.
  • Disabling SMT bricks the system (no display whatsoever) - clear CMOS brings it back.
  • Changing other advanced ZEN options also bricks the system.

4.4 “Stable” BIOS:

  • (4.15 kernel) Boots with periodic freezes later and screen split in half.
  • (4.15 kernel) Disabling SMT causes kernel panic.
  • (4.15 kernel) Disabling Cool n Quiet causes system freeze at boot.

Some errors from dmesg in case it offers clues:

[    0.000000] ACPI Error: [SMIC] Namespace lookup failure, AE_ALREADY_EXISTS (20170831/dswload-378)
[    0.000000] ACPI Exception: AE_ALREADY_EXISTS, During name lookup/catalog (20170831/psobject-252)
[    0.000000] ACPI Exception: AE_ALREADY_EXISTS, (SSDT:  AMD PT) while loading table (20170831/tbxfload-228)
[    0.000000] ACPI Error: 1 table load failures, 7 successful (20170831/tbxfload-246)

......

[    0.044307] ACPI Error: [PTOS] Namespace lookup failure, AE_NOT_FOUND (20170831/psargs-364)
[    0.044313] ACPI Error: Method parse/execution failed \, AE_NOT_FOUND (20170831/psparse-550)

.......

[    0.376308] AMD-Vi: Unable to write to IOMMU perf counter.
[    0.376412] pci 0000:00:00.2: can't derive routing for PCI INT A
[    0.376413] pci 0000:00:00.2: PCI INT A: not connected

.......


[   10.460799] [drm:generic_reg_wait [amdgpu]] *ERROR* REG_WAIT timeout 1us * 100 tries - tgn10_lock line:566


........


[   11.573295] drm (null): uevent: failed to send synthetic uevent

........


[   11.787861] sp5100_tco: I/O address 0x0cd6 already in use

#29

The expectations…

Waited 6+ months to get a goddamn desktop displayed in linux with vega, and all the threads popping up with "help help no linux support with my brandnew vega laptop/apu…


#30

Damn, I assumed Vega worked just fine on Linux. I have been running Vega 56 since release but that’s GPU passthrough under Windows…


#31

In general it seems to. I do not own Vega nor run Linux, but the reports seem good though some tinkering is involved sometimes.

It is a lot better over all than it used to be but everything is going through a rewrite right now and people always what everything yesterday so something has go to give.

TL;DR: Vega does work for the most part, some people will never be happy.


#32

Vega working fine, not exactly. It displays a desktop, that doesn’t mean it works great, yet anyway (remember that 4.15 was a massive overhaul on the AMD side and still lacks freesync support among other things)

So more like still in the stage of getting proper support. Newest stable kernel 4.15.8 released friday, kernel 4.16 still experimental

Changes:
https://www.phoronix.com/scan.php?page=news_item&px=Linux-4.15-Changes-Week-One

If anyone wants an idea of how long it took for kernel 4.15 to get released and why:

(for those that don’t, supposedly it got a ninth release candidate)

TLD;DR: The Linux 4.15 Kernel - Half Million New Lines Of Code So Far


#33

To be fair “works for the most part” after 6 months is hardly anything to be happy about. Lets not forget it worked on Windows on day 1 with only minor bugs.


#34

This is why you buy last years hardware, by that time the bugs are out and you have support as soon as you put it together.


#35

Or just use Windows. This is why Windows is in a dominant position despite all the BS that comes with it.


#36

The thread is about Linux support and maybe back down a bit on the virtue signaling


#37

Linux is an OS so I think it fair to draw comparisons between the two. I don’t think it fair to justify something in Linux ignoring everything else. Not sure what you mean by virtue signaling.


#38

Fair, justify, what? It’s fair to draw comparisons?

A gratis/free/open source operating system which everyone can contribute to and modify and a million other things

Compared with

Proprietary operating systems which allows none of the above and that profile’s its users, turns them into products, sells their information and on top of that owns most of the planets computers, because you only get a license, ms owns your machine.

A fair comparison? please It’s not, even remotely comparable

Support takes time, in linux even sometimes in ms10 (proper support anyway) The problem i see with Linux is for example with the 4.15 kernel which provides entry vega support, is that when it’s available and in mainline stable, they might aswell build and release it. Instead they start arguing and ask their users to do it instead…

Thats like i go over to someone and tell them i know a fix for their laptop, a ram replacement. Though there is a catch. You have to do the fix yourself, now who in their right mind (who has no experience with computer internals) would actually go SURE! lemme have at it?

Answer is, if your a goddamn expert in your field and many linux users are, you should probably just make the goddamn build, instead of arguing about it. So users can USE your distrobution, instead of asking users that came to your distrobution, in the first place because of ease of use and beginner friendliness.


#39

Just because it’s Free/open-source does not turn it into something entirely different. It is fundamentally different but so is an electric car compared to petrol car yet it is compared to petrol because it does the same thing. Linux still an OS and is used as such. Libre Office is constantly compared to MS Office because they do the same thing. Things should be evaluated based on their merits. Linux has advantages such as being free, or having a sane update process same way Windows has advantages and disadvantages like you stated. For the record I am not a fan of Windows but it’s just not avoidable in many cases.


#40

Replace not avoidable with = Forced. Because that’s what it actually is. Just because it isn’t talked about in that way, (Why not ???) does make it otherwise. That’s exactly what it is…

The talks about it makes it sound like there is a choice to be made, when technologies are locked down and or even sabotages the opposition actively. Which i assure you, i can absolutely bombard you with that information.

You can’t compare with that analogy. There are billions upon billions invested in ms, than there is in Linux. Where money goes, most of the “support” goes also. So comparing day1 support, regarding hardware for both, doesn’t exactly make much sense…

So you’re basically comparing a porsche 2018 model with AI to a volkswagen with a ham radio